LINUX.ORG.RU

RewriteCond %{REQUEST_URI} ^(.*)//(.*)$
RewriteRule . %1/%2 [R=301,L]

это редирект. думаю, для 404, ежели оно действительно надо переделаешь.

iSage ★★★★ ()
Ответ на: комментарий от iSage

Кстати, неоднократно были случаи, когда эта проблема не решалась таким образом.

1) Набираешь в браузере http://domain.ru//dir1/dir2.html
2) Смотришь какие заголовки передаются -

GET //dir1/dir2.html
host: domain.ru
...

3) Выводишь переменную окружения REQUEST_URI

/dir1/dir2.html

Чудеса в .htaccess тоже, само-сабой, не работают

r_asian ★☆☆ ()
Ответ на: комментарий от r_asian

а нгникса случаем фронтэндом не стоит? а то он слеши склеивает по дефолту. вот чтоб апач вдруг склеивать начал как-то не попадалось.

iSage ★★★★ ()
Ответ на: комментарий от iSage

ежели оно действительно надо

Ок, спасибо. Надо, но не мне, я давно вебом не занимался.

Droid790 ()
Ответ на: комментарий от iSage

Насколько я понял, у людей вообще какой-то совершенно примитивный сайт без php и т.п., просто apache и статические страницы и картинки, сайт-визитка. Говорят, что такие двойные слэши портят поисковую статистику, вроде. То есть сейчас при таком двойном слэше ответ сервера 200 OK. А должно быть 404.

Droid790 ()

Попробовал сейчас на своём тестовом апаче в виртуалке:

user@ubuntu9:/var/www/site$ ls index.html sub

user@ubuntu9:/var/www/site$ cat .htaccess Options +FollowSymLinks RewriteEngine On

RewriteCond %{REQUEST_URI} ^(.*)//(.*)$ RewriteRule . %1/%2 [R=301,L]

http://127.0.0.1/site//sub/

Ничего не происходит со слэшами.

Droid790 ()
Ответ на: комментарий от Droid790

А, вроде получилось, да. Забыл сконфигурировать, чтобы .htaccess подхватывался.

Droid790 ()
Ответ на: комментарий от Droid790

>Говорят, что такие двойные слэши портят поисковую статистику, вроде.

Кстати полный бред. Раскрутчиков надо нафиг посылать с такими разговорами. Лично сталкивался.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.