LINUX.ORG.RU

Как установить aiohttp?

 , , ,


0

1

У меня какая-то дичь творится с PIP. Кажется, я его правильно установил, но проблема в том, что не получается установить модуль aiohttp. Вот что пишет консоль:

md@md /var/lib $ sudo apt-get install python3-pip
sudo: /var/lib/sudo writable by non-owner (040777), should be mode 0700
[sudo] password for md: 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  python-colorama python-distlib python-html5lib
Для их удаления используйте «apt-get autoremove».
Рекомендуемые пакеты:
  python3-wheel
Следующие НОВЫЕ пакеты будут установлены:
  python3-pip
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 24 пакетов не обновлено.
Необходимо скачать 0 B/80,3 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 447 kB.
Выбор ранее не выбранного пакета python3-pip.
(Чтение базы данных … на данный момент установлено 211733 файла и каталога.)
Preparing to unpack …/python3-pip_1.5.4-1ubuntu4_all.deb ...
Unpacking python3-pip (1.5.4-1ubuntu4) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Настраивается пакет python3-pip (1.5.4-1ubuntu4) …
md@md /var/lib $ pip --version
bash: /usr/bin/pip: No such file or directory
md@md /var/lib $ pip3 --version
pip 1.5.4 from /usr/lib/python3/dist-packages (python 3.4)
md@md /var/lib $ python -m pip install aiohttp
Traceback (most recent call last):
  File "/usr/lib/python3.7/runpy.py", line 183, in _run_module_as_main
    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
  File "/usr/lib/python3.7/runpy.py", line 142, in _get_module_details
    return _get_module_details(pkg_main_name, error)
  File "/usr/lib/python3.7/runpy.py", line 109, in _get_module_details
    __import__(pkg_name)
  File "/usr/lib/python3/dist-packages/pip/__init__.py", line 59, in <module>
    from pip.log import logger
  File "/usr/lib/python3/dist-packages/pip/log.py", line 9, in <module>
    import colorama, pkg_resources
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 668, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 638, in _load_backward_compatible
  File "/usr/share/python-wheels/setuptools-3.3-py2.py3-none-any.whl/pkg_resources.py", line 1479, in <module>
    register_loader_type(importlib_bootstrap.SourceFileLoader, DefaultProvider)
AttributeError: module 'importlib._bootstrap' has no attribute 'SourceFileLoader'
md@md /var/lib $ python --version
Python 3.7.0
md@md /var/lib $ python3 --version
Python 3.4.3
md@md /var/lib $ 

Помогите пожалуйста советом

Ответ на: комментарий от foozzi

я понимаю, что прошу телепатию. но не получается и так: https://pastebin.com/aE5xHxSh

возможно, у меня система засрана. я думал, на venv это не должно влиять.

но такое чувство, что venv не включился. я так думаю потому что внутри venv используется python2: https://i.yapx.ru/FuYRC.png

prozaik ()