LINUX.ORG.RU

Странный Gem Load Error

 ,


0

1

Пытаюсь поставить gitlab, а оно мне ошибку куча бинарщины, которую лор не даёт запостить, ибо is not a legal XML character. Как это вообще понимать?

Gentoo, ruby-2.3.1.

UPD: Да, hardened. Workaround: paxctl -m /usr/bin/ruby*

rake aborted!
Bundler::GemRequireError: There was an error while trying to load the gem 'sys-filesystem'.
Gem Load Error is: <та же куча>
Backtrace for gem load error is:
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/ffi-1.9.10/lib/ffi/library.rb:263:in `attach'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/ffi-1.9.10/lib/ffi/library.rb:263:in `attach_function'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:13:in `<module:Functions>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:5:in `<class:Filesystem>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:4:in `<module:Sys>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:3:in `<top (required)>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem.rb:3:in `require_relative'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem.rb:3:in `<top (required)>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/filesystem.rb:11:in `require_relative'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys/filesystem.rb:11:in `<top (required)>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys-filesystem.rb:1:in `require_relative'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/sys-filesystem-1.1.6/lib/sys-filesystem.rb:1:in `<top (required)>'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:86:in `require'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:86:in `block (2 levels) in require'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:81:in `each'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:81:in `block in require'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:70:in `each'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:70:in `require'
/usr/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler.rb:102:in `require'
/home/git/gitlab/config/application.rb:5:in `<top (required)>'
/home/git/gitlab/Rakefile:5:in `require'
/home/git/gitlab/Rakefile:5:in `<top (required)>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/rake_module.rb:28:in `load'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/rake_module.rb:28:in `load_rakefile'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:689:in `raw_load_rakefile'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:94:in `block in load_rakefile'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:176:in `standard_exception_handling'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:93:in `load_rakefile'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:77:in `block in run'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:176:in `standard_exception_handling'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/lib/rake/application.rb:75:in `run'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-10.5.0/bin/rake:33:in `<top (required)>'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `load'
/home/git/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `<main>'
★★

У меня на Fedora на 2.3.1 с чистым gemset гем загружается успешно.

Быстрый гуглинг показал, что проблема может быть из-за hardened-ядра.

theNamelessOne ★★★★★ ()
Ответ на: Ссылки от theNamelessOne

Какое у тебя сильное гугл-фу, я второй день гуглю.

gadfly ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.