LINUX.ORG.RU

sudo rake generate_secret_token error

 


0

1

Пытаюсь обновоить RedMIne 3.4.0 до 4.0 (Ubuntu 16.04) При вызове sudo rake generate_secret_token

rake aborted!
RGLoaderError: RubyEncoder Loader - This protected script does not support version 2.3.1 of Ruby. Please contact the script author about this problem. Error code [07]
/opt/redmine-4.0.0/plugins/clear_plan/init.rb:2:in `RGLoader_load'
/opt/redmine-4.0.0/plugins/clear_plan/init.rb:2:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `require'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `block in require'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `require'
/opt/redmine-4.0.0/lib/redmine/plugin.rb:173:in `block in load'
/opt/redmine-4.0.0/lib/redmine/plugin.rb:164:in `each'
/opt/redmine-4.0.0/lib/redmine/plugin.rb:164:in `load'
/opt/redmine-4.0.0/config/initializers/30-redmine.rb:21:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `block in load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:657:in `block in load_config_initializer'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/notifications.rb:170:in `instrument'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:656:in `load_config_initializer'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:614:in `block (2 levels) in <class:Engine>'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:613:in `each'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:613:in `block in <class:Engine>'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:32:in `instance_exec'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:32:in `run'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:61:in `block in run_initializers'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:50:in `each'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:50:in `tsort_each_child'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/initializable.rb:60:in `run_initializers'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/application.rb:361:in `initialize!'
/opt/redmine-4.0.0/config/environment.rb:14:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `require'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `block in require'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in `require'
/opt/redmine-4.0.0/plugins/a_common_libs/lib/tasks/a_common_libs.rake:1:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `block in load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/opt/redmine-4.0.0/lib/tasks/redmine.rake:190:in `block in <top (required)>'
/opt/redmine-4.0.0/lib/tasks/redmine.rake:190:in `each'
/opt/redmine-4.0.0/lib/tasks/redmine.rake:190:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `block in load'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:285:in `load'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:650:in `block in run_tasks_blocks'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:650:in `each'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:650:in `run_tasks_blocks'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/application.rb:515:in `run_tasks_blocks'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/engine.rb:459:in `load_tasks'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/railtie.rb:190:in `public_send'
/var/lib/gems/2.3.0/gems/railties-5.2.2/lib/rails/railtie.rb:190:in `method_missing'
/opt/redmine-4.0.0/Rakefile:7:in `<top (required)>'
/var/lib/gems/2.3.0/gems/rake-12.3.2/exe/rake:27:in `<top (required)>'
(See full trace by running task with --trace

Версия ruby

 ruby -v
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-linux]

Что не так, я вижу что он ищет в папке 2.3.0, папка 2.6.0 отсутствует по этому пути...

Ответ на: комментарий от blackst0ne

Делаю всё с нуля. Я обновли убунту 12 до 14, далее скачал и сделал все по мануалу

http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade

на пункте sudo bundle install --without development test выдаёт ошибку.

RubyGems 1.8.23 is not threadsafe, so your gems will be installed one at a time. Upgrade to RubyGems 2.1.0 or higher to enable parallel gem installation.
Fetching rake 12.3.2
Installing rake 12.3.2
Gem::InstallError: rake requires Ruby version >= 2.0.0.
An error occurred while installing rake (12.3.2), and Bundler cannot continue.
Make sure that `gem install rake -v '12.3.2'` succeeds before bundling.

выполнил sudo gem update --system Он обновил RubyGems, но ошибка не ушла .

madcry ()