LINUX.ORG.RU
ФорумTalks

Apache OpenJPA 2.3.0

 ,


0

1

25 ноября, после почти двух лет с релиза версии 2.2.0, тихо и незаметно™ вышла очередная версия Apache OpenJPA - реализации Java Persistence API (JPA), стандарта ORM-систем для платформы Java.

На сайте новости ещё нет, но релиз уже появился в репозитории Maven Central.

Для столь большого времени разработки изменения по сравнению с версией 2.2.2 удивительно незначительные, хоть их и много. В основном это багфиксы, улучшения производительности и обновления зависимостей. Потому и «минорщина».

2.3.x будет последней веткой OpenJPA, поддерживающей Java 6 и ориентированной на спецификацию JPA 2.0. В транке начата работа над веткой 3.0.x, которая будет реализовывать JPA 2.1 и требовать Java 7.

Надо сегодня попробовать обновить проекты, раз такое дело.

orm-i-auga ★★★★★ ()

хотел написть письмо reserved с новостью, а потом увидел ник ТСа

stevejobs ★★★★☆ ()

Кстати, чем это лучше Hibernate?

stevejobs ★★★★☆ ()

Чем оно лучше DataNucleus?

iZEN ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Hibernate при использовании JPA тоже так умеет.

Другой вопрос, что Hibernate - монстр, а JPA там является просто обёрткой над его собственным внутренним API, в то время как другие реализации JPA созданы изначально именно как реализации JPA, и ничего лишнего.

Плюс OpenJPA традиционно преуспевает в документации и генерирует более человекочитаемый SQL.

Но вообще, честно говоря, скорость развития OpenJPA в последнее время навевает тоску. Если буду делать новый проект с нуля, то выберу, скорее всего, EclipseLink.

reserved ()
Последнее исправление: reserved (всего исправлений: 2)
Ответ на: комментарий от reserved

Но вообще, честно говоря, скорость развития OpenJPA в последнее время навевает тоску. Если буду делать новый проект с нуля, то выберу, скорее всего, EclipseLink.

Гм, «Sun Microsystems выбрала EclipseLink в качестве эталонной реализации JPA 2.0.». http://www.eclipse.org/org/press-release/20080317_Eclipselink.php

Актуальна уже Java EE 7 с JPA 2.1. http://www.opennet.ru/opennews/art.shtml?num=37150

iZEN ★★★★★ ()
Последнее исправление: iZEN (всего исправлений: 1)
Ответ на: комментарий от iZEN

Так последний EclipseLink и JPA 2.1 поддерживает. А вот OpenJPA - нет.

reserved ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.