LINUX.ORG.RU

GCC 4.7.2

 ,


1

2

Вышел корректирующий релиз набора компиляторов GCC 4.7.2, в котором проведена работа по исправлению ошибок, регрессивных изменений и проблем с совместимостью. С момента выхода прошлой версии отмечено 75 исправлений, большинство из которых связано с устранением внесенных ранее регрессивных изменений. В новой версии также устранены недоработки в поддержке спецификаций C++11. В частности, исправлены проблемы с ABI, связанные с некоторыми шаблонами C++11 (std::list and std::pair), что позволило обеспечить совместимость использующего данные шаблоны кода на уровне ABI с режимами C++03/C++98 или C++11 в GCC 4.6. Исходные тексты компилятора можно загрузить с сайта проекта или с его зеркал.

А зачем ты постишь сюда новости с opennet? Кстати, тебе уже говорили, что неплохо бы ссылку ставить, а то ты авторство присваиваешь.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

А зачем ты постишь сюда новости с opennet?

Потому что хочу так.

Кстати, тебе уже говорили, что неплохо бы ссылку ставить, а то ты авторство присваиваешь.

Да, а ещё я Кеннеди убил.

Kindly_Cat ()
Ответ на: комментарий от Kindly_Cat

Потому что хочу так.

Почему и зачем — разные вопросы.

i-rinat ★★★★★ ()
Ответ на: комментарий от Kindly_Cat

Затем, что хочу так.

опять-таки, это ответ на вопрос «почему?», а не «зачем?». Пока что получается:

— Посчёт договоров звонил в финансовый отдел?
— Нету.
— Зачем?

i-rinat ★★★★★ ()

Наверное я как-то не так понял тег gentoo.

Lavos ★★★★★ ()
Ответ на: комментарий от Kindly_Cat

Пусть убунтоиды сидят на bleeding edge, мне нужна стабильная система, а 4.7 сейчас замаскирован

black7 ()
Ответ на: комментарий от Kindly_Cat

Чтобы гентушников в известность поставить.

А чё, 4.6 уже стабилизировали?

O02eg ★★★★★ ()
Ответ на: комментарий от Kindly_Cat

Это ж тебе не какая-то левая прога, которая упадёт, на старую версию откатиться можно.

O02eg ★★★★★ ()
Ответ на: комментарий от O02eg

Всегда можно откатиться на старую ветку gcc, если, конечно, не удалять её.

Но 4.6.х уже достаточно стабилен, использую с версии 4.6.1 и проблем не встречал.

Kindly_Cat ()

Кстати, я тут накатил portage-9999 и при emerge -epv @installed вылезло сообщение:

The @installed set is deprecated and will soon be
removed. Please refer to bug #387059 for details.

Круто, чё. И чем им этот сет помешал, блин?

Kindly_Cat ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.