LINUX.ORG.RU

Где взять свежий пакет freeNX для Debian?

 ,


0

1

Собственно, сабж.
В дебиановской вики сказано, что нигде, но мне в это верить не хочется. Тем более, что сборка пакета, по утверждениям авторов самого freenx, является нетривиальной задачей.
Истории успеха в установке сабжа на сабж горячо приветствуются.

★★★★★

свежий
freenx

/0. Последний релиз - 18.08.2008
neatx чуть посвежее, да - 2009-ый.

h31 ★★★★ ()
Ответ на: комментарий от uspen

попробуй поставить с ppa

Где вы видели в debian stable ppa?

Axon ★★★★★ ()
Ответ на: комментарий от h31

Кстати, раз уж на то пошло, можете сказать пару слов на тему «freenx vs neatx»? Я второй не пробовал, думаю, стоит ли.

Axon ★★★★★ ()
Ответ на: комментарий от uspen

добавь реп из ppa ubuntu же

И каковы шансы на успех? Пакет совместим? Зависимости найдутся?

Axon ★★★★★ ()
Ответ на: комментарий от uspen

а ты попробуй

Да, как-то, не горю желанием в малознакомой системе сходу на граблях отплясывать. Подожду пока историй успеха, если не дождусь, то попробую. Если что, ждите от меня вброс на тему «дебиан говно, софта нет, ломается от каждого чиха». :-)

Axon ★★★★★ ()
Ответ на: комментарий от Axon

премного извиняюсь, там в зависимостях upstart )

uspen ★★★★★ ()
Ответ на: комментарий от kitar

Не прокатило. Как я и думал, требует свежие либы, которых нет в стейбле.

Axon ★★★★★ ()

Неужели в дебиановских репах НАСТОЛЬКО старый софт?

CYB3R ★★★★★ ()
Ответ на: комментарий от CYB3R

Неужели в дебиановских репах НАСТОЛЬКО старый софт?

Welcome to the real world, Neo.
А ещё его там, внезапно, мало. Куда ни ткнись: freenx, neatx - нету, deadbeef - нету, gsimplecal, sbxkb, gscreenshot - нету. Самы обширные репозитории среди линуксов, ага.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Поэтому я и перешел на Убунту. Сейчас чувствую себя белым человеком. Почти что виндузятником.

pacify ★★★★★ ()
Ответ на: комментарий от pacify

Поэтому я и перешел на Убунту. Сейчас чувствую себя белым человеком. Почти что виндузятником.

Всё это очень хорошо, но дебиан этот я ставлю не для себя. Мне-то и на Арче хорошо, вот уж где благодать.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

в самом деле, поставь ubuntu 10.04, все работает. до 2015 года.

uspen ★★★★★ ()
Ответ на: комментарий от uspen

в самом деле, поставь ubuntu 10.04, все работает. до 2015 года.

Во-первых, я органически не переношу апстарт. Во-вторых, конечный пользователь от гнома с непривычки может впасть в ступор, нужны кеды, которые не ломают привычной парадигмы рабочего стола, а с ними в убунте не очень.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Да разницы большой и нет. Всю основную выполняют библиотеки от NoMachine, freenx/neatx - это просто врапперы. Если планируешь подключать большое число клиентов в сложной конфигурации, то думаю, что разница будет, а при бытовом применении - вряд ли.

h31 ★★★★ ()
Ответ на: комментарий от h31

Если планируешь подключать большое число клиентов в сложной конфигурации, то думаю, что разница будет, а при бытовом применении - вряд ли.

Ясно, спасибо. Буду придерживаться уже знакомого freenx.

Axon ★★★★★ ()
Ответ на: комментарий от CYB3R

А у меня всегда был баттхёрт из-за того, что у меня пакетов меньше, чем у других

Я, вот, тоже не понимаю, каким хламом набивают репозитории майнтейнеры некоторых дстрибутивов. Впрочем, в случае дебиана/убунты число пакетов сразу надо делить минимум на 3 из-за того, что там половину софта трут на мелкой тёрке.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Забыл упомянуть, что использую арч и дебиан.

CYB3R ★★★★★ ()
Ответ на: комментарий от Axon

Самы обширные репозитории среди линуксов, ага.

из оттестированных - самые обширные, ага.

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm
sergey@virt:~$ sudo apt-get install freenx-server --no-install-recommends
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  desktop-file-utils evolution-data-server-common expect gnome-about gnome-desktop-data
  gnome-menus gnome-panel gnome-panel-data gnome-session gnome-session-bin gnome-session-common
  gnome-settings-daemon libcamel1.2-14 libebook1.2-9 libecal1.2-7 libedataserver1.2-13
  libedataserverui1.2-8 libgnome-desktop-2-17 libgnome-menu2 libgnomekbd-common libgnomekbd4
  libgweather-common libgweather1 libimobiledevice1 libmetacity-private0 libnautilus-extension1
  libpanel-applet2-0 libplist1 libunique-1.0-0 libupower-glib1 libusbmuxd1 libxcomp3
  libxcompext3 libxcompshad3 metacity metacity-common nautilus nautilus-data nxagent nxlibs
  openssh-server python-gmenu tcl8.5 upower usbmuxd zenity
Предлагаемые пакеты:
  expectk esound-clients libarts1c2 libarts1 xdm freenx yelp gnome2-user-guide evolution
  epiphany-browser gnome-user-guide gnome-screensaver gnome-themes xdg-user-dirs eog totem
  mp3-decoder tracker ssh-askpass rssh molly-guard ufw tclreadline
Рекомендуемые пакеты:
  freenx-session-launcher gnome-applets gnome-control-center evolution-data-server alacarte
  gnome-power-manager hwdata brasero app-install-data gvfs-backends
НОВЫЕ пакеты, которые будут установлены:
  desktop-file-utils evolution-data-server-common expect freenx-server gnome-about
  gnome-desktop-data gnome-menus gnome-panel gnome-panel-data gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon libcamel1.2-14 libebook1.2-9 libecal1.2-7
  libedataserver1.2-13 libedataserverui1.2-8 libgnome-desktop-2-17 libgnome-menu2
  libgnomekbd-common libgnomekbd4 libgweather-common libgweather1 libimobiledevice1
  libmetacity-private0 libnautilus-extension1 libpanel-applet2-0 libplist1 libunique-1.0-0
  libupower-glib1 libusbmuxd1 libxcomp3 libxcompext3 libxcompshad3 metacity metacity-common
  nautilus nautilus-data nxagent nxlibs openssh-server python-gmenu tcl8.5 upower usbmuxd
  zenity
обновлено 0, установлено 47 новых пакетов, для удаления отмечено 0 пакетов, и 4 пакетов не обновлено.
Необходимо скачать 46,2 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 122 MB.
Хотите продолжить [Д/н]? wtf?!
Аварийное завершение.

Эээ... Так и должно быть? Нахрена ему гном вообще?

Axon ★★★★★ ()
Ответ на: комментарий от lazyklimm

и правильно делают

И в чем заключается «правильность»?

Ok ()
Ответ на: комментарий от Ok

можно ставить только нужное. deb-based, благодаря опциональным зависимостям и вот такому дроблению пакетов одни из самых гибких дистрибутивов.

Но это, конечно, на любителя, тем, кому все время хочется поканпелять отсутствие -dev пакетов, будет напрягать.

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

одни из самых гибких дистрибутивов.

речь про бинарные, конечно

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm
sergey@virt:~$ sudo apt-cache depends freenx-server 
freenx-server
  Зависит: libc6
 |Зависит: debconf
  Зависит: <debconf-2.0>
    cdebconf
    debconf
  Зависит: nxagent
  Зависит: openssh-server
  Зависит: openssh-client
  Зависит: netcat
    netcat-openbsd
    netcat-traditional
  Зависит: expect
  Зависит: bash
  Зависит: adduser
  Зависит: binutils
 |Зависит: gnome-session
 |Зависит: <ksmserver>
 |Зависит: xfce4-session
 |Зависит: freenx-rdp
  Зависит: freenx-vnc
  Предлагает: esound-clients
 |Предлагает: <libarts1c2>
  Предлагает: <libarts1>
  Предлагает: xdm
  Предлагает: freenx
  Рекомендует: xfonts-base
  Рекомендует: freenx-session-launcher
  Рекомендует: consolekit
  Конфликтует: freenx
  Конфликтует: freenx-session-launcher

Отлично, и чем же его не устраивает ksmserver из моих кед?

Axon ★★★★★ ()
Ответ на: комментарий от lazyklimm

Так тут же, вроде, не указаны требования к версии?

Axon ★★★★★ ()
Ответ на: комментарий от Axon

хз, в самом пакете может быть, у меня других вариантов пока нет

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

Мда. Как-то не задаётся моё очередное знакомство с Дебианом...

Axon ★★★★★ ()
Ответ на: комментарий от lazyklimm

кстати, а ты где достал в stable ksmserver?

А разве он оне сроду в четверокедах?

sergey@virt:~$ ps -ef | grep ksmserver
sergey    1736  1578  0 May03 ?        00:00:00 kwrapper4 ksmserver
sergey    1737  1687  0 May03 ?        00:00:00 kdeinit4: ksmserver [kdeinit]                  
sergey    4021  3929  0 10:05 pts/1    00:00:00 grep ksmserver
sergey@virt:~$ apt-cache search ksmserver
kdebase-workspace-bin - core binaries for the KDE Plasma Workspace

Axon ★★★★★ ()
Ответ на: комментарий от lazyklimm

пакета ksmserver в stable нет

Такого пакета вообще нигде нет. Он предоставляется пакетом kdebase-workspace-bin.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Такого пакета вообще нигде нет

в oldstable есть

Он предоставляется пакетом kdebase-workspace-bin.

нет

lazyklimm ★★★★★ ()
Ответ на: комментарий от Axon

Подожду пока историй успеха, если не дождусь, то попробую.

linux.org.ru

Ø

iBliss ()
Ответ на: комментарий от h31

/0. Последний релиз - 18.08.2008

Разработка продолжается в git, для Ubuntu регулярно обновляются snapshot'ы в PPA.

reserved ()
Ответ на: комментарий от Axon

У меня то что работало в neatx работло прямее. С freenx ловил глюки. В итоге на ARM юзаю neatx, а на нормальніх тачках - nomachine

vasily_pupkin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.