LINUX.ORG.RU

Небезопасность OpenBSD


0

0

Для тех, кто интересуется отличными от Linux Unix-like OS.

Спорная, но не лишенная смысла статья. Автор делает попытку развеять миф о самой безопасной ОС в мире. Внимание: англ.яз.

Ссылка взята с distrowatch.com

http://allthatiswrong.wordpress.com/2010/01/20/the-insecurity-of-openbsd/

Вот в этом то треде iZEN включит свою горелку на всю мощььь

подставляйте зажигалки, кто запустит сию ракету на околоземную орбиту тому тапочки iZEN`а.

wfrr ★★☆ ()
Ответ на: комментарий от Cancellor

Он бздишник, во всех смыслах этого слова.

wfrr ★★☆ ()

>Автор делает попытку


сабака лает.

ansi ★★★★ ()

Лучше б чего-нибудь про NetBSD пописали, а то все опенок да фри...

NoMad ★★ ()

много слюны, а что он хотел сказать так и не понял

beastie ★★★★★ ()
Ответ на: комментарий от beastie

Меня на весь текст тоже не хватило, но вроде он хотел сказать, что OpenBSD не может называться безопастной, потому что там нету SELinux. А так же то, что разработчики не занимаються аудитом программ из портов.

DukE-M ★★ ()
Ответ на: комментарий от DukE-M

> Меня на весь текст тоже не хватило, но вроде он хотел сказать, что OpenBSD не может называться безопастной, потому что там нету SELinux. А так же то, что разработчики не занимаються аудитом программ из портов.

Я тоже ещё не дочитал, но пока не встретил других дельных замечаний. И то автор не обосновывает недостаточность стандартных разрешений Unix и необходимость установки чего-то дополнительного.

А так чем дальше читаю, тем правильнее мне кажется подход OpenBSD :)

Хотя им явно не хватает народу для проведения аудита в должном объёме.

question4 ★★★★★ ()
Ответ на: комментарий от question4
% uname -rsm
FreeBSD 8.0-STABLE amd64
% pkg_info portaudit-0.5.14
Information for portaudit-0.5.14:

Comment:
Checks installed ports against a list of security vulnerabilities


Description:
portaudit provides a system to check if installed ports are listed in a 
database of published security vulnerabilities.

After installation it will update this security database automatically and 
include its reports in the output of the daily security run.

If you have found a vulnerability not listed in the database, please contact 
the FreeBSD Security Officer <security-officer@FreeBSD.org>. Refer to

  http://www.freebsd.org/security/#sec

for more information.

WWW: http://people.freebsd.org/~eik/portaudit/

Oliver Eikemeier <eik@FreeBSD.org>
% portaudit -Fa
auditfile.tbz                                 100% of   59 kB   27 kBps
New database installed.
Affected package: linux-sun-jdk-1.6.0.17
Type of problem: jdk -- jar directory traversal vulnerability.
Reference: <http://portaudit.FreeBSD.org/18e5428f-ae7c-11d9-837d-000e0c2e438a.html>

1 problem(s) in your installed packages found.

You are advised to update or deinstall the affected package(s) immediately.

Слава богу, что linux-sun-jdk — неосновная:

% java -version
java version "1.6.0_03-p4"
Java(TM) SE Runtime Environment (build 1.6.0_03-p4-root_23_dec_2009_22_14-b00)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_03-p4-root_23_dec_2009_22_14-b00, mixed mode)
И эти люди что-то там лепечут о небезопасности OpenBSD в пользу решений на Linux...

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

> Affected package: linux-sun-jdk-1.6.0.17

Каким боком это относится к обсуждаемой теме?

И почему бы тебе не обновиться? 1.6.0.18 уже 2 недели вышла.

Кстати, почему linux-sun-jdk? Под фрю не собирается?

question4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.