LINUX.ORG.RU
ФорумTalks

Какими GTK-2-приложениями вы ещё пользуетесь?

 , ,


2

2

Сейчас из любопытства полазил по своей системе (Mint 20) и сходу не нашёл приложения, которые бы использовали GTK-2. ГИМП и Инкскейп перевели/переводят на ГТК-3. Интересно, когда из репозиториев выкинут на мороз ГТК-2 вслед за Qt4? Что вы используете из того, что поддерживает только ГТК-2?

★★★★★

Интересно, когда из репозиториев выкидывают на мороз полезные кому-то программы, у гномофашни эякуляция происходит?

bread ()

Наверное только гимп у меня и остался.

Im_not_a_robot ★★★★★ ()
Ответ на: комментарий от BceM_IIpuBeT

Там вроде, насколько я помню, фронт вообще в виде плагина, можно использовать любой из нескольких. В Слаке нынешней вроде и ГТК2, и ГТК3 поддерживается.

meliafaro ★★★★★ ()
$ sudo pacman -Rs gtk2
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing gtk2 breaks dependency 'gtk2' required by gimp
:: removing gtk2 breaks dependency 'gtk2' required by ibus
:: removing gtk2 breaks dependency 'gtk2' required by spotify


Ещё sylpheed был, но я им не пользуюсь - поставил на посмотреть.

snizovtsev ★★★★ ()
Ответ на: комментарий от meliafaro

Так электрон относительно недавно переехал на гтк3, если я ничего не путаю.

Im_not_a_robot ★★★★★ ()

double commander идёт с интерфейсами на qt4, qt5 и gtk2

grem ★★★★★ ()
Ответ на: комментарий от meliafaro

да, олдолд на десктопе и олдолдолд на лаптопе, но эти два - единственные долгожители. лаптоп так вообще только лучше с олдолдолдом ибо новые версии просто практически висят, такой вот он, современный линукс - «мало» жрущий ресурсы.

deep-purple ★★★★★ ()
Ответ на: комментарий от another

А нет, попытался удалить libgtk-2.0 вылетело, что есть по зависимостям предлагает удалить еще deadbeef (давно не использую, просто установлен, перешел на rhythmbox), amule (тоже не использую, есть на всяк случай), doublecmd (иногда пользуюсь), fbreader (давно не использую, в основном foliate), pcamanfm (давно не использую), pinta (пользуюсь). Как-то так.

another ★★★★★ ()

Из нужного – только GIMP и JFX, но первый скоро переведут на 3-ку окончательно, а вот с «жабой» будет непросто, ибо Minecraft.

Korchevatel ★★★★★ ()
Ответ на: комментарий от meliafaro

Споти нужен ГТК2? Был уверен, что он на чем-нибудь вроде Электрона.

Так и есть, электрон. Но настолько древний, что слинкован с gtk2 и не умеет в wayland. Редиски, в общем.

snizovtsev ★★★★ ()
Ответ на: комментарий от meliafaro

В мате темы тянут гтк2. Если выпилить, то будет только гтк3 и некоторое вырвиглазие.

utanho ★★ ()

Краснопанда все ещё просит гтк2. Про гимп писали уже.

А основном на гтк или спецсофт или копролит.

utanho ★★ ()
Ответ на: комментарий от utanho

Mint 20 (= Ubuntu 20.04). Гтк 2 стоит, но тут из коробки даже Джава есть. В системе, кроме либ, его требует только изкоробочный Hexchat.

meliafaro ★★★★★ ()
Ответ на: комментарий от slovazap

Вот собсно и ответ. Красная панда требует гтк2 для сборки. Из бинарного можно спокойно гтк2 выковырять. Но из сырцов без гтк2 не соберете.

utanho ★★ ()
Последнее исправление: utanho (всего исправлений: 2)

По зависимостям предложило снести audacity, geeqie, gimp, discord, ну и MATE.

Sectoid ★★★★★ ()
Последнее исправление: Sectoid (всего исправлений: 1)
Ответ на: комментарий от yu-boot

Своё, родное же!

Если серьёзно, то наличие биндингов к чему угодно, ибо объектная система надъязыковая. Ну и лицензия без всякой двусмысленности.

meliafaro ★★★★★ ()
Ответ на: комментарий от BceM_IIpuBeT

В одной из тем писали,что в Debian кто-то пожаловался на audacious с qt5 и его заменили на gtk2. Что мешало им предоставлять 2 пакета неизвестно.

Может этот баг: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820472

Что-о им не понравилось.

По крайней мере разработчик на тот момент ссылался на отсутствие каких-то фич в интерфейсе с qt. Но это было на тот момент и он предлагал иметь отдельный пакет с qt.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)
Ответ на: комментарий от utanho

Вот собсно и ответ. Красная панда требует гтк2 для сборки. Из бинарного можно спокойно гтк2 выковырять. Но из сырцов без гтк2 не соберете.

Это не Firefox требует, а NPAPI под Adobe Flash, который скоро дропнут вместе с GTK+3.

См. https://bugzilla.mozilla.org/show_bug.cgi?id=1377445

Сам Firefox уже очень давно не зависит от GTK+2, настолько давно, что из исходников Firefox выпилили поддержку отрисовки через GTK+2:

Firefox окончательно удаляет поддержку GTK+2

EXL ★★★★★ ()
Ответ на: комментарий от yu-boot

Кстати а в чём причина такой популярности гытыка перед кутями? Plain-C-филия?

Изначально столмоноугодная и свободная лицензия. Выбор крупных дистростроителей (RedHat, SUSE, Debian, Ubuntu) оболочек на GTK+ по умолчанию.

EXL ★★★★★ ()

По сабжу – у меня остался только GIMP на GTK+2

Но он вот на днях релизнул GTK+3-версию.

EXL ★★★★★ ()
Ответ на: комментарий от meliafaro

наличие биндингов к чему угодно

Ничего не даёт. Весь гткшный софт на Си по факту. И тоже кайф такой писать гуи на сишке, аж прям слюнки текут. Вот и не пишут, все живые еще программы чуть не старше поттеринга.

bread ()
Последнее исправление: bread (всего исправлений: 1)
Ответ на: комментарий от meliafaro

Ага, только это либо гтк-шкурка как в либреофисе (без которой он намного удобнее), либо неюзабельное днище в виде питоноподелий. Впрочем, с гтк3 теперь всё такое.

bread ()
$ yum deplist steam | grep gtk2

  dependency: gtk2(x86-32)
   provider: gtk2-2.24.32-8.fc33.i686
sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от EXL

Это не Firefox требует, а NPAPI под Adobe Flash, который скоро дропнут вместе с GTK+3.

Я знаю что там и почему. Но пока положение дел именно таково. Как дропнут, так и поговорим.

utanho ★★ ()

Xfburn. До этого использовал epdfview, viewnior, geeqie, но позже отказался как раз таки по причине того, что они на GTK 2

puffy ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)