LINUX.ORG.RU
ФорумTalks

Emacs 25.1 released

 


1

2

https://lists.gnu.org/archive/html/emacs-devel/2016-09/msg00451.html

Highlights of this release include:
- Emacs can now load shared/dynamic libraries (modules)
- Experimental support for Cairo drawing
- Enhanced network security (TLS/SSL certificate validity and the like)
- New minor mode 'electric-quote-mode' for using curved quotes as you type
- Character folding support in isearch.el
- Xwidgets: a new feature for embedding native widgets inside Emacs buffers
- New and improved facilities for inserting Unicode characters

★★★★★

Ответ на: комментарий от Kostya69

Emacs lisp is good enough. Можно воротить носом и жаловаться на dynamic scope, отсутствие синтаксиса для структур данных, и на прочие недостатки; а можно писать на нем нормальные вещи.

unlog1c ★★★ ()
Ответ на: комментарий от unlog1c

можно кушать кал и радостно просить еще

Нет спасибо я не голодный

Kostya69 ()

The Emacs server now has socket-launching support.

годная фича, не знал, что она есть(интересно, была ли в rc1? )

f1u77y ★★★ ()
Ответ на: комментарий от f1u77y

не руководит, но его мнение разработчики emacs уважают

Bad_ptr ★★★★ ()
Ответ на: комментарий от Bad_ptr

столлман же был раньше против такой фичи, не?

It should also export a symbol named 'plugin_is_GPL_compatible' to indicate that its code is released under the GPL or compatible license; Emacs will refuse to load modules that don't export such a symbol.

iVS ★★★★★ ()
Ответ на: комментарий от iVS

Emacs will refuse to load modules that don’t export such a symbol

отлично, ещё бы это умело отключаться(надо же уважать свободу юзеров). и я ни разу не видел даже в коде с gpl-compatible лицензией таких чудес. хоть где-то прописано, что код должен содержать в себе такой символ, кроме доков emacs 25?

f1u77y ★★★ ()
Ответ на: комментарий от Kostya69

ты тупой? тупой.

guile-emacs это реализация elisp поверх guile.

x4DA ★★★★★ ()
Ответ на: комментарий от Bad_ptr

Столмана в мягкой форме послали с его манямирком, он не принимает участия в разработке давно уже.

x4DA ★★★★★ ()

- Enhanced network security (TLS/SSL certificate validity and the like)

не буду спрашивать, зачем это текстовому редактору

Harald ★★★★★ ()
Ответ на: комментарий от Harald

алё очнись, счас текстовые редакторы на вебките, там оно уже подефолту встроено. Да и даже если бы было не так, то всё равно это нужно чтобы там обновления/плагины из интернета ставить, онлайн-справку смотреть.

Bad_ptr ★★★★ ()
Ответ на: комментарий от Hertz

виму надо нормальный язык расширений завезти

Не, там далеко не в языке дело. Там некоторые вещи нельзя вызовами функций выразить, а только как 'нажатия клавиш', короче тот ещё гемор и он не в языке, а в архитектуре.

Bad_ptr ★★★★ ()
Последнее исправление: Bad_ptr (всего исправлений: 1)
Ответ на: комментарий от Hertz

Я не знаю, но там вроде оставили совместимость со старым вимом. Так что скорее всего нет.

Bad_ptr ★★★★ ()

Если бы не заголовок, я бы подумал, что это очередной релиз systemd

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.