LINUX.ORG.RU
ФорумTalks

ALSA (2 no-dashi)


0

0

В треде про 2.6.15 ты говорил, что alsa-у патчил - не можешь патч выложить?
У меня такая ж звуковуха - с дровами начиная с версии 1.0.10 началась лажа типа такой
ALSA lib simple_none.c:1216:(simple_add1) helem (MIXER,'Front Playback Volume',0,0,0) appears twice or more
Я у себя просто закомментил exit() после такой оказии. Может надо было как нить по-другому?

★☆☆☆

Re: ALSA (2 no-dashi)

Я патчил не alsa-util, а alsa-lib, но tiwai сказал это некошерно,
ибо все равно надо патчить драйвер :-) Вся разница между патченым и
непатченым драйвером заключается в следующем - если посмотреть в
emumixer.c, то там можно найти такую декларацию (в непатченом
драйвере):

        static char *emu10k1_remove_ctls[] = {
                /* no AC97 mono, surround, center/lfe */
                "Master Mono Playback Switch",
                "Master Mono Playback Volume",
                "PCM Out Path & Mute",
                "Mono Output Select",
                "Surround Playback Switch",
                "Surround Playback Volume",
                "Center Playback Switch",
                "Center Playback Volume",
                "LFE Playback Switch",
                "LFE Playback Volume",
                NULL
        };

А патч состоит в том, что в этот массив надо добавить еще
две строки - "Front Playback Volume" и "Front Playback Switch"
чтобы это выглядело следующим образом:

        static char *emu10k1_remove_ctls[] = {
                /* no AC97 mono, surround, center/lfe */
                "Master Mono Playback Switch",
                "Master Mono Playback Volume",
                "PCM Out Path & Mute",
                "Mono Output Select",
                "Front Playback Volume", /* +++ добавлено +++ */
                "Front Playback Switch", /* +++ добавлено +++ */
                "Surround Playback Switch",
                "Surround Playback Volume",
                "Center Playback Switch",
                "Center Playback Volume",
                "LFE Playback Switch",
                "LFE Playback Volume",
                NULL
        };

В CVS у них лежит уже исправленая версия, но в linux-2.6.15 и
ALSA-driver-1.0.11rc2 естественно этого нет (наверное будет
в .16 и .rc3)

no-dashi ★★★★★ ()

Re: ALSA (2 no-dashi)

> Я у себя просто закомментил exit() после такой оказии.

Хреновое решение, кстати. После этого некоторые проги валиться начинают.

no-dashi ★★★★★ ()
Ответ на: Re: ALSA (2 no-dashi) от no-dashi

Re: ALSA (2 no-dashi)

Спасибо! Хотя проги не валились ни разу у меня, сделаю как надо.

sabonez ★☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.