LINUX.ORG.RU

А php6 они пропустили из-за суеверий?

И да, на большинстве хостингов до сих пор 5.14 в лучшем случае, а вы про 7. Оно доедет лет через 5, когда допилят.

ekzotech ★★★★ ()
Последнее исправление: ekzotech (всего исправлений: 1)
Ответ на: комментарий от Kaschenko

Оу, спасибо. Почитал его посты про php. Не, я знал, что php это говнокод, но чтоб до такой степени. Ужс.

ekzotech ★★★★ ()

С хераб радоваться очередному выкаку? PHP был уродцем. И остался монстром у которого пришиты голва утки ласты лося и рога лебедя.

dmxrand ()
Ответ на: комментарий от nikita-b

На сервере, где я ковыряю проект, стоит 5.4 с чем-то. Там debian, может у них поэтому такая старая версия. Лично мне не встречалось свежее, если не считать локалхосты. Но у меня и хостингов мало, с которыми я работал.

ekzotech ★★★★ ()

Официально релиз будет только сегодня (3-го). Вот всё жду анонса на оф. сайте, чтобы новость из черновиков запилить.

Kilte ★★★★★ ()

Где танцы радости и счастья?

Все убежали обмазываться новым пыхом.

no-such-file ★★★★★ ()

Мёртвый

PHP 7

2015

EXL ★★★★★ ()
Ответ на: комментарий от ekzotech

на большинстве хостингов до сих пор 5.14 в лучшем случае

Верни машину времени. 5.6 пока самый новый.

KRoN73 ★★★★★ ()
Ответ на: комментарий от ekzotech

На сервере, где я ковыряю проект, стоит 5.4 с чем-то.

Поддержка 5.4 прекращена в сентябре. А потом ругаются на взломы...

KRoN73 ★★★★★ ()
Ответ на: комментарий от ekzotech

Везде где я работал был выбор версии из нескольких. Это сейчас почти стандартная фишка.

nikita-b ()
Ответ на: комментарий от ekzotech

А php6 они пропустили из-за суеверий?

php6 они пилили лет пять, но поняли, что крупно косякнули в концепции (что-то там было не так с ютф, в частности). А так как гугл уже был засран новостями и обзорами про 6, решили, что лучше не путать и два раза про php6 не говорить.

zloelamo ★★★★ ()

1) или пых перестанет быть говном, поломав обратную совместимость, тогда это плохо, всем надо будет весь код менять

2) или пых останется говном, какой тогда толк, новые фишки для ненужного оопа, что ли

amomymous ★★★ ()
Ответ на: комментарий от amomymous

Пункт 1 не катит, зачем тогда вообще пых нужен, можно сразу взять нормальный язык, которых как минимум несколько на выбор и они уже развиты и с кучей готовых библиотек.

pawnhearts ★★★★★ ()
Ответ на: комментарий от KRoN73

Поддержка 5.4 прекращена в сентябре. А потом ругаются на взломы...

Так я ж не говорю, что это хорошо.

ekzotech ★★★★ ()
Ответ на: комментарий от amomymous

или пых перестанет быть говном, поломав обратную совместимость, тогда это плохо, всем надо будет весь код менять

Говно выпиливается регулярно. Например, safe_mode и register_globals выпилили в 5.4 (а запретили register_globals по дефолту ещё в 4.2. аж в 2002).

или пых останется говном, какой тогда толк, новые фишки для ненужного оопа, что ли

Сегодня вся инфраструктура PHP на ООП ориентирована. Собственно, Composer без ООП практически не существует.

И новые фишки весьма востребованы — и пространства имён, и замыкания, и генераторы, позднее статическое связывание... В 5.6 вообще дофига вкусного, но в разработке приходится ориентироваться на последнюю поддерживаемую версию.

Вообще, даже не смотря на радикальные переломы, типа 5.4, в PHP удаётся поддерживать хороший баланс и между полезными новшествами и совместимостью. У меня часть кода 15-летней давности работает до сих пор. И огромная масса кода 10-летней давности. Без переделок.

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

Оригинальный bittorrent написаный на питоне 1.6 в 2001-м году работает на 2.7 с одним небольшим изменением(и то связанным с модулем стандартной библиотеки, а не самим питоном).

Как и про Python

Например?

Всякие https://github.com/cosmologicon/pywat высосаны из пальца по большей части. Вот это более реально http://www.b-list.org/weblog/2015/nov/15/real-python-wat/ но не актуально для питон3 и не смертельно.

Есть пара gotchas, но они проблема совсем новичков и описаны 1000 раз и если понимать язык они вполне логичны(типа def foo(a=[]):)

Да, модули в стандартной библиотеке иногда имеют разный стиль совсем, но они написаны в разное время и разными людьми и их хранят для обратной совместимости.

Большинство претензий сводятся к отступам.

pawnhearts ★★★★★ ()
Ответ на: комментарий от KRoN73

я то знаю, но в центос, да и, наверное, во всем редхат, - не знают

r0ck3r ★★★★★ ()
Последнее исправление: r0ck3r (всего исправлений: 1)
Ответ на: комментарий от KRoN73

Ну не, там меньше. Там больше про инфраструктуру и дураков программистов.

zloelamo ★★★★ ()
Ответ на: комментарий от permafrost

Зайди в тред по любому языку программирования и там будет написано, что он плохой. Жава тормозит и жрет память. У питона отступы. Дотнет анальное микрософторабство. Не так страшны кресты, как шаблоны в них. Го для дебилов. Про негодность жаваскрипт достастчно сказать, что на нем пишет анонiмус.

goingUp ★★★★★ ()
Последнее исправление: goingUp (всего исправлений: 1)
Ответ на: комментарий от reprimand

А кому оно надо-то в 2015 году?

Действительно, кому надо ускорение PHP до х2, серьезная оптимизация структур данных, улучшенный type hinting и AST, благодаря которому будут пилить фичи в новых версиях?

И причем тут 2015 год? В 2015 году исчезли все сайты на PHP вместе с разработчиками?

nguseff ()
Ответ на: комментарий от reprimand

java

Любой адекватный человек тебе скажет, что для типичных веб задач PHP проще гораздо.

перл6

Вот уж на что действительно всем пофиг. Как был write-only УГ так и остался.

php5

У Symfony уже 100% PHP7 compatibility. Остальные, кто не в танке, тоже подтягиваются. Это вопрос времени только.

nguseff ()
Ответ на: комментарий от drull

Еще те, кому приходится разбирать приготовленное другими.

amomymous ★★★ ()
Ответ на: комментарий от drull

Гугол тебе в помощь. Столько написано уже, что смысла здесь срачик устраивать нет.

zloelamo ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.