LINUX.ORG.RU

Nmap 5.30BETA1 не находит порты


0

0

система Ubuntu 10.04
скачал, собрал, поставил nmap
#./configure
#make
#make install

все поставилось прекрасно...

но блин вот фигня получается

делаю от обычного юзверя -
dron@xakep:~/_build/nmap$ nmap 10.1.1.254

Starting Nmap 5.30BETA1 ( http://nmap.org ) at 2010-06-27 11:33 EEST
Warning: File ./nmap-services exists, but Nmap is using /usr/local/share/nmap/nmap-services for security and consistency reasons. set NMAPDIR=. to give priority to files in your local directory (may affect the other data files too).
Nmap scan report for gw.private (10.1.1.254)
Host is up (0.29s latency).
Not shown: 981 closed ports
PORT STATE SERVICE
1/tcp open tcpmux
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
25/tcp open smtp
53/tcp open domain
79/tcp open finger
80/tcp open http
81/tcp open hosts2-ns
110/tcp open pop3
111/tcp open rpcbind
119/tcp open nntp
143/tcp open imap
1080/tcp open socks
1524/tcp open ingreslock
1723/tcp open pptp
2000/tcp open cisco-sccp
6667/tcp open irc
12345/tcp open netbus

Nmap done: 1 IP address (1 host up) scanned in 1.24 seconds

нашло порты...

делаю от рута -

dron@xakep:~/_build/nmap$ sudo su -

root@xakep:~# nmap 10.1.1.254

Starting Nmap 5.30BETA1 ( http://nmap.org ) at 2010-06-27 11:34 EEST
Nmap scan report for gw.private (10.1.1.254)
Host is up (0.00017s latency).
All 1000 scanned ports on gw.private (10.1.1.254) are filtered
MAC Address: 00:02:2A:E1:F9:6B (Asound Electronic)

Nmap done: 1 IP address (1 host up) scanned in 21.44 seconds

нет портов, странно...

добавляю параметр -sT -

root@xakep:~# nmap -sT 192.168.0.250

Starting Nmap 5.30BETA1 ( http://nmap.org ) at 2010-06-27 11:20 EEST
Nmap scan report for proxy(192.168.0.250)
Host is up (0.0040s latency).
Not shown: 900 closed ports, 80 filtered ports
PORT STATE SERVICE
1/tcp open tcpmux
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
25/tcp open smtp
53/tcp open domain
79/tcp open finger
80/tcp open http
81/tcp open hosts2-ns
110/tcp open pop3
111/tcp open rpcbind
119/tcp open nntp
143/tcp open imap
1080/tcp open socks
1524/tcp open ingreslock
1723/tcp open pptp
2000/tcp open cisco-sccp
3306/tcp open mysql
6667/tcp open irc
12345/tcp open netbus
MAC Address: 00:02:2A:E1:F9:6B (Asound Electronic)

Nmap done: 1 IP address (1 host up) scanned in 1.56 seconds

есть порты...

каждый раз добавлять этот параметр или добавить в алиас это костыль получится...

кто-то может сталкивался с такой проблемой???


Ответ на: комментарий от edigaryev

и 2 и 3 раза от обычного пользователя порты видны...

для 10.04 идет 5.00 версия, она работает нормально, но это наверное изза того что она ставится из репозитария, а не из исходников...
где то в переменных окружения или в каком то конфиге чет не хватает))

dr0n ()

читай man nmap:

для root по умолчанию запускается -sS, для пользователя по умолчанию запускается -sT. Очевидно у тебя для подопытной машины -sS не срабатывает, возможно на ней слишком жестокие настройки iptables.

pupok ★★ ()

checkinstall спасёт дистр от превращения в слаку

true_admin ★★★★★ ()
Ответ на: комментарий от pupok

сканирую свою машину, iptables настроен не сильно жестко... все в пределах разумного))

собрал из сырцов 5.21, положил в prefix=/opt/nmap
/opt/nmap/bin/nmap 10.1.1.254
работает правильно и от юзверя и от рута

потом также собрал 5.30beta1, положил в /opt/nmap53
и все теже грабли что и в первом посте))

видать в бета версии все таки баг((

dr0n ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.