LINUX.ORG.RU

ufw не запускается при загрузке ОС

 , ,


0

1

Здравствуйте, с Linux работаю всего 3 месяца, много не знаю. Есть сервер с «Ubuntu 16.04.6 LTS», на нем запущен ufw работает нормально (всего 11 правил, открыто 4 порта и полный доступ с 7 ip адресов), но когда перезагружается сервер то команда «ufw status» показывает что ufw не запустился «Status: inactive». Если выполнить команду «ufw enable» Firewall запускается нормально - Status: active. Я подумал что скорее всего службы нету в автозагрузке, выполнил команду «systemctl enable ufw» и получил ошибку:

Synchronizing state of ufw.service with SysV init with /lib/systemd/systemd-sysv-install… Executing /lib/systemd/systemd-sysv-install enable ufw insserv: warning: current start runlevel(s) (empty) of script ufw' overrides LSB defaults (S). insserv: warning: current stop runlevel(s) (1 S) of scriptufw’ overrides LSB defaults (1). initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused The script you are attempting to invoke has been converted to an Upstart job, but lsb-header is not supported for Upstart jobs. insserv: warning: script ‘screen-cleanup’ missing LSB tags and overrides insserv: Default-Start undefined, assuming empty start runlevel(s) for script screen-cleanup' insserv: Default-Stop undefined, assuming empty stop runlevel(s) for scriptscreen-cleanup’ initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused The script you are attempting to invoke has been converted to an Upstart job, but lsb-header is not supported for Upstart jobs. insserv: warning: script ‘screen-cleanup’ missing LSB tags and overrides insserv: Default-Start undefined, assuming empty start runlevel(s) for script screen-cleanup' insserv: Default-Stop undefined, assuming empty stop runlevel(s) for scriptscreen-cleanup’

Можете подсказать как устранить эту проблему, в гугле решение не нашел.

Ответ на: комментарий от mky

Сначала удалил скрипт, а потом заменил,результат одинаковый, в автозагрузку оно не добавилось, но ошибок стало меньше

root@*********:/etc/init.d# systemctl enable ufw Synchronizing state of ufw.service with SysV init with /lib/systemd/systemd-sysv-install… Executing /lib/systemd/systemd-sysv-install enable ufw insserv: warning: current start runlevel(s) (empty) of script ufw' overrides LSB defaults (S). insserv: warning: current stop runlevel(s) (1 S) of scriptufw’ overrides LSB defaults (1).

dimon93 ()
Ответ на: комментарий от dimon93

Не знаю, ИМХО, это бага, переходной дистрибутивы upstart -> systemd. Попробуйте вручную создать юнит systemd и забыть про systemctl. Если в каталоге /lib/systemd/system/ есть файл ufw.service, создайте на него симлинк из каталога /etc/systemd/system/.

mky ★★★★★ ()