LINUX.ORG.RU

Не работает SFTP

 ,


0

1

Доброго времени суток коллеги

Немогу настроить sftp, вроде все по инструкции, да собственно там и настраивать то нечего, но однако споткнулся на этом

вот пример конфига /etc/ssh/sshd_config:

Subsystem sftp internal-sftp
Match user mary
    ChrootDirectory /home/%h
    ForceCommand internal-sftp
    AllowTcpForwarding no

перезапускаю ssh и не могу соединиться не по sftp не напрямую по ssh

ssh: connect to host 192.168.0.50 port 22: Connection refused

операционная система Ubuntu Server 14.04.1

В чем могут быть проблемы, я не понимаю какого черта ему надо, обьясните глупому.

Тебе же клиент написал, что не так: «Connection refused». Порт кто-то слушает? А фаерволл пускает? А что в логах?

Телепаты в отпуске.

anonymous ()

ssh: connect to host 192.168.0.50 port 22: Connection refused

Что то мне подсказывает что до настройка sftp у тебя ssh и так не работал.

snaf ★★★★★ ()
Ответ на: комментарий от snaf

Не, я вангую, что он работал, но после игр ТС с конфигом уже не стартанул.

Доброго времени суток коллеги

ТС, ты полегче. Тут есть и все, от русских физиков до зоогинекологов, так что ты особо словами не разбрасывайся.

t184256 ★★★★★ ()
Ответ на: комментарий от snaf

Да нет, сам демон работает, перебором выяснил что проблема в директиве Match как только ее прописываешь ssh просто не стартует, убираешь ее из конфига, все запускается, я не понимаю почему это происходит, кстати незнаю как в Debian но в Ubuntu Server нет никакой разницы между

Subsystem sftp /usr/lib/openssh/sftp-server

и

Subsystem sftp internal-sftp

работает и так и так, но вот с Match не знаю как быть в openssh начиная с версии 4.9 есть возможность пользователей по их «хомякам» раскидывать, вот этого и хочу добиться но не получается. Netfilter не запущен, в логе auth.log ничего нет, очевидно кешируется. Короче уже устал незнаю как быть.

georgy_barkovsky ()
Ответ на: комментарий от t184256

Форум тематический и под словом коллеги я подразумеваю людей увлеченных Linux

georgy_barkovsky ()

Во-первых, ssh -vvv попробуй. Во-вторых, покажи логи ssh-сервера.

generator ★★★ ()

iptables его не блокирует часом? А вообще - это в Admin вопрос

upcFrost ★★★★★ ()

Решено

Совсем забыл про эту ветку)

В общем если кому нибудь это будет интересно, то решение следущее, SFTP не функционировал должным образом из-за директивы Match, так как эта директива действует на все, что находится после нее, пока не дойдет до следующей Match. В большенстве статей опубликованных в интернете про sftp, таких нюансов не описывается. Поэтому настройки sftp нужно прописывать в самом-самом конце файла конфигурации sshd.config

Вот пример реально рабочей конфигурации (самый конец файла sshd.config):

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#sftp-server
Subsystem sftp internal-sftp

Match User mary
    X11Forwarding no
    AllowTcpForwarding no
    ForceCommand internal-sftp
    ChrootDirectory /home/%u

где пользователь mary, при соединении с сервером, попадает в свою домашнюю директорию. Хочу обратить внимание на то, что конкретно в Ubuntu Server, нет никакой разницы между:

Subsystem sftp /usr/lib/openssh/sftp-server

и

Subsystem sftp internal-sftp

sftp работать будет и так, и так. Конкретно я решил не отходить от «классической» настройки, поэтому оставил Subsystem sftp internal-sftp. Если необходимо настроить вход для нескольких пользователей, то лучше для этого создать отдельную группу. Если группу создавать не хочется, да и пользователей всего-то, две, три учетки. То прописывать их следует в таком порядке, строго «в столбик», если прописать пользователей одной строкой, даже через запятую, то работать не будет:

Пример настройки sftp для нескольких учетных записей:

Match User user1
Match User user2
Match User user3
    X11Forwarding no
    AllowTcpForwarding no
    ForceCommand internal-sftp
    ChrootDirectory /home/%u

Надеюсь мой пост будет кому то полезен, данную тему считаю закрытой.

georgy_barkovsky ()
Ответ на: Решено от georgy_barkovsky

Re: Решено

Спасибо!!! Помогло!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.