LINUX.ORG.RU

Интернет-банк невзлюбил wheezy

 , ,


1

3

Не могу зайти в интернет-банк с двух компьютеров с debian wheezy на борту, с компьютера с jessie - могу, с компьютера с виндой - тоже могу. «Проблема при загрузке страницы» вместо сайта.
Браузеры firefox от 31.2 до 36 (пробовал доступные варианты, результат не меняется совершенно).
Локальная сеть и параметры подключения одни и те же.
В техподдержке банка сидит телефонная барышня, которая чередует ответы обновить/перезагрузить/у нас все работает.
У меня пока только только две гипотезы:
1. В wheezy устаревшая версия пакетов, которые отвечают за шифрование.
2. Банк блочит по юзерагенту в каких-то своих целях (например, чтобы на него не набегали какие-нибудь ботнеты).
С другими сайтами проблем не замечено.
Куда копать? Никто не сталкивался с подобными чудесами?
P.S. в секьюрити пишу по вдохновению, т.к. проблема может быть с шифрованием.
P.P.S. Попробовал убунту 14.04 - тоже заходит открывается.

шифрование непричём, у фф же свои ссл, тлс. ну проверь с конкьюеррора, сменив там ЮА.

darkenshvein ★★ ()
Ответ на: комментарий от darkenshvein

Сравнил два юзерагента на одинаковых версиях лисы на jessie и на wheezy. Они абсолютно одинаковые до знака. Тем не менее на wheezy не открывается сайт.
Сейчас попробую другой браузер на всякий случай.
Midori тоже не осиливает.

siphonops ★★★ ()
Последнее исправление: siphonops (всего исправлений: 1)

не приватбанк случаем? а то у меня не открывается в iceweasel (deb 7)

mul4 ★★★★★ ()

хотя, в банках кодеры обычно упоротые фанатики синих животных сидят...

darkenshvein ★★ ()
Ответ на: комментарий от darkenshvein

Я не могу понять механизм этой проблемы. Как вообще и почему сервер определяет разные версии операционной системы с одинаковыми браузерами, одинаковыми юзерагентами, одинаковым ip, одинаковыми настройками сети (хотя в этом может быть подвох), вычисляет среди них wheezy и не отвечает ему. Причем на два компьютера с wheezy отличается между собой довольно сильно. Один - десктоп с мате на борту, присоединенный по проводу и настройками сети рулит пресловутый network-manager. Второй - ноут с i3, wicd, который ходит в сеть по вафле.
А на точно таком же, как и первый, десктопе с jessie (тоже мате, тоже nm, тоже провод) все работает. На ноуте с виндой тоже все работает.
Вот как так?

siphonops ★★★ ()

«Проблема при загрузке страницы» вместо сайта.

до или после ввода логина/пароля ?

1. В wheezy устаревшая версия пакетов, которые отвечают за шифрование.
2. Банк блочит по юзерагенту в каких-то своих целях (например, чтобы на него не набегали какие-нибудь ботнеты).

обе эти причины устанавливаются/опровергаются при помощи developers tools/firebug и/или wireshark/tcpdump

maloi ★★★★★ ()
Ответ на: комментарий от siphonops

может быть сломан pmtu discovery в ядре, тогда уменьшение mtu на интерфейсе должно помогать.

maloi ★★★★★ ()

1. В wheezy устаревшая версия пакетов, которые отвечают за шифрование.

Недавно было оюновление libssl.

tailgunner ★★★★★ ()
Ответ на: комментарий от maloi

до или после ввода логина/пароля ?

Вообще сайт не открывается.

обе эти причины устанавливаются/опровергаются при помощи developers tools/firebug и/или wireshark/tcpdump

Спасибо. Вечером попробую этим воспользоваться.

siphonops ★★★ ()
Ответ на: комментарий от tailgunner

Недавно было оюновление libssl.

Все обновления поставлены. Секурные репозитории на месте.

siphonops ★★★ ()
Ответ на: комментарий от maloi

может быть сломан pmtu discovery в ядре, тогда уменьшение mtu на интерфейсе должно помогать.

Но сначала попробую это, т.к. симптомы совпадают.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Проверь вообще содержимае запросов. Посмотри, что там еще кроме юзерагента передается.

hlebushek ()

Внезапно, хромиум осилил этот интернет-банк, и я отложил решение этой проблемы на будущее (когда jessie релизнется, потребности в нем не будет).

siphonops ★★★ ()

Попробовал убунту 14.04 - тоже заходит открывается.

вывод: пользуйся нормальным дистрибутивом - убунтой!

umren ★★★★★ ()

Дебианом не пользуюсь, так что на 100% не уверен. Но помню, что в дебиане бэкпорты есть/были для лисы. И еще есть какие-то репозитории с firefox'ом под разные версии дебиана.

anonymous ()

твой браузер отображается как iceweasel. Поставь юзер-агент firefox и будет всё в порядке.

snaf ★★★★★ ()
Последнее исправление: snaf (всего исправлений: 1)

Интернет-банк не на java случаем?

fbiagent ★★★ ()

To umren:

вывод: пользуйся нормальным дистрибутивом - убунтой!

У «нормального» дистрибутива - убунты, такого рода проблем значительно больше. Это не голословное утверждение, т.к. я достаточно долгое время пользовался 9.04, 9.10, 10.04, 11.04 и сосем недавно имел возможность пообщаться с 14.04, которая просто поражает воображение количеством пакетов с костыльными патчами.
To anonymous:

Но помню, что в дебиане бэкпорты есть/были для лисы.

Все подключено, пробовал в т.ч. последнюю на тот момент версию лисы 36.0.1, от версии браузера это не зависит.
To shooter93:

А curl пробовал?

Не потребовалось ввиду того, что хромиум осилил этот интернет-банк.
To snaf:

твой браузер отображается как iceweasel. Поставь юзер-агент firefox и будет всё в порядке.

Возможно я неясно описал это в топике, но jessie c iceweasel версии 31 и 36 открывает этот банк с дефолтным юзерагентом. У браузеров одинаковой версии на jessie и wheezy юзерагенты полностью идентичны.
To fbiagent:

Интернет-банк не на java случаем?

Нет. Вообще никаких сторонних плагинов не использует.

siphonops ★★★ ()
Ответ на: комментарий от mul4

Канитель с Приватом нежно лечиться UserAgent Switcher или как его там.

После этого принимает юзерагент даже от Iphone 3 и Гуглбот, на ПК с Iceweasel :D

Twissel ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.