LINUX.ORG.RU

debian testing+Amarok 2.4.1+mysql server. Амарок не работает с внешней базой данных.


0

1

Добрый день, такая проблема. Амарок не хочет работать с базой данных mysql. Версии софта в заголовке, базу данных создал, параметры с базой в настройках амарок прописал. После перезапуска:

klasik@klasik-desktop:/usr/lib/kde4$ amarok --debug

amarok(4863)/kdecore (KLibrary) kde4Factory: The library «/usr/lib/kde4/amarok_collection-mysqlservercollection.so» does not offer a qt_plugin_instance function.
amarok(4863)/kdecore (KLibrary) kde3Factory: The library «/usr/lib/kde4/amarok_collection-mysqlservercollection.so» does not offer an «init_amarok_collection-mysqlservercollection» function.
amarok: [WARNING] [PluginManager] «Failed to get factory 'amarok_collection-mysqlservercollection' from KPluginLoader: Cannot load library /usr/lib/kde4/amarok_collection-mysqlservercollection.so: (/usr/lib/kde4/amarok_collection-mysqlservercollection.so: symbol __cxa_pure_virtual, version libmysqlclient_16 not defined in file libmysqlclient.so.16 with link time reference)»

И амарок не стартует, хочет отправить отчет об ошибке.

klasik@klasik-desktop:/usr/lib/kde4$ mysql -u amarok -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 9
Server version: 5.1.49-3 (Debian)

mysql> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| amarokdb |
+--------------------+
2 rows in set (0.02 sec)

mysql> use amarokdb;
Database changed
mysql> show tables;
Empty set (0.00 sec)

Пробовал также версию 2.4.0 из реп тестинга, та же ситуация. Подскажите плиз, в чем может быть проблема?

Cannot load library /usr/lib/kde4/amarok_collection-mysqlservercollection.so: (/usr/lib/kde4/amarok_collection-mysqlservercollection.so: symbol __cxa_pure_virtual, version libmysqlclient_16 not defined in file libmysqlclient.so.16 with link time reference)" 

Арчик/генточка ?

Jetty ★★★★★ ()
Ответ на: комментарий от Jetty

Блин, затупил :) Вижу что нет :)

Думаю проблема в том что намешалось веток.

Jetty ★★★★★ ()

проблема в кривом пакете, где же еще. Сам при апдейте на 2.4.0 напарывался, только у меня он не падал, а просто не видел коллекцию. Забил, переключил на встроенную базу. Ищи/пиши багрепорт

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.