LINUX.ORG.RU

Mint 10 (on Ubuntu 10.10) + Alsa + несколько приложений


0

1

привет всем,

OS: Mint 10
Hardware: Asus K40AB

Когда у меня играет плеер, то в браузере ютуб смотреть со звуком не могу.
использую альсу (устанавливал alsa-base, alsa-oss,..).
в etc asound.conf нет.

$ sudo alsactl init
Found hardware: «HDA-Intel» «VIA VT1708S» «HDA:11060397,10431523,00100000» «0x1043» «0x1523»
Hardware is initialized using a generic method

пробовал поставить pulse - тоже не получилось параллельного воспроизведения,
кроме того, возможно мне кажется, но на альсе звук на порядок чище.

собирал из исходников по инструкции http://help.ubuntu.ru/wiki/alsa

собралось вроде бы без ошибок.
но:

1. sudo: alsaconf: command not found
2. alsa-base.conf - не существует в /etc/modprobe.d/
3. Если звук играет в одном приложении, то в другом его не будет пока не прекращается в первом.

только что заметил что осталась предыдущая версия
$ alsactl -v
alsactl version 1.0.23

спасибо каждому кто поможет разрулить эту проблему :)

Ответ на: комментарий от anonymous

rmmod snd-pcm-oss; echo 'blacklist snd-pcm-oss' >>/etc/modprobe.d/modprobe.conf


Его c 10.10 там нет.

2ТС
Зачем на убунтах чего-то собирать? Есть бэкпорты пр. alsa-utils поставь.

amorpher ★★★★★ ()

Хех. У меня наоборот ситуация была: на FreeBSD какая-то устанавливаемая библиотека подтянула PulseAudio, и звук стал воспроизводится только в одном приложении, а плагин Gnash в браузере не воспроизводил ни единого звука, хотя раньше работал. Пока не посмотрел список пакетов и не удалил pulseaudio, звук одновременно в двух приложениях (gnash plug-in и exaile) не воспроизводился.

iZEN ★★★★★ ()

alsa

ССЗБ.

пробовал поставить pulse

Зачем ты его вообще удалял?

rafister ()
Ответ на: комментарий от GHhost

reply to GHhost

+alsa +dmix

пробовал-пробовал гуглить,
скручивал че-то среднее между несколькими манами.
после того как в ~ создал asound и asoundrc
звук пропал вообще (
есть одна и оч хорошо разжеванная инструкция?

reply to amorpher

Есть бэкпорты пр. alsa-utils поставь.

alsa-utils даж при сборке из исходников ставил самую последнюю 1.0.24 с deb пакета.

reply to rafister

Зачем ты его вообще удалял?

во имя моей большой наивности и доверчивости безоговорочной всем мануалам ( ибо пишут в 96% что перед установкой альсы обязательно нужно снести пульс. а пульс вначале совсем не хотел сам определять когда воткнуты наушники, а когда нет.

Spartanec ()
Ответ на: комментарий от Spartanec

>пробовал-пробовал гуглить,

скручивал че-то среднее между несколькими манами.
после того как в ~ создал asound и asoundrc
звук пропал вообще (
есть одна и оч хорошо разжеванная инструкция?

ты смеешся чтоли? http://alsa.opensrc.org/Dmix вторая в гугле блин.

GHhost ()

Спасибо тебе, добрый человек! Решился снести альсу и вернуть пульс. В результате траблы только с mpd

YYY ()
Ответ на: комментарий от YYY

>Решился снести альсу и вернуть пульс. В результате траблы только с mpd
это такой толстый троллинг?
с каких пор пульс способен заменить альсу? о_О
это разные вещи вообще-то

megabaks ★★★★ ()

засунуть что-то типа

pcm.!default {
    type             plug
    slave.pcm       "dmixer"
}

pcm.dmixer {
  type dmix
  ipc_key 1024
  slave {
    pcm 'hw:0'
  }
}

ctl.dmixer {
   type hw
   card 0
   device 0
}
pcm.dsp {
    type plug
    slave.pcm "dmixer"  
}
в /etc/asound.conf?
ну и потом перезапустить альсу или...тупо ребут

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>это разные вещи вообще-то

Посыпаю голову пеплом. Глупость сморозил. Надо больше спать

YYY ()
Ответ на: комментарий от megabaks

to megabaks:

засунуть что-то типа


дак видимо у меня в том-то и дело что что-то вроде система не хочет примать, нужно конкретно под аудиокарту и кодек.

$ lspci | grep «Intel HDA»
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

$ cat /proc/asound/card0/codec#0 | grep Codec
Codec: VIA VT1708S

в скайпе звука нет.
пульс полностью весь вынул.

$gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosrc'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesrc'

в меню есть устройств есть:
1. По умолчанию
2. VIA VT1708S Analog

Если выбрать по умолчанию - то при тесте пишет что Не удалось открыть устройство для воспроизведения.
Во втором случае конвеерами выступают
alsasink device=«hw:0,0»
alsasrc device=«hw:0,0»

настройка dmix для меня все прежняя загадка (
asoundrc и asound.conf пытался настроить - нужного результата нет.

Spartanec ()
Ответ на: комментарий от megabaks

to megabaks:
вставил в asound.conf предложенный Вами конфиг.
сейчас идеальная тишина в vlc, firefox, skype..тобишь всюду.

...так что думаю что все-таки под каждый случай видимо нужны уникальные настройки :(

Spartanec ()
Ответ на: комментарий от megabaks

Сменил.
Перегрузил альсу, заодно перегрузил ноут.

В доказательство что все вставляю согласно конфигу:

$ cat /etc/asound.conf
pcm.!default {
type plug
slave.pcm «dmixer»
}

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm 'hw:1'
}
}

ctl.dmixer {
type hw
card 1
device 0
}
pcm.dsp {
type plug
slave.pcm «dmixer»
}

P.S.
личное наблюдение.
В vlc и подобных программах, есть 2 выбора куда послать исходящий звук.
По умолчанию и HDA ATI SB: VT1708S Analog (hw:0,0)
Всюду выбирал второй из списка.

Spartanec ()
Ответ на: комментарий от megabaks

to megabaks сменил в конфиге pcm 'hw:0' на pcm «hw:0,0»

pcm.!default {
    type	plug
    slave.pcm	"dmixer"
}

pcm.dmixer {
  type dmix
  ipc_key 1024
  slave {
    pcm "hw:0,0"
  }
}

ctl.dmixer {
   type hw
   card 0
   device 0
}
pcm.dsp {
    type plug
    slave.pcm "dmixer"  
}

еще снял в Gnome Alsa Mixer галочку Mute со всех каналов.

так же нашел по ссылке вики инструкцию и конфиг похожий http://www.linux.org.ru/wiki/en/ALSA

Перегрузился. Звук все равно последовательный (используется приложениями по очереди), при использовании каждого из конфигов.

Не могу понять что я пропустил...

to amorpher

Поставь уже OSS4, там всё просто, как 3 рубля.

Нашел ссылочку. Но не уверен что моя карта захочет это поддерживать, кроме того не много знаю про OSS4. http://www.ubuntugeek.com/howto-install-oss4-in-ubuntu-10-04-lucid-for-better-sound-quality.html

Spartanec ()
Ответ на: комментарий от megabaks

to megabaks

$ aplay -l 
**** Список PLAYBACK устройств ****
карта 0: SB [HDA ATI SB], устройство 0: VT1708S Analog [VT1708S Analog]
  Подустройства: 2/2
  Подустройство №0: subdevice #0
  Подустройство №1: subdevice #1

Spartanec ()
Ответ на: комментарий от Spartanec

карта у меня одна

$cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfbcf4000 irq 16

Spartanec ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.