LINUX.ORG.RU

Помогите включить звук


0

1

В новых SuSe и Ubuntu звук есть, в текущем Crunchbang 2.6.32-5-686 (основан на Debian Stable) звука нет. Запускаем sudo alsactl init, получаем:

Unknown hardware: «HDA-Intel» «ATI ID aa01» «HDA:1002aa01,00aa0100,00100200» «0x103c» «0x3577» Hardware is initialized using a guess method

lspci|grep Audio дает 00:01.1 Audio device: ATI Technologies Inc Device 1314 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)

Полная информация здесь.

mplayer выдает: [AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory [AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave

Если создать ~/.asound.rc и указать card 1, mplayer начинает проигрывание без ошибок, но фактически звука нет. Как включить звук?

Deleted

Ответ на: комментарий от Deleted

Это потому что эта утилита была установлена ранее, а не потому что мнтры арча так изволили :)

f1xmAn ★★★★★ ()

Вероятно, дело в ядре. Можно ли мне доустановить недостающие модули, не ставя тестируемое ядро?

Deleted ()
Ответ на: комментарий от nixtrian

Звук начал работать в Puppy (у которого более новое ядро) после того, как в alsamixer я поднял громкость на speaker. Когда я выбираю ту же карту в Crunchbang, alsamixer не видет speaker. Что делать?

Deleted ()

Пришлось дополнительно ставить убунту, ибо там все без проблем работает (все равно для HD нужно проприетарные дрова сверху накатывать).

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.