LINUX.ORG.RU

Вертикальная синхронизация видео при включенных эффектах KDE


0

1

«Разрывы» видео (т.е. отсутствие вертикальной синхронизации) наблюдаются при включенных эффектах KDE. При просмотре видео в полноэкранном режиме, разрывы пропадают (помогла опция TripleBuffer в xorg.conf).

Как можно добиться синхронизации видео в оконном режиме (при включенных эффектах KDE)?

Для вывода пробовал: Xvideo, Vdpau, gl2, gl_nosw (в общем, почти все, что есть в SMplayer). Пробовал и в VLC (также разные выводы, включая vdpau).

В настройках эффектов KDE установлен opengl и опция вертикальной синхронизации и вообще все, что указано в arch-wiki (http://wiki.archlinux.org/index.php/KDEmod#NVIDIA_graphics_card_KDE_4_perform...). Конечно, пробовал разные варианты.

Надо сказать, что с разрывами удавалось отлично бороться, когда монитор был поменьше (17").

======================================

Видеокарта: Nvidia GTS250 1000 Гб Процессор: Core i5 750 @ 2.67GHz Память: 4 Гб Система: 2.6.34-ARCH, KDE 4.4.5 Монитор: Benq 24", рабочее разрешение 1920*1080-60Гц

======================================

Мой xorg.conf (кроме устройств ввода):

http://pastebin.com/bUxHYbde


попробуйте дрова 256.44 установить, если не поможет, тогда отключайте композит в конфиге.

Sky777 ()
Ответ на: комментарий от Sky777

не Ъ!
надо бороться!
ТС - а в настройках нвидии пробовал ставить?
З.Ы. что люди нашли в этом квине?...

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

> ТС - а в настройках нвидии пробовал ставить?

конечно, пробовал. и для xv, и для opengl (и в разных комбинациях)

З.Ы. что люди нашли в этом квине?...

не знаю. :) я неделю на кедах... в гноме таже фигня, если что.

piko ()
Ответ на: комментарий от piko

о_О
свежие дрова пробовал?
компиз с sync to Vblank в его настройках?

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

> свежие дрова пробовал?

256.44 стоят.

компиз с sync to Vblank в его настройках?

когда был компиз, то vsync включал. и частоту равную частоте монитора выставлял. не помогало. но повторюсь: когда был монитор поменьше, то на этом же железе все работало отлично. такое ощущение, что если где-то увеличить какой-нибудь буфер (фиг знает какой), то это поможет. но какой и где?.. да, может быть, и нет никакого.

piko ()
Ответ на: комментарий от piko

ну в том же компизе есть размер уст-ва вывода...
а так хз

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

в ксорге выставлен трипл - благодаря этому хотя бы в полном экране смотрю нормально. также в настройке кде эффектов пробовал и трипл и дабл.

piko ()
Ответ на: комментарий от piko

>хотя бы в полном экране смотрю нормально
не распарсил - это окно плеера в полный экран или фулскрин?

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>не распарсил - это окно плеера в полный экран или фулскрин?

фуллскрин.

кстати, если поверх видео в фуллскрине появляется какое-то окошко (например, скроллбар smplayer'a), то появятся и «разрывы».

piko ()
Ответ на: комментарий от megabaks

>бррр - так а чего ещё не хватает?

чтобы и в оконном режиме видео не «рвалось».

piko ()
Ответ на: комментарий от piko

кстати, если поверх видео в фуллскрине появляется какое-то окошко (например, скроллбар smplayer'a), то появятся и «разрывы».

Это, кстати, известный баг - https://bugs.kde.org/show_bug.cgi?id=177495, по ссылке и вариант обхода предложен:

You can disable unredirecting the following way:

1. open ~/.kde/share/config/kwinrc in an editor

2. go to section [Compositing]

3. Add following line:

UnredirectFullscreen=false

4. Save file and restart kwin (alt+f2 and kwin --replace)

Мне помогло.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.