LINUX.ORG.RU

Нет звука на Linux Mint 19.1

 


0

1

Помогите пожалуйста!!Нет звука.Купил Lenovo chromebook n20.Надоела система Ghrome os,и установил Linux.Alsamixer говорит что card: intel hdmi\dp lpe audio и по середине This sound device does not have any controls.На сайте про этот chromebok написано звуковая карта Intel Valleyview SoC - HD Audio Controller. ПОМОГИТЕ!!! Уже 2 недели не могу сделать звук!! И да я новичок в Linux.

Ответ на: комментарий от lolik3232

Покажи какие модули используются по идеи длжен быть snd_hda_inte

lsmod |grep  snd[code\]
Попробуй перезагрузить модуль 

 sudo  modprobe snd_hda_intel
и глянь алсамиксер
anonymous ()
Ответ на: комментарий от anonymous

loli@loli-Clapper:~$ lsmod |grep snd

snd_hda_intel 40960 0

snd_hda_codec 126976 1 snd_hda_intel

snd_hda_core 81920 2 snd_hda_intel,snd_hda_codec

snd_hwdep 20480 1 snd_hda_codec

snd_hdmi_lpe_audio 24576 0

snd_pcm 98304 4

snd_hda_intel,snd_hda_codec,snd_hdmi_lpe_audio,snd_hda_core

snd_seq_midi 16384 0

snd_seq_midi_event 16384 1 snd_seq_midi

snd_rawmidi 32768 1 snd_seq_midi

snd_seq 65536 2

snd_seq_midi,snd_seq_midi_event

snd_seq_device 16384 3

snd_seq,snd_seq_midi,snd_rawmidi

snd_timer 32768 2 snd_seq,snd_pcm

snd 81920 9

snd_seq,snd_seq_device,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_hdmi_lpe_audio,snd_pcm,snd_rawmidi

soundcore 16384 1 snd

loli@loli-Clapper:~$ sudo modprobe snd_hda_intel

перезагрузить не получается,опять ничего не происходит

lolik3232 ()
Ответ на: комментарий от lolik3232

Ну можно создать /etc/modprobe.d/alsa.conf с содержанием

options snd_hda_intel index=1
и перезагрузиться

так аналоговый модуль будет первым грузиться вместо hdmi

и проверить появился ли в алсамиксере

если не поможет надо ждать владельцев подобных аппаратов может подскажут

anonymous ()
Ответ на: комментарий от Samsky

loli@loli-Clapper:~$ aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]

Subdevices: 0/1

Subdevice #0: subdevice #0

card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]

Subdevices: 1/1

Subdevice #0: subdevice #0

lolik3232 ()

Lenovo chromebook n20

Это ультрабук, верно? Если это так, то скорее всего аудиокарта не определяется ядром, определилось только HDMI выход, а аналоговая аудюха - нет. Поэтому хочу узнать версию ядра и рекомендую поставить самое новое ядро.

[Отсюда](https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.3/) , например.

Skullnet ★★ ()
Последнее исправление: Skullnet (всего исправлений: 3)