LINUX.ORG.RU

Устроновка apulse Linux Mint 18.3

 , , ,


0

1

Сначала скажу, что в Linux я полный профан. Все что здесь указано, было найдено с помощью поисковых запросов.

Как и многих меня достал PulseAudio с его проблемами. Решил поделиться опытом установки apulse 32-бита (для Skype) на Linux Mint 18/3 xfce с нуля.

  1. sudo apt-get update
  2. sudo aptitude install git cmake libasound2-dev libglib2.0-dev libglib2.0-0:i386 libasound2-dev:i386 build-essential gcc g++ gcc-multilib
  3. sudo git clone https://github.com/i-rinat/apulse apulse1
  4. cd ~/apulse1/
  5. sudo mkdir build && cd build
  6. sudo CFLAGS=-m32 cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
  7. sudo rm CMakeCache.txt
  8. sudo make
  9. sudo rm CMakeCache.txt
  10. sudo make install

Набор пакетов определял по поиску по ошибкам. Могут быть указаны лишние пакеты. Так же проверил на Ubuntu Mate 16.04 - работает.

Удаление CMakeCache.txt необходимо для Linux Mint. В Ubuntu make стартует и так.

Спасибо i-rinat за столь нужную программу!

Linux Mint 18/3 xfce с нуля.

Для начала 32 бита или 64?

Как и многих меня достал PulseAudio с его проблемами.

Присоединюсь к вопросу выше. Какими проблемами?

AfterWork ()
Ответ на: комментарий от AfterWork

Для начала 32 бита или 64?

64

Присоединюсь к вопросу выше. Какими проблемами?

Тема не о проблемах PulseAudio, а о проблемах установки apulse, с которыми я столкнулся и, кажется, решил. В процессе вываливалось несколько ошибок, которые я долго гуглил, пробовал всякое, и решил оформить то что вышло в итоге отдельным постом.

Спасибо, за проявленное участие!

alxleo ()
Ответ на: комментарий от alxleo

Тема не о проблемах PulseAudio

Ну и что? Раз уж ты говоришь что у него есть проблемы, то назови их! Я вот ни одной проблемы с пульсой не испытовал, все всегда работает автоматически и не надо лезть и править конфиг файлы

playX ★★ ()