LINUX.ORG.RU

Gentoo нет звука

 , , ,


1

2

Привет, всем! При настройке gentoo никак не запустить звук. Помогите, плз.

cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc1310000 irq 27
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xc0020000 irq 28
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
Установлены alsa, pulseaudio.
cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe -march=native -mtune=native"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2 -gnome -kde -minimal -qt4 dbus jpeg lock \
     session startup-notification thunar udev X alsa consolekit acl \
     alsa-plugin"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
VIDEO_CARDS="radeon"
INPUT_DEVICES="evdev synaptics"
LINGUAS="ru"

Системдэ или опенрц? посто в системдэ работает из коробки, а сопенрц надо делать дополнительные телодвижения.

Deleted ()
Ответ на: комментарий от Deleted

Не знаю как, но аудио запустилось. Вот действия. Удалил этот юз, пересобрал мир. Поставил pavu, там всё на 100%. Вернул юз, пересобрал мир. удалил себя из группы audio. Так и не понял, в чём всё-таки была проблема... Хотя, наверное, я ещё сегодня пересобрал ядро с драйверами аудио как модули и добавил очерёдность PCH, HDMI...

heaven__12 ()
Ответ на: комментарий от heaven__12

Пожалуйста.
Бывает, что в pulseaudio очередность устройств появляется неправильная, такое бывает, но очень редко, обычно когда одно устройство удалишь, а потом перелогинтшься/перезагрузишься. А из группы audio, думаю, что ты зря юзера удалил.

Deleted ()
Ответ на: комментарий от Deleted

Руководствовался этой фразой

Important For ConsoleKit/Systemd Logind managed permissions to be respected no one may be part of the audio group (not even even the user pulse). Remove any and all users from the audio group

PulseAudio uses:

sys-fs/udev and sys-auth/consolekit

heaven__12 ()
Ответ на: комментарий от Deleted

Системдэ или опенрц? посто в системдэ работает из коробки, а сопенрц надо делать дополнительные телодвижения.

Толсто.

Meyer ★★★★★ ()
Ответ на: комментарий от Bfgeshka

Попробуй обновиться до 4.2 хотя бы, в 4.0 и 4.1 были прошлемы со звуком HDA у штеуда.

Как раз наоборот. С кодеком от Conexant на 4.2 порой возникает kernel panic.

Meyer ★★★★★ ()

ТС, добавь себя в группу audio, включи поддержку нужного кодека в ядре, и не пиши всякие локальные use-флаги в make.conf, тогда будет тебе счастье.

Meyer ★★★★★ ()
Ответ на: комментарий от Meyer

В 4.0 сделали какое-то переименование именно для HDA у интела, не работало точно. Заработало стабильно только с 4.2.

Conexant

Вопросы к ним. У VIA, например, так, как выше описал.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Deleted

Дык мануал говорит, что пульс использует sys-auth/consolekit или Systemd, далее идёт предупреждение, что при использовании ConsoleKit нужно всех удалить из audio group. Или я не так что-то понимаю?

heaven__12 ()
Ответ на: комментарий от Meyer

См. сообщение выше. Не понимаю, почему я должен быть в audio. Сейчас без этого всё работает.

heaven__12 ()
Ответ на: комментарий от Meyer

Ничуть, ручных правок конфигов в случае системдэ нет.

Deleted ()
Ответ на: комментарий от heaven__12

кстати, да. всегда мой user был группе audio и всегда работало, даже счас с pulseaudio.

удалил user'a из audio, согласно wiki

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)
Ответ на: комментарий от heaven__12

я так понимаю, двойное обеспечение доступа к аудиокарте - излишне, т.е. если есть ConsoleKit/Systemd-logind и PulseAudio, то добавлять user'a в группу audio - overhead.

Deleted ()
Ответ на: комментарий от heaven__12

оно и так и эдак. В вики рекомендуют-с. А пашет оно при любых, если в группе audio.

dodevich ()
Последнее исправление: dodevich (всего исправлений: 1)

Вообще порядок такой. Правишь ядро. Устанавливаешь pavucontrol, если пульса, добавляешь поддержку в make.conf (pulseaudio) для всех приложений, хряпаешь pavu. там тебе и заноют, что нет доступа, если не завел consolekit, или не состоишь в группе и т.д. Так как не пользуюсь DE, просто ставлю pulse и завожу пользователя в audio. Всё, никаких больше настроек не нужно, работает без dbus, consolekit и т.д.

dodevich ()
Ответ на: комментарий от deity

Не заработало из коробки по вики, грешил на драйвера в ядре. Потом выяснилось, что инит-скрипт писать надо. У мня несколько юзеров и если один был залогинен - у второго звука небыло. Сначала поставил в SYSTEM_WIDE, потом переехал на системдэ.

Deleted ()
Ответ на: комментарий от deity

Может быть, конечно, я не претендую на полную правоту.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.