LINUX.ORG.RU

Иногда пропадает подсветка синтаксиса в постах

 , ,


0

1

Заметил такое вот сегодня: иногда пропадает подсветка синтаксиса в созданном мной посте.

В частности, в посте содержимое моего конфига ~/.config/fontconfig/fonts.conf, которое я скопипастил с тегом code=XML (не знаю, как экранировать здесь код, так как «code=XML» в квадратных скобках вообще исчезает).

Помогает обновление страницы по F5, но не всегда с первого раза, иногда приходится и по несколько раз обновлять.

Вот как это выглядит: раз (как и должно быть), два (без подсветки).

★★★★★

Всегда так было. Это лор.

anonymous ()

Подсветка генерируется на клиенте с помощью highlight.js. Может, у тебя скрипт не грузится?

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Подсветка срабатывает через раз. Firefox 66.0.3 и после сегодняшнего обновления до 66.0.4. Что со старым профилем, что с чистым.

Gonzo ★★★★★ ()
Ответ на: комментарий от Gonzo

В новой вкладке жмёшь Ctrl-Shift-i, выбираешь вкладку Сеть (Network), вбиваешь в адресной строке адрес, жмёшь Enter. В общем, там будет список запросов и их результатов.

i-rinat ★★★★★ ()
Ответ на: комментарий от Gonzo

Шрифты у тебя страшные. А ещё иконочный шрифт не подгрузился. Ты их блокируешь, что ли?

Скрипт вроде закеширован, с этим проблем нет. Может, во вкладке Console есть какая-то ругань?

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Да нормальные шрифты вроде... Tahoma, отключен антиалиасинг и снята галка с «Allow pages to choose their own fonts». Привык так уже. Не люблю «размазню».

Gonzo ★★★★★ ()
Ответ на: комментарий от i-rinat

Как-то странно в консоли: когда синтаксис подсвечен, то расширение lorify-ng прерывает соединение. Когда синтаксис не подсвечен, то вот так.

Gonzo ★★★★★ ()
Ответ на: комментарий от i-rinat

Кажется, отбой. Это lorify-ng блокирует подсветку. Отпишу разработчику.

Gonzo ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)