LINUX.ORG.RU

Дикие тормоза. DMA?


0

0

Недавно тут пробегал топик с подобной проблемой, но я его что-то не нашел. В FAQ тоже смотрел, там решение описано, но оно мне не помогло. В общем, проблема, думаю, ясна из сабжа: во время операций с диском система начинает жутко тормозить. Говорят, что это из-за того, что не включен DMA. В ядре я его включил. hdparm говорит следующее:

root@friday kppp # hdparm -d 1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)

В чем может быть дело и как это исправить?

Re: Дикие тормоза. DMA?

чипсет в студию плиз :)

ну и кусок конфига ядра после

> # IDE chipset support/bugfixes

gr_buza ★★★★ ()
Ответ на: Re: Дикие тормоза. DMA? от gr_buza

Re: Дикие тормоза. DMA?

чипсет via km400

#
# IDE chipset support/bugfixes
#
CONFIG_IDE_GENERIC=y
CONFIG_BLK_DEV_CMD640=y
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
# CONFIG_BLK_DEV_IDEPNP is not set
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_IDEPCI_SHARE_IRQ=y
# CONFIG_BLK_DEV_OFFBOARD is not set
CONFIG_BLK_DEV_GENERIC=y
# CONFIG_BLK_DEV_OPTI621 is not set
CONFIG_BLK_DEV_RZ1000=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
# CONFIG_BLK_DEV_IDEDMA_FORCED is not set
CONFIG_IDEDMA_PCI_AUTO=y
# CONFIG_IDEDMA_ONLYDISK is not set
# CONFIG_BLK_DEV_AEC62XX is not set
# CONFIG_BLK_DEV_ALI15X3 is not set
# CONFIG_BLK_DEV_AMD74XX is not set
# CONFIG_BLK_DEV_ATIIXP is not set
# CONFIG_BLK_DEV_CMD64X is not set
# CONFIG_BLK_DEV_TRIFLEX is not set
# CONFIG_BLK_DEV_CY82C693 is not set
# CONFIG_BLK_DEV_CS5520 is not set
# CONFIG_BLK_DEV_CS5530 is not set
# CONFIG_BLK_DEV_HPT34X is not set
# CONFIG_BLK_DEV_HPT366 is not set
# CONFIG_BLK_DEV_SC1200 is not set
CONFIG_BLK_DEV_PIIX=y
# CONFIG_BLK_DEV_NS87415 is not set
# CONFIG_BLK_DEV_PDC202XX_OLD is not set
# CONFIG_BLK_DEV_PDC202XX_NEW is not set
# CONFIG_BLK_DEV_SVWKS is not set
# CONFIG_BLK_DEV_SIIMAGE is not set
# CONFIG_BLK_DEV_SIS5513 is not set
# CONFIG_BLK_DEV_SLC90E66 is not set
# CONFIG_BLK_DEV_TRM290 is not set
# CONFIG_BLK_DEV_VIA82CXXX is not set
# CONFIG_IDE_ARM is not set
# CONFIG_IDE_CHIPSETS is not set
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_IDEDMA_IVB is not set
CONFIG_IDEDMA_AUTO=y
# CONFIG_BLK_DEV_HD is not set

Thomas ()
Ответ на: Re: Дикие тормоза. DMA? от Thomas

Re: Дикие тормоза. DMA?

хм... у меня без него все пашет.

попробуй включить все, и пересобрать ядро.

потом попробуй натравить хдпрм на винт - если пройдет, значит все ок, и никуда больше лезть не надо :))

gr_buza ★★★★ ()
Ответ на: Re: Дикие тормоза. DMA? от gr_buza

Re: Дикие тормоза. DMA?

имею в виду все BLK_DEV'ы :)

просто подредактируй ручками конфиг, и make тебе в руки :))

gr_buza ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.