LINUX.ORG.RU

Непонятность с sys-devel/gcc

 ,


0

1

После установки по хэндбуку, поставил kde. Установлен gcc-4.6.3 .

Ставлю нужный софт и замечаю, что устанавливается sys-devel/gcc-4.5.4 . Ну, ладно, едем дальше. Делаю emerge --depclean и удаляется sys-devel/gcc-4.5.4 . Делаю emerge -uDavN world , portage хочет установить sys-devel/gcc-4.5.4 .

Дальше- по циклу:

Делаю emerge --depclean и удаляется sys-devel/gcc-4.5.4 . Делаю emerge -uDavN world , portage хочет установить sys-devel/gcc-4.5.4 .

В чем может быть дело, как решать?


equery d sys-devel/gcc-4.5.4

Deleted ()

хочет установить

Так он только хочет, или уже когда-то завершался полный emerge world? можно дорисовать -t в параметры, и посмотреть кто же его хочет

vasily_pupkin ★★★★★ ()

Это значит, что для сборки какого-то пакета нужен gcc данной версии, но его в системе нет. Поэтому система ставит его для сборки, собирает пакет, а после сборки - может смело его удалить. Потом, когда вы пересобираете мир, он снова ставится.

l0stparadise ★★★★★ ()
gcc-config -l

покажет версии GCC, ну и дальше выбрать нужную через gcc-config.

iVS ★★★★★ ()
Ответ на: комментарий от Deleted

# equery d sys-devel/gcc-4.5.4
* These packages depend on sys-devel/gcc-4.5.4:
sys-devel/llvm-3.1-r2 (>=sys-devel/gcc-3.0)
sys-libs/glibc-2.15-r3 (>=sys-devel/gcc-3.4.4)
(arm ? >=sys-devel/gcc-4.1.0)
(x86 ? >=sys-devel/gcc-4.3)
(amd64 ? >=sys-devel/gcc-4.3)
(ppc ? >=sys-devel/gcc-4.1.0)
(ppc64 ? >=sys-devel/gcc-4.1.0)
virtual/fortran-0 (sys-devel/gcc[fortran,openmp?])
www-client/firefox-17.0.8 (pgo ? >=sys-devel/gcc-4.5)

www-client/firefox собран без pgo

Skala ()
Ответ на: комментарий от vasily_pupkin

Удаляет версию 4.5.4.
А вот emerge -uDavN world опять хочет поставить эту версию.

Skala ()
Ответ на: комментарий от vasily_pupkin

emerge -uDavNt world Ничего особенного не пишет. Просто хочет поставить 4.5.4 и все.

Skala ()
Ответ на: комментарий от markelov

Я же и говорю- ничего не стоит. Вот такая красота:

# emerge -uDavNt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild NS ] sys-devel/gcc-4.5.4:4.5 [4.6.3:4.6] USE=«cxx gtk mudflap (multilib) nls nptl (-altivec) -doc (-fixed-point) -fortran -gcj (-hardened) (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc -openmp -regression-test -vanilla» 0 kB

Skala ()
Ответ на: комментарий от Skala

Дык может он у тебя просто с world листе?

Вообще у тебя тут написано, что тебе поставят новый gcc новым слотом, так что это ничего не значит. Снеси 4.5.4 и спробуй ще

vasily_pupkin ★★★★★ ()
Ответ на: комментарий от Skala

В качестве костыля можно просто замаскировать его - внести в /etc/portage/package.mask строку:

<sys-devel/gcc-4.6.0
markelov ()
Ответ на: комментарий от vasily_pupkin

... а потом на --depclean удалить, и на обновлении мира, снова зачем-то ставить ... =(
Не пойму я, что его просит.
Может это что подскажет (USE из make.conf) :

USE=«bindist mmx sse sse2 policykit dbus consolekit sqlite udev infinality lcdfilter \
utf8 utf unicode slang mpg123 pda -mysql ffmpeg \
xvid win32codecs cdr dvdr aac vorbis ogg dri asf ipv6 -cups -cjk \
bzip2 iconv -fortran opengl alsa ncurses ssl -debug \
-zeroconf gstramer glitz jpg png gif jpeg mikmod gpm nls \
pdf jack mp3 man live esd a52 dts \
xml avi dvdread divx4linux dv encode fame mpeg \
quicktime subtitles matroska real theora skins wxwindows xosd xv \
bitmap-fonts truetype-fonts type1-fonts dvd \
doxywizard glib -hal plugins vst midi \
truetype fontconfig cdparanoia cpudetection wma mad rar rar% spell \
libsamplerate libsamplerate% mad% ladspa%* ladspa flac \
xcomposite -gnome ftp gtkhtml icq imagemagick jabber javascript \
jpeg2k mng mplayer openal oscar portaudio wmf type1 ntfs nvidia tiff \
caps xfs reiserfs amrnb amrwb lzo speex xvmc wavpack \
mmap modplug vcd gnutls idn accessibility -samba svga sdl -mozilla \
-postgres usb chardet sndfile raw exif gimp \
startup-notification cairo libnotify -ldap pch gphoto2 \
-eds -evo acpi apm pmu lzma disablexmb \
secure-delete v4l v4l2 vdpau \
-semantic-desktop bluray directfb ggi -puleaudio qt vaapi nvidia -radeon -video_cards_radeon»

Skala ()
Ответ на: комментарий от Skala

* These packages depend on sys-devel/gcc-4.5.4:

Не выглядит так, как если бы его тянул кто-то из пакетов.

gcc-config -l
и
emerge --info sys-devel/gcc
в студию.

Deleted ()
Ответ на: комментарий от vasily_pupkin

Дык может он у тебя просто с world листе?

Я не думаю, что он мог там остаться после --depclean. К тому же

[ebuild NS ]

намекает, что пакет ставится новый, а не обновляется.

Deleted ()
Ответ на: комментарий от Skala

Ничего страшного не увидел, за исключением всяких спецсимволов после некоторых флагов в USE.

Попробуй выполнить emerge -NuDpvte @world |& grep -B3 gcc
Да, и на всякий случай grep gcc /var/lib/portage/world

Deleted ()
Ответ на: комментарий от Skala

Во, видишь, 4.5.3 в списке больше нет. Тогда просто пересобери мир с ключом -e.

Deleted ()
Ответ на: комментарий от Deleted

Нет, нет,- я ошибся: Выдавал emerge -NuDpvte @world |& grep -B3 gcc , когда по совету markelov добавил в /etc/portage/package.mask строку:

<sys-devel/gcc-4.6.0

Когда убрал эту строку, то emerge -NuDpvte @world |& grep -B3 показал это (по-моему, ничем не отличается):

http://bpaste.net/show/132159/

Но portage все также хочет поставить старую версию gcc.

Skala ()
Ответ на: комментарий от Skala

Но portage все также хочет поставить старую версию gcc.

Не вижу. В пасте кроме :4.6 другого слота нет.

Deleted ()
Ответ на: комментарий от Deleted

Спасибо за помощь!
Решение было таким: пересбор мира ( emerge -eav world ).

Skala ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.