LINUX.ORG.RU

Ошибка при установке MATE 1.6.0 на Gentoo


0

2

Пишет при установке mate-common-1.6.2:

....
Cannot find $EPATCH_SOURCE!
....
Это вроде как ему (mate-common'у) не удается найти патч в папке:
/var/lib/layman/mate/mate-base/mate-common/files
А в этой папке у меня:
# ls /var/lib/layman/mate/mate-base/mate-common/files
mate-common-1.6.1-automake-1.14.patch
Пробовал изменить версию этого патча в папке на 1.6.2, патч нашелся, но не подошел.

Также есть версия mate-common-1.7.0, но ее поставить не получилось, т.к. emerge не мог скачать ни с одного из зеркал архив с исходником, да и не известно, заработал бы с этим пакетом mate.

Что делать?

Ответ на: комментарий от fbiagent

в сам ebuild заглядывал?

Да.
Вы предлагаете не патчить этот пакет, как это было задумано теми, кто писал ебилд?

Glaciuse ()

Там же есть мета-пакет с GNOME2.

anonymous ()

Что делать?

Ставить Gnome 2.32 из стабильной ветки.

Скажи мне, зачем тебе MATE, если второй гном до сих пор в стабильной ветке Генты?

neocrust ★★★★★ ()
Ответ на: комментарий от neocrust

В общем поправил ебилд, удалил оттуда патч и все поставилось.

Скажи мне, зачем тебе MATE, если второй гном до сих пор в стабильной ветке Генты?

А зачем вообще форкнули Gnome 2 и сделали MATE?

Glaciuse ()
Ответ на: комментарий от Glaciuse

А зачем вообще форкнули Gnome 2 и сделали MATE?

Чтобы пользоваться привычным окружением в тех дистрибутивах, где второй гном больше не доступен. Gentoo - не из их числа.

neocrust ★★★★★ ()
Ответ на: комментарий от neocrust

А где вообще можно посмотреть сколько по времени еще будет поддерживаться гном 2 в генту?

cheburashko ()
Ответ на: комментарий от cheburashko

Сам бы хотел это узнать.

Можешь спросить это на Генту-форуме, в конференции или в рассылке.

neocrust ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.