LINUX.ORG.RU

Обновление Фанту привело к мерцанию окна терминала и диалогов xfce

 , , ,


0

1

здравствуйте! обновил мир, теперь терминал мигает - окно частично или полносью исчезает при наведении на кнопки свернуть закрыть, или просто при выполнении команд.

также диалоговые окна xfce исчезают, вот пример нажатие кнопки старт https://itmag.es/5tFvQ меню при дижении мышки то появляется, то исчезает — мигает.

есть предположение что это из-за ошибки zlib

# emerge zlib
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-libs/zlib-1.2.11::core-kit
 * zlib-1.2.11.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...               [ ok ]
>>> Unpacking source...
>>> Unpacking zlib-1.2.11.tar.gz to /var/tmp/portage/sys-libs/zlib-1.2.11/work
>>> Source unpacked in /var/tmp/portage/sys-libs/zlib-1.2.11/work
>>> Preparing source in /var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11 ...
 * Running eautoreconf in '/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11/contrib/minizip' ...
 * Running libtoolize --install --copy --force --automake ...            [ ok ]
 * Running aclocal ...                                                   [ ok ]
 * Running autoconf --force ...                                          [ ok ]
 * Running automake --add-missing --copy --foreign --force-missing ...   [ ok ]
 * Running elibtoolize in: zlib-1.2.11/contrib/minizip/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.3 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11 ...
 * abi_x86_32.x86: running multilib-minimal_abi_src_configure
/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11/configure --shared --prefix=/usr --libdir=/usr/lib32 --uname=linux
Using ar
Checking for shared library support...
No shared library support; try without defining CC and CFLAGS
Building static library libz.a version 1.2.11 with x86_64-pc-linux-gnu-gcc -m32.
Checking for size_t... No.
Checking for long long... Yes.
Failed to find a pointer-size integer type.
** /var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11/configure aborting.
 * ERROR: sys-libs/zlib-1.2.11::core-kit failed (configure phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  115:  Called src_configure
 *   environment, line 3203:  Called multilib-minimal_src_configure
 *   environment, line 2458:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2672:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2388:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2386:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  491:  Called multilib-minimal_abi_src_configure
 *   environment, line 2452:  Called multilib_src_configure
 *   environment, line 2903:  Called die
 * The specific snippet of code:
 *               echoit "${S}"/configure --shared --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/$(get_libdir)" ${uname:+--uname=${uname}} || die
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/zlib-1.2.11::core-kit'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/zlib-1.2.11::core-kit'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/zlib-1.2.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/zlib-1.2.11/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11'

>>> Failed to emerge sys-libs/zlib-1.2.11, Log file:

>>>  '/var/tmp/portage/sys-libs/zlib-1.2.11/temp/build.log'

 * Messages for package sys-libs/zlib-1.2.11:

 * ERROR: sys-libs/zlib-1.2.11::core-kit failed (configure phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  115:  Called src_configure
 *   environment, line 3203:  Called multilib-minimal_src_configure
 *   environment, line 2458:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2672:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2388:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2386:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  491:  Called multilib-minimal_abi_src_configure
 *   environment, line 2452:  Called multilib_src_configure
 *   environment, line 2903:  Called die
 * The specific snippet of code:
 *               echoit "${S}"/configure --shared --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/$(get_libdir)" ${uname:+--uname=${uname}} || die
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/zlib-1.2.11::core-kit'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/zlib-1.2.11::core-kit'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/zlib-1.2.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/zlib-1.2.11/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-libs/zlib-1.2.11/work/zlib-1.2.11'

как решить проблему? до обновления рабоало нормально.

# cat /etc/portage/make.conf
MAKEOPTS="-j5"
LINGUAS="en_US ru_RU"
L10N="en-US ru-RU"

CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"

CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

VIDEO_CARDS="intel"

USE="alsa dbus core-kit flv introspection 
     jpeg mp3 networkamager nsplugin  
     ppapi png 
     udev policykit 
     X zlib
     -gnome -gtk -kde -qt3 -qt4
     -wicd"

PYTHON_TARGETS="python2_7 python3_4"
PYTHON_SINGLE_TARGET="python3_4"

скрипт обновления:

# cat ~/re.sh
emerge --sync
eix-update

emerge -avuND --with-bdeps=y --complete-graph=y --backtrack=30 --keep-going --verbose-conflicts --exclude "chromium gentoo-sources gimp glibc libreoffice perl python gcc" world

lenovo x552e, intel, xorg, xfce, dbus,

★★

поставь генту, зачем страдать через день.

xaTa ★★★ ()

не установились несколько частей xorg, например:

checking for i686-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc -m32
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/x11-proto/randrproto-1.5.0/work/randrproto-1.5.0-abi_x86_32.x86':
configure: error: C compiler cannot create executables
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-proto/randrproto-1.5.0/work/randrproto-1.5.0-abi_x86_32.x86/config.log
 * ERROR: x11-proto/randrproto-1.5.0::xorg-kit failed (configure phase):
 *   econf failed
 * 
 * Call stack:

.....
>> Failed to emerge x11-proto/randrproto-1.5.0, Log file:

>>>  '/var/tmp/portage/x11-proto/randrproto-1.5.0/temp/build.log'



....Next pasted to pastebin.com :.....

# cat /var/tmp/portage/x11-proto/randrproto-1.5.0/temp/build.log


# cat /var/tmp/portage/x11-proto/randrproto-1.5.0/work/randrproto-1.5.0-abi_x86_32.x86/config.log

https://pastebin.com/y45FDbiQ

gcc 5.3.0

# gcc -v
Используются внутренние спецификации.
COLLECT_GCC=/usr/x86_64-pc-linux-gnu/gcc-bin/5.3.0/gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-pc-linux-gnu/5.3.0/lto-wrapper
Целевая архитектура: x86_64-pc-linux-gnu
Параметры конфигурации: ../gcc-5.3.0/configure --disable-libssp --disable-multilib --enable-version-specific-runtime-libs --enable-libmudflap --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/5.3.0 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/5.3.0/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/5.3.0/include/g++-v5.3.0 --enable-libstdcxx-time --enable-__cxa_atexit --enable-clocale=gnu --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --with-system-zlib --enable-obsolete --disable-werror --enable-secureplt --enable-lto --without-cloog --with-bugurl=http://bugs.funtoo.org --with-pkgversion='Funtoo 5.3.0-r1' --with-mpfr-include=/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/gcc-5.3.0/mpfr/src --with-mpfr-lib=/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir/mpfr/src/.libs --enable-libgomp --build=x86_64-pc-linux-gnu --enable-libgomp --enable-languages=c,c++,fortran --disable-libgcj --disable-esp --disable-libsanitizer
Модель многопоточности: posix
gcc версия 5.3.0 (Funtoo 5.3.0-r1)


# uname -a
Linux localhost.localdomain 4.8.15-1 #1 SMP Mon Jul 24 15:58:06 -00 2017 x86_64 Intel(R) Pentium(R) CPU N3530 @ 2.16GHz GenuineIntel GNU/Linux


znavko ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.