LINUX.ORG.RU

Ubuntu Server 12.04 x64 + Lenovo U400 + SSD OSZ = черный экран

 , , , ,


0

1

Ноут Lenovo U400 + SSD mSata NOC 60G Ставлю на него Ubuntu Server 12.04 x64 с флэхи записанной dd с образа. Всё ставится замечательно, но... После установки происходит перезагрузка, видим меню GRUB и все после выбора любого пункта имеем черный экран и полный фриз, реагирует только на POWEROFF. Вход в консоль GRUB тоже с косяками в частности нажатие tab приводит к зависанию и спасение тоже только POWEROFF.

Если грузится в режиме восстановления с установочного образа, то разделы монтируются без проблем и с SSDой можно работать.

/dev/sda1 - /boot - ext4 /dev/sda2 - / - ext4 grub установлен на /dev/sda

Внимание вопрос. Что сделать чтобы можно было работать с ноутом?

Ответ на: комментарий от ololoid

ArchLinux, даже до граба не доходит, если быть точнее пишет GRUB2 welcome! или что-то в этом роде потом черный экран (увидел надпись путем записи на камеру и замедленного воспроизведения). Аналогично установочный образ грузился нормально.

bogdan-zuy ()

Если я правильно понял, то:

При загрузке системы после первого экрана нажимаете shift, чтобы появился grub.

Потом нажимаете e. появляется окно с параметрами.

В предпоследней строке, к-я начинается со слова linux удаляете последнее значение, к-е начинается с $ и вводите nomodeset.

Если система загрузится, ставьте jockey-gtk и видеодрайвера.

cinyflo ★★★★★ ()
Ответ на: комментарий от cinyflo

Значения начинающегося с $ нет, добавление nomodeset ситуации не изменило.

setparams 'Ubuntu, c Linux 3.2.0-29-generic'

recordfail
gfxmode $linux_gfx_mode
insmode gzio
insmode parts_msdos
insmode ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root (ЮИД1)
linux /vmlinuz-3.2.0-29-generic root=UUID=(ЮИД2) ro
initrd /initrd.img-3.2.0-29-generic

bogdan-zuy ()

у всех бубунт на этой архитектуре такая бага вылазит, исключая некоторые альфы и беты. я думаю у каноникал это фича такая.

funeralismatic ★★★ ()
Ответ на: усли у тебя ivi bridge то ... от Astin

Re: усли у тебя ivi bridge то ...

Поставил ядро 3.5 (с ppa:upubuntu-com/kernel-amd64) ситуация не изменилась. Есть еще предположения?

bogdan-zuy ()

через dd записал образ ubuntu 10.04 server, выбрал загрузку с него, в итоге через несколько секунд попал обратно к своему grub меню, но о чудо он грузится в recovery mode (nomodeset). Но это только если через флэшку с образом ubuntu 10.04. Даже запустился графический режим с lightdm + openbox с корявым разрешением, но при попытке установить ati-шные драйвера при перезагрузке (также через флэшку) черный экран, просто черный экран ctrl+alt+del в отличии от пред. ситуации приводит к перезагрузке.

И так вопрос, далее почему через флэху грузиться, хоть и кое как но грузится, а без нее жесткий фриз?

С атишными дровами позже разбираться буду для начала нужно загрузится не с пихача.

bogdan-zuy ()

Итог, стоило сделать первым устройством не SSD, а ODD и вуаля система грузится, так... Кто знает почему так происходит? Ну да ладно. Если кому-то интересно, что же все таки было дальше... Так вот, загрузился, дальше как обычно, только пришлось отключить радионовскую карту, очень греется. И работаю пока на GDI. Тему пока не закрываю ибо все таки интересно почему грузится только если не первое устройство.

bogdan-zuy ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.