LINUX.ORG.RU

X-сервер не запускается на 2-ом экране


0

0

При запуске GDM появляется на двух экранах, но Gnome запускается только с нулевого. При попытке войти с 1-ого появляется ошибка:

Xlib: connection to "0.0" refused by server Xlib: No protocol specified

В gdm.conf настроил на 2 экрана, в xdm.conf :0 и :1 локальные сервера. Два сервера и стартуют, но на второй не пускает. А раньше всё работало по умолчанию. Потом переинсталился и началось... Подскажите пожалуста в чём дело!

Алексей Ремнёв


Re: X-сервер не запускается на 2-ом экране

я эти файлы вообще не трогал!!!

я просто в XF86Config 2 монитора прописал и все

выглядит примерно вот так:


Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Samsung"
        ModelName    "Samsung SyncMaster 700p Plus (CSH7839*)"
        Modeline "1280x1024" 135.00   1280 1284 1428 1636   1024 1033 1036 1062
+hsync +vsync
        HorizSync    30.0 - 85.0
        VertRefresh  50.0 - 160.0
EndSection
                                                                                
Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "nvidia"
        BoardName   "Unknown video card"
        VideoRam    131072
        Option      "DPMS"
        Option      "NvAGP" "3"
        Option      "TwinView"
        Option      "NoDDC"
        Option      "TwinViewOrientation" "LeftOf"
        Option      "SecondMonitorHorizSync" "30-85"
        Option      "SecondMonitorVertRefresh" "60-90"
        Option      "MetaModes" "1280x1024,1280x1024"
        Option      "TVOutFormat" "COMPOSITE"
        Option      "ConnectedMonitor" "CRT,TV"
        Option      "TVStandard" "PAL-B"
        BusID       "PCI:1:0:0"
EndSection

berkuf ()

Re: Re: X-сервер не запускается на 2-ом экране

У меня один монитор.
Мне надо несколько сессий на vt7,vt8 и т.д.
что бы разные юзера сидели на своих экранах
и не мешали друг другу.
После некоторых поисков записал в /etc/X11/xdm/Xservers:

:0 A local /usr/X11R6/bin/X :0
:1 B local /usr/X11R6/bin/X :1

Загружаю XDM и с 2-х экранов вхожу Гномом.
Вероятно ошибка в gdm.conf. Если кто его настраивал, подскажите!

ran ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.