LINUX.ORG.RU

Проблема с ./configure


0

0

Запускаю ./configure, а он выдает error: Can't find X includes. Что это и где его искать?

И еще вопрос: что делать, если при компиляции выдает, что пакет не установлен, а в действительности все установлено?

На ФАК отсылать не надо - я там уже был и devel проставил.

Re: Проблема с ./configure

ftp://ftp.asplinux.ru/pub/i386/RPMS.9.2/XFree86-devel-4.3.0-42.i386.rpmc&...://ftp.asplinux.ru/pubЮ>>.../i386/RPMS.9.2/XFree86-devel-4.3.0- 42.i386.rpmc&#65 535;ftp://ftp.asplinux.ru/pub/i386/RPMS.9.2/XFree86-de>Can't find X includes. Что это и где его искать? vel-4.3.0-42.i386.rpmc&#6553 5;ftp://ftp.asplinux.ru/pub/i386/RPMS.9.2/XFree86-devel-4.3.0-42.i386.rpmc&...://ftp.asplinux.ru/pub/i386/RPMS.9.2/XFree86-devel-4.3.0-42.i386.rpmc&#65535... XFree86-devel

>что делать, если при компиляции выдает, что пакет не установлен, а в действительности все установлено?

поискать в google сообщение об ошибке :)

anonymous ()

Re: Проблема с ./configure

Смотри config.log

Для каждого проводимого теста там пишется, что делается. Для неудавшихся - пишутся исходники тестовых программ и то, что выдано на stderr при компиляции. Так что, должно быть понятно, где и что программа хочет найти.

Если то, что надо уже стоит, но не там, то можно попытаться объяснить ./configure где оно лежит.

Куда смотреть:

1. ./configure --help

2. info Autoconf "Running configure Scripts", если есть.

Вот маленькая цитатка оттуда:

For packages that use the X Window System, `configure' can usually find the X include and library files automatically, but if it doesn't, you can use the `configure' options `--x-includes=DIR' and `--x-libraries=DIR' to specify their locations.

> В пакетах, использующих X Window System, `configure' обычно находит заголовочные файлы и библиотеки X'ов автоматически, но если нет, Вы можете использовать опции `configure' `--x-includes=DIR' и `--x-libraries=DIR' чтобы указать их месторасположение.

watashiwa_daredeska ★★★★ ()

Re: Проблема с ./configure

Тут есть еще тонкость. Если ты поставил xorg-x11-devel (т.е. у тебя не XFree и XFree86-devel), то для версии 6.8.1 возможно придется доставить пакет xorg-x11-deprecated-libs-devel (как-то так).

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.