LINUX.ORG.RU

а в выньде-то звук есть? ну или в бубунте.

anonymous ()
Ответ на: комментарий от anonymous

или мб по-дефолту звук выводится не в тот канал, например rear

anonymous ()
Ответ на: комментарий от anonymous

До этого ставил ASPLinux и звук был(до ASPLinux были форточки и звук был, собственно все определения об устройствах прежде переписал, чтобы легче было с орентироваться), т.к. ASPLinux не устраивает решил ставить gentoo!

FA70H ()

Ну во-первых, вы выполнили не все рекомендации, которые вам дали на форуме gentoo.ru.

Вам сказали проверить уровни громкости каналов вывода звука в alsamixer и их статус «MUTE» или нет., для этого запускаете alsamixer и клавишами влево вправо выбираете шкалу (канал) и клавишей вверх устанавливаете уровень громкости на максимум, после чего проверяете состояние кагала на «MUTE», если внизу под шкалой стоит «MM», то нажимаете клавишу «M», что бы стало «00», этим вы разрешите вывод звука на канал.

┌──────────────────────────── AlsaMixer v1.0.24.2 ─────────────────────────────┐
│ Card: HDA NVidia                                     F1:  Help               │
│ Chip: Analog Devices AD1988B                         F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0.00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      >
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │OO│              │OO│     │MM│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100 100<>100   0<>0   100<>100   100       │
│  < Master >Headphon   PCM     Front   Front Mi Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘

Какая у вас звуковая карта покажите вывод команды:

/usr/sbin/lspci | grep -i audio

У меня к примеру так:

/usr/sbin/lspci | grep -i audio
00:0e.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]

Так же стоит проверить конфигурацию вашего ядра, выполните команду:

/usr/sbin/lspci -n

и её вывод (весь) скопируйте в поле ввода на этом сайте: http://kmuto.jp/debian/hcl/ и нажмите «Check», в выведенной таблице будут указаны устройства вашего компьютера и в последней графе опции ядра, которые нужно включить для их поддержки, найдите вашу звуковую карту и проверьте опции её поддержки в ядре.

Так же покажите вывод команды:

cat /proc/asound/cards

Если у вас в выводе присутствуют две карты то можно выбрать карту по-умолчанию.

Вообще с вероятностью в 100 процентов вы сможете найти решение своей проблемы почитав руководство по alsa в wiki Linux.org.ru: http://www.linux.org.ru/wiki/en/ALSA

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Благодарен за замечание=)

Ну во-первых, выполнил все рекомендации, которые мне дали на форуме gentoo.ru=) ALSAmixer по несколько раз в день проверяю что бы ни где не было «ММ»...

Во-вторых, команда: /usr/sbin/lspci | grep -i audio, разве не равносильна команде: lspci -v | grep -i audio, вот мой вывод для тех кто не желает просматривать gentoo:

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)

В-третьих, вывод cat /proc/asound/cards, есть на gentoo, но для особых вновь привожу пример:

0 [Live ]: NFORCE - NVidia CK8S NVidia CK8S with ALC655 at irq 23

Благодарен тебе kostik87 за столь познавательную ссылку: http://kmuto.jp/debian/hcl/index.rhtmlx , без обид, но лучше с этого и надо было начинать... Вывод команды: /usr/sbin/lspci -n (соответственно через указанную выше ссылку, т.е вывод был введен в поле предоставляющее ссылкой), подтверждает что в ядре, как мне кажется, порядок:

PCI ID Works? Vendor Device Driver Kernel

10de00e1 Yes nVidia Corporation nForce3 250Gb Host Bridge amd64-agp

10de00e0 nVidia Corporation nForce3 250Gb LPC Bridge

10de00e4 Yes nVidia Corporation nForce 250Gb PCI System Management i2c-nforce2 v2.6.25-

10de00e7 Yes nVidia Corporation CK8S USB Controller usb-ohci,ohci-hcd

10de00e7 Yes nVidia Corporation CK8S USB Controller usb-ohci,ohci-hcd

10de00e8 Yes nVidia Corporation nForce3 EHCI USB 2.0 Controller ehci-hcd

10de00df Yes nVidia Corporation CK8S Ethernet Controller forcedeth v2.6.25-

10de00ea Yes nVidia Corporation nForce3 250Gb AC'97 Audio Controller snd-intel8x0 v2.6.25-

10de00e5 Yes nVidia Corporation CK8S Parallel ATA Controller (v2.5) pata_amd v2.6.25-

10de00e3 Yes nVidia Corporation nForce3 Serial ATA Controller sata_nv v2.6.25-

10de00e2 nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge

10de00ed nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge

10221100 Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration

10221101 Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map

10221102 Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller

10221100 Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration

10024152 Yes ATI Technologies Inc RV350 AR [Radeon 9600] radeonfb v2.6.25-

10024172 Yes ATI Technologies Inc RV350 AR [Radeon 9600] (Secondary) radeonfb,XFree86

FA70H ()

запускай alsamixer. проверь что бы не в одной колонки в низу НЕ БЫЛО MM. и выкрути их все процентов на 30.

nickionn ★☆ ()
Ответ на: комментарий от nickionn

[>nickionn<][запускай alsamixer. проверь что бы не в одной колонки в низу НЕ БЫЛО MM. и выкрути их все процентов на 30.]

Читай выше=(

FA70H ()
Ответ на: комментарий от FA70H

Ну если вы говорите что всё сделали верно, то проверьте ещё раз уровни громкости в alsamixer и статус канала, а затем выполните:

cat /dev/urandom > /dev/dsp
или если нет устройства /dev/dsp
cat /dev/urandom > /dev/audio 

Так же проверьте, что ваш пользователь находится в группе audio, если вы конечно не работаете в системе исключительно под пользователем root, что не правильно.

Так же после изменения уровней громкости в alsamixer не забудьте выполнить:

/etc/init.d/alsasound save
Для восстановления уровней запуска можете выполнить:
/etc/init.d/alsasound restore
И проверьте, что у вас alsasound присутствует в уровнях запуска:
/sbin/rc-update | grep alsa
Насчёт команд:
lspci -v - выдаёт подробный вывод, с указанием прерывания назначенного устройству, развёрнутого указания производителя оборудования, а не только его идентификатор в 16-ричном виде, размер выделенной памяти под модуль и собственно имя модуля, реализующего его поддержку.
lspci - выведет сокращённую информацию, идентификатор производителя и оборудования, указание подсистемы и название оборудования.

Я указал /usr/sbin/lspci, т.к. видно эта команда доступна только пользователю root, поэтому указал абсолютный путь, у обычных пользователей в переменной окружения PATH нет путей /sbin и /usr/sbin.

Выполните:

echo $PATH 
от root и обычного пользователя и сравните результат.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

cat /dev/urandom > /dev/dsp - сначала ни чего не выдавал

cat /dev/urandom > /dev/audio - в другом терминале выдал следующие: -bash: /dev/audio: Устройство или ресурс занято

затем сделал /etc/init.d/alsasound save и cat /dev/urandom > /dev/dsp - выдал следующие: -bash: /dev/audio: Устройство или ресурс занято, а в другом терминале cat /dev/urandom > /dev/audio - ни чего не выдавал!

Нахожусь под пользователем root, т.к. не знаю, вдруг что нужно будет подправить!

/sbin/rc-update | grep alsa - показывает что alsa не в автозапуске, т.к. его туда не помещал, каждый раз запускаю вручную!

echo $PATH - выдал следующие: /usr/local/sbin:/usr/local/bin:/usr/sbin/:/usr/bin:/sbin:/bin:/opt/bin:usr/i686-pc-linux-gnu/gcc-bin/4.4.5

PS: благодарю за разъяснение lspci, настраиваю звук без Х-в, но Х-ы стоят и работают - Fluebox!

FA70H ()
Ответ на: комментарий от FA70H

cat /dev/urandom > /dev/dsp - сначала ни чего не выдавал

Что значит сначала ничего не выдавал ?

Шипение / треск всё же было ?

/dev/audio и /dev/dsp устройства относятся к подсистеме oss., так же появляются если у вас в alsa включена поддержка oss.

у вас pulseaudio не используется ?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

[Что значит сначала ничего не выдавал ?]

не выводил ни каких сообщений!

[Шипение / треск всё же было ?]

буфер с колонками постоянно потрескивают, а если громкость регулировать, то прерывистое шипение усиливается!

pulseaudio - не используется!

FA70H ()
Ответ на: комментарий от FA70H

Хм, вы уверены, что вставили штекер в правильное гнездо аудио карты?

Сообщений ни каких и не должно быть должен выводиться шум, так как этими командами на звуковую карту выводятся случайные последовательности данных, следовательно если звуковая подсистема работает должен быть треск и шум. Всё же мне кажется что у вас что-то не правильно подключено, так же попробуйте поставить mute на канал микрофона, «Front Mic».

А сообщение о том что ресурс занят выводится потому, что по сути /dev/dsp и /dev/audio это одно устройства, а вы на разных консолях осуществляете на него вывод.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

штекер воткнут в самый правый разъем(имеется всего три разъема; раньше подключался другой буфер на все три разъёма, а который использую сейчас, подключается только к одному), т.к. на других компах мною было замечено что колонки с одним джеком подключаются в самый правый разъём!

Подключил наушники, и командой cat /dev/urandom > /dev/dsp значительно лучше прослушивается результат в отношении шумов/тресков, т.к. при отключении(^C) возникает тишина! Проигрыватель mplayer при запуске файла /home/Law4Riot.mp3, не выводит звук, но проигрывает звуковой файл!

FA70H ()
Ответ на: комментарий от FA70H

Так, звуковая подсистема у вас работает.

Попробуйте другой плеер, к примеру mpg123.

Или уже непосредственно в графической оболочке, от обычного пользователя, но не забудьте добавить его в группу audio.

kostik87 ★★★★★ ()
Ответ на: комментарий от FA70H

т.к. на других компах мною было замечено что колонки с одним джеком подключаются в самый правый разъём!

рукалицо.jpg

подключать надо в разъем audio out (обычно он светло-зеленого цвета) зы: он у меня из 3 разъемов в среднем.

fbiagent ★★★ ()
Ответ на: комментарий от fbiagent

SOLVED

Доброго времени суток! Прошу меня извинить за мою не внимательность, т.к. звуковая карта полноценно используется, но всё же опишу как я это выяснил. Во-первых, использовал Live-CD Knoppix 5.1.1, который при запуске воспроизводит звук! При запуске звука не было, но ради любопытства я подключил наушники и после перезагрузке звук звучал в наушниках! Затем выполнил следующие команды:

# cat /proc/asound/cards 0[CK8S ]: NFORCE -NVidia CK8S NVidia CK8S with ALC655 at irq 17 1[UART ]: MPU-401 UART - MPU-401 UART MPU-401 UART at 0x330, irq 10

# cat /proc/asound/oss/sndstat Sound Driver:3.8.1a-980706 (ALSA v1.0.14 emulation code) Kernell: Linux Knoppix 5.1.1

Config options: 0

Installed drivers: Type 10: ALSA emulation

Card config: NVidia CK8S with ALC655 at irq 17 MPU-401 UART at 0x330, irq 10

Audio devices: 0: NVidia CK8S (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: 1: MPU-401 UART MIDI

Timers: 31: system timer

Mixers: 0: Realtek ALC655 rev 0 1: mixer10

Из этого я сделал вывод, что возможно у меня две звуковые карты! После чего отыскав на этом лайве-диске звуковые файлы, я включал их на проигрывателе(который был в лайве-диске), и убедившись что звук воспроизводиться(в наушниках!), смонтировал свой hdd, а именно /home, и туда переместил несколько звуков! Но перед тем как отключиться от лайва-сд, попытался воспроизвести с монтированного /home звуковой файл(формата *.mp3), которым я до этого проверял звук в mplayer-е, но плейер выдал ошибку, из чего я сделал вывод что плейер с лайва-сд не поддерживает *.mp3!

Во-вторых, при установке gentoo, я также этими командами выводил значения файлов proc, и результат был темже, но об этом умолчал, т.к. не думал что у материнки может быть встроено две карточки. Ведь, прежде я через ХРюшу зарание переписал все данные о железе моего ПК. Но почитав отзывы на форуме, заметил что у некоторых всё же присутствует две карточки(поправте если ошубаюсь)! После чего в ядро добавил следующие значения:

Device Drivers ---> <*>Sound card support ---> Advanced Linux Sound Architecture ---> Generic sound devices ---> <M> UART16550 serial MIDI multiport MIDI <M> Generic MPU-401 UART driver

В третьих, после перекомпиляции ядра, звука серавно не было(подключил колонки в гнездо наушников!)! Запуская звуковой файл который прежде проигрывал в mplayer-е(файл в формате *.mp3) звука серавно не было слышно! После чего, также через mplayer, запустил один из скопированных звуков с лайва-сд, звук воспроизвёлся!

Моя проблема была в следующем: 1)скачанный мной звуковой файл оказался пустышкой(качал в консоли через wget на местном ftp); 2)колонки подключены через буфер, который подключил к задниму джеку, самому правому гнезду, ПК(до этого был другой буфер, который также был подключен сзади, но через три провода), т.к. шнур одни в отличие от бывшего буфера; 3)впервые столкнулся с ручной установкой linux, до этого всё делали бинарные дистрибутивы!

NOTICE! Пере компилировал ядро в прежнее состояние, т.е. убрал выше указанные значения, звук работал с одной карточкой(здесь возможно ошибаюсь, т.к. по второй карточки ни чего не делал, кроме как пере компиляция ядра!):

# cat /proc/asound/cards 0 [Live ]: NFORCE - NVidia CK8S NVidia CK8S with ALC655 at irq 23

!>подключать надо в разъем audio out (обычно он светло-зеленого цвета) зы: он у меня из 3 разъемов в среднем.

СОГЛАСЕН!

PS:Ещё раз прошу за свою невнимательность прощения, т.к. помощь мне была оказана полноценно, но из-за своей не опытности сглупил...

FA70H ()
Ответ на: SOLVED от FA70H

ну а я вам, что писал, что у вас не правильно подключены колонки (наушники) или что там у вас.

Вторая звуковая карта может быть встроенным кодеком звука в видео карту, если она у вас поддерживает HDMI, у меня карта Radeon HD, в неё встроен такой кодек.

Так же я вам давал ссылку на wiki LOR`а, где все ваши проблемы описаны и решены, а вы не удосужились посмотреть.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

>Так же я вам давал ссылку на wiki LOR`а, где все

Читал: www.linux.org.ru/wiki/en/ALSA , но: 1) я извиняюсь за свою слепоту и 2) напомню что звуковой файл оказался пустышкой! Благодарен твоим замечаниям!

FA70H ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.