LINUX.ORG.RU

Не запускается программный RAID при загрузке


0

0

Проблемы с запуском программного RAID при загрузке. Поставил ASPLinux 9.0, сконфигурировал RAID0 как в HOWTO написано, config переделал из raid0.conf.sample: raiddev /dev/md0 raid-level 0 # it's not obvious but this *must* be persistent-superblock 1 # set this to 1 if you want autostart, chunk-size 32 nr-raid-disks 2 nr-spare-disks 0 device /dev/hdb2 raid-disk 0 device /dev/hdc2 raid-disk 1 При загрузке RAID обнаруживается, но не запускается: md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27 md: Autodetecting RAID arrays. [events: 00000002] [events: 00000002] md: autorun ... md: considering hdc2 ... md: adding hdc2 ... md: adding hdb2 ... md: created md0 md: bind<hdb2,1> md: bind<hdc2,2> md: running: <hdc2><hdb2> md: hdc2's event counter: 00000002 md: hdb2's event counter: 00000002 kmod: failed to exec /sbin/modprobe -s -k md-personality-2, errno = 2 md: personality 2 is not loaded! md :do_md_run() returned -22 md: md0 stopped. md: unbind<hdc2,1> md: export_rdev(hdc2) md: unbind<hdb2,0> md: export_rdev(hdb2) md: ... autorun DONE.

Версия raidtools - 1.00.3-2 Весия драйвера (судя по dmesg) - 0.90.0 Может из за этого глючит ? Хотя, IMHO, более новая версия tools'ов должна поддерживать предыдущие версии драйверов. alias md-personality-2 raid0 в /etc/modules.conf не помогает. Прописал пока raidstart /dev/md0 и mount ... в rc.sysinit, работает, но это ж per anus. Подскажите, чем лечить subj ?

anonymous

Re: Не запускается программный RAID при загрузке

А RAID-партиции какую файловую систему имеют?

anonymous ()

Re: Re: Не запускается программный RAID при загрузке

Файловая система - Ext3, тип раздела - fd (Linux raid autodetect). Детектиться то оно детектится, но не запускается... А вручную все работает.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.