LINUX.ORG.RU

Проблемы с настройкой сети Debian 11.2

 , ,


0

1

Здравствуйте! Подскажите пожалуйста по настройкам сети. Первый раз устанавливаю Debian, при установке сеть не настроилась.

Сетевой кабель напрямую подключён в сетевую карту. Образ отсюда: https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/current/amd64/iso-cd/

Так что настраиваю без рабочего стола. В консоли вошёл под root команда dmesg | grep eth выводит два сетевых интерфейса eth0 и enp2s0 и что почему-то последний был переименован из eth0:

[1.073185] r8169 0000:02:00.0 eth0: RTL816evl/8111evl, 74:d4:35:b2:bb:ff, XID 2C9, IRQ 29
[1.073186] r8169 0000:02:00.0 eth0: jumbo features [frames: 9194 bytes, tx checksumming: ko]
[1.074390] r8169 0000:02:00.0 enp2s0: renamed from eth0

lspci | grep Ethernet выводит информацию о моей сетевой карте Realtek

ip addr выводит:

lo <LOOPBACK.. 
и 
enp2s0 <BROADCAST,MULTICAST,UP, LOWERUP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 74:d4:35:b2:bb:ff brd ff:ff:ff:ff:ff:ff
inet6 fe80:76d4:35ff:feb2:bbff/64 scope link
valid_lft forever preferred_lft forever

Никакие команды с eth0 не работают, если вносить в /etc/network/interfaces его имя то пишет ошибки, что таковой не найден.

Файл конфигурации /etc/network/interfaces изначально не имел других записей кроме iface lo inet loopback.

Только если использовать вместо eth0 имя enp2s0 ошибок не возникает, но и сеть не работает.

Что я сделал:

ifdown enp2s0 выводит:

interface enp2s0 not configured

внёс в файл /etc/network/interfaces строки:

auto enp2s0 iface enp2s0 inet dhcp

в файл /etc/resolv.conf

внёс строку: nameserver 8.8.8.8 (он был пуст)

после делал:

systemctl restart networking.service

ifdown enp2s0 выводит: interface enp2s0 not configured

когда запускал ifup enp2s0 то был вывод:

Listening on LPF/enp2s0/74:d4:35:b2:bb:ff
Sending on LPF/enp2s0/74:d4:35:b2:bb:ff
Sending on Socket/fallback
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 11
No DNCPOFFERS received.
No working leases in persistent database – sleeping.

При пинге 8.8.8.8 писал нет сети, потом ping google.com – временный сбой в разрешении имён.

Фото: http://vfl.ru/fotos/be35e28538136459.html

http://vfl.ru/fotos/7de6443e38136460.html


Здравствуйте.

Никакие команды с eth0 не работают, если вносить в /etc/network/interfaces его имя то пишет ошибки, что таковой не найден.

А вы читать вывод команд, который сами предоставили пробовали?

[1.074390] r8169 0000:02:00.0 enp2s0: renamed from eth0

Как это переводится?

Подуймайте.

В выводе

ip a

Должен присутствовать нужный вам сетевой адаптер, покажите его целиком.

Ну и заодно залейте на любой pastebin сервис вывод команды dmesg.

anonymous ()

Проверьте состояние провода, что он корректно обжат.

Так же у меня на ноутбуке Lenovo была проблема c Ethernet адаптером, вроде бы тоже Realtek, при загрузке драйвер в вывод dmesg выдавал сообщение о том, что он хочет загрузить в него прошивку и я установил пакет с прошивками для realtek. И как следствие ошибка о невозможности загрузить прошивку пропала.

Но при этом сетевая карта перестала работать, т.е. с загруженной прошивкой драйвер не работает. А без неё - работает.

Возможно у вас так же. Проанализируйте какие прошивки загружает драйвер и переместите файлы прошивок из /lib/firmware.

После чего перезагрузите систему и проверьте работу сетевого контроллера.

Но это пальцем в небо.

anonymous ()

No DNCPOFFERS received.

У тебя в локалке нету dhcp. Настрой айпи-адрес и гейт врчную. Например так

auto enp2s0
iface enp2s0 inet static
	address 192.168.1.2
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1

Только подставь свои адреса сети.

потом сделай ifup enp2s0

firkax ★★ ()
Ответ на: комментарий от firkax

В выводе ip a Должен присутствовать нужный вам сетевой адаптер, покажите его целиком. Ну и заодно залейте на любой pastebin сервис вывод команды dmesg.

Вывод dmseg и ip a попробую залить.

У тебя в локалке нету dhcp. Настрой айпи-адрес и гейт врчную."

Спасибо, попробую. Впервые ставлю Linux, может путь ошибок позволит быстрее изучить..

Просто не хотел статику прописывать, ведь, думал, раз сетевое подключение в винде находит dhcp (видимо в сети провайдера) - у меня в ней получение IP происходит динамически.

Я ещё не понимаю момент, ведь когда настраиваю сетевое подключение в винде, то прописываю пароль и логин пользователя выданный провайдером, тогда всё настраивается автоматически, видимо взаимодействие с dhcp-сервером как-то происходит, находит какой-то шлюз.

А при настройки сети в Debian должен же, по идее, где то запрашиваться ввод логина и пароля (или в конфигах быть прописано)? Иначе как провайдер позволит подключиться к своему шлюзу?

Подскажите, пожалуйста не совсем понимаю, какие адреса вводить в конфиг, Вот вывод ipconfig /all в винде:

Адаптер Ethernet Ethernet:

   DNS-суффикс подключения . . . . . :
   Описание. . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Физический адрес. . . . . . . . . : 74-D4-35-B2-BB-FF
   DHCP включен. . . . . . . . . . . : Да
   Автонастройка включена. . . . . . : Да
   Локальный IPv6-адрес канала . . . : fe80::7938:cbcf:63ad:559f%16(Основной)
   Автонастройка IPv4-адреса . . . . : 169.254.85.159(Основной)
   Маска подсети . . . . . . . . . . : 255.255.0.0
   Основной шлюз. . . . . . . . . :
   IAID DHCPv6 . . . . . . . . . . . : 108319797
   DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-24-BE-9F-18-74-D4-35-B2-BB-FF
   DNS-серверы. . . . . . . . . . . : 2001:4860:4860::8888
                                       2001:4860:4860::8844
                                       8.8.8.8
                                       8.8.4.4
   NetBios через TCP/IP. . . . . . . . : Включен
Адаптер PPP Internet:

   DNS-суффикс подключения . . . . . :
   Описание. . . . . . . . . . . . . : Internet
   Физический адрес. . . . . . . . . :
   DHCP включен. . . . . . . . . . . : Нет
   Автонастройка включена. . . . . . : Да
   IPv4-адрес. . . . . . . . . . . . : 5.138.105.138(Основной)
   Маска подсети . . . . . . . . . . : 255.255.255.255
   Основной шлюз. . . . . . . . . : 0.0.0.0
   DNS-серверы. . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBios через TCP/IP. . . . . . . . : Отключен

Попробовать такую настройку? Поправьте, пожалуйста, если не так:

auto enp2s0
iface enp2s0 inet static
	address 169.254.85.159
	netmask 255.255.255.255
	network 169.254.85.0
	broadcast 169.254.85.255
	gateway 0.0.0.0
djey ()

В чём заключается вопрос?

targitaj ★★★★★ ()

внёс в файл /etc/network/interfaces строки:

auto eth0 iface enp2s0 inet dhcp

Писали же уже, что у вас не eth0 интерфейс, а enp2s0. Его и указывайте в /etc/network/interfaces

iface enp2s0 inet dhcp
auto enp2s0
Flotsky ()
Ответ на: комментарий от djey

Иначе как провайдер позволит подключиться к своему шлюзу?

Ого, это ещё где-то нужно? Каменный век. Но в любом случае прописать всё можно, узнавай способ подключения и читай соответствующую документацию.

anonymous ()
Ответ на: комментарий от djey

Вот вывод ipconfig /all в винде: Адаптер PPP Internet:

Тогда в iface enp2s0 inet dhcp смысла нет и в статической адресации тоже, читайте как ваш провайдер предоставляет доступ в интернет и поднимайте это силами linux.

Вам точно нужен linux в таком виде? Может остаться на windows и гонять linux в virtualBox, пока не поймёте, что освоились?

Flotsky ()
Ответ на: комментарий от Flotsky

Да, извиняюсь, опечатка тут у меня, я enp2s0 вписывал в конфиг везде.

djey ()
Ответ на: комментарий от Flotsky

Надеюсь, через решение проблем может оказаться даже быстрее изучить Linux. В виртуалке проблем с сетью конечно нет, там он видимо использует уже настройки винды. Но хочется решить именно эту проблему.

djey ()

откуда ты взял все эти ifup, ifdown, /etc/network/interfaces?
В каком году была написана статья, из которой ты это взял?
сделай sudo dhclient -v enp2s0
сделай resolvectl dns enp2s0 8.8.8.8

anonymous ()
Ответ на: комментарий от djey

Автонастройка IPv4-адреса … . : 169.254.85.159(Основной)

Это означает, что dhcp-сервера нет и винда сама настроила частный адрес из avahi/bonjour/zeroconf-подсети 169.254* (https://ru.wikipedia.org/wiki/Zeroconf)

А дальше поднимается PPoE-туннель, и уже там выдаётся IP-адрес для работы.

anonymous ()
Ответ на: комментарий от kontranik

Попробовал оба способа:

Указал modules=ppp-udeb в начальном меню инсталлятора, но установщик не смог настроить PPPoE соединение, пишет, что не находит концетратор PPPoE.

Далее попробовал запустить pppoeconf, но пишет, что данной команды нет.

Возможно, стоит попробовать установиться не с такого куцего урезанного образа, где нет ничего? Посоветовали LiveCD образ с DVD.

djey ()
Ответ на: комментарий от djey

Тебе нужен любой LiveCD / DVD с которого ты сможешь загрузиться и поднять сеть.

Далее тебе нужно смонтировать корневую файловую систему установленного Linux, сделать chroot в систему и далее поставить нужные пакеты в установленный Linux.

anonymous ()

Загрузился с LiveCD там тоже команда pppoeconf недоступна. Не понимаю как установить этот пакет?

Появился, конечно, графический интерфейс, но не нашёл никаких настроек насчёт PPPoE.

Смотрел инструкции по настройки сети для Ubuntu там в NetworkManager есть вкладка DSL где и осуществляется ввод пароля и логина. Но в Debian не нашёл подобного, есть, правда, вкладка 802.1 security (если это оно), но все поля в её форме неактивны, ввод невозможен. Подскажите, пожалуйста, что делать или где искать?

djey ()
Ответ на: комментарий от anonymous

Спасибо, за более простой способ настройки, но возможно в данном случае, нет разницы как настроить dhcp, приходится решать проблему с настройкой PPPoE.

sudo pppoe-discovery не обнаруживает концентраторов PPPoE.

djey ()
Ответ на: комментарий от djey

нет, купить роутер - значить сдаться, и не изучить linux по-настоящему.

Shushundr ()

Спасибо всем! Проблема всё-таки решилась из gui. Оказывается просто надо было нажать «+» в окне «Сетевые соединения», внизу справа. Далее добавляется пункт DSL/PPPoE и т.д..

djey ()
Ответ на: комментарий от djey

замечательно!
теперь будем знать, что все твои последующие вопросы лучше просто игнорировать

anonymous ()
Ответ на: комментарий от djey

To enable or disable the WiFi, right click the network icon in the corner, and click “Enable WiFi” or “Disable WiFi.” When the WiFi adapter is enabled, single click the network icon to select a WiFi network to connect to. Type the network password and click “connect” to complete the proces https://www.clickercounter.org/spacebar-clicker

Noradavis ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.