LINUX.ORG.RU

Gentoo. Установлено уже вроде бы все что можно. Граб виснет, startx выдает рабочий стол без реакции на мышь, клавиатуру и тачпод.

 , , ,


0

1

USE=«gtk -gnome -kde xfce dvd alsa X cdr unicode qt5» INPUT_DEVICES=«evdev synaptics» VIDEO_CARDS=«nouveau intel»

x11-base/xorg-server x11-base/xorg-x11 x11-base/xorg-drivers

profile - default/linux/amd64/17.0/desktop (stable)

Все приложения крысы и драйвера тоже скачаны. Но я так понимаю не в крысе дело. В /etc нет X11.

Было проделано так же root #echo XSESSION=\«Xfce4\» > /etc/env.d/90xsession root #env-update && source /etc/profile

И все равно граб виснет при всех трех вариантах загрузки на одном и том же моменте, а команда startx из консоли - открывает дефолтную крысу которая абсолютно не реагирует на мышь, тачпод и кнопками даже не могу вызвать терминал дефолтный Alt+Ctrl+F1.


Ответ на: комментарий от anonymous

В дефолтом терминале в котором доделываю генту. Заново все монтирую после перезагрузки, хотя это перазгрузкой не назвать. На кнопку питания не реагирует крыса в которую захожу, приходится долго жать для резкого отключения питания.

jdncx ()

Если ты поставил пакет xorg-server, то директория /etc/X11 должна быть.

Что значит зависает grub?

Ядро запускается или нет?

Если ты используешь драйвер evdev в xorg-server`е, то в собранном ядре должны быть включена поддеркжа evdev.

Если ты сейчас запускаешь startx в chroot окружении, то смысла в этом нет.

Разберись что бы система запускалась с собранным ядром. Обычным способом.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Дак ставил же в чруте xorg-server. Ну граб с огромным разрешением начинает грузиться и останавливается на одном и том же моменте при всех трех вариантах загрузки генты через граб. Я иксы не могу настроить потому что нет /etc/X11. Я не знаю какой там драйвер используется. Сейчас докомпилируется обновление мира после изменений, и буду искать что не так с драйвером evdev.

jdncx ()

Комп не из времён Core 2 Duo? У меня был похожий баг на одной из сборок ядра на старой машине с интеловской интеграшкой. Вылечилось другим ядром, ничего не менял.

devzero ()
Ответ на: комментарий от jdncx

начинает грузиться и останавливается на одном и том же моменте при всех трех вариантах загрузки генты через граб

Каком? Где скриншот или что-то другое?

Я иксы не могу настроить потому что нет /etc/X11.

Уверен, что ты путаешь chroot окружение, в котором ставишь Gentoo и систему из которой ты ставишь Gentoo, т.е. Gentoo Minimal CD.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Увы у меня нет фотографирующих устройств кроме галимой дискретной вебки. Но для такого разрешения вывода граба, она сойдет. Закончится компиляция - и сфоткаю. Это еще часа пол. В обычном окружении после cd /mnt/gentoo тоже нет /etc/X11. На Minimal CD не захожу, оно ж не нужно.

jdncx ()
Ответ на: комментарий от AnDoR

Рач это слишком просто. Ты шо, в первый раз установить с бумажки (смартфона не было) за несколько часов после пробы на виртуалке. Не-не. Не годится. Так что терпите меня.

jdncx ()

А что Grub пишет? На каком этапе виснет? Дело, скорее всего, в неправильно собранном ядре. Было бы хорошо снимок экрана увидеть.

anonymous ()

— мама, посмотри, я сам компилирую и собираю мир, правда здорово? мне всё это очень нужно, иначе я не буду трушным гентушником и на лоре будут надо мной смеяться. а бинарные дистрибутивы говно, мне так старшие ребята сказали. — над тобой в любом случае будут смеяться, потому что ты не самостоятельный и у тебя нет своего мнения, дурачок.

anonymous ()
Ответ на: комментарий от jdncx

Только объясни почему он у тебя не установлен?

Если ты ставишь на любом профиле пакет xorg-server, т.е.

emerge -av xorg-server
или
emerge xorg-server
то пакет xinit будет установлен как зависимость.

И если он у тебя по какой-то причине не установлен - значит ты что-то уже покрутил руками.

Вот у тебя ничего и не работает.

kostik87 ★★★★★ ()