LINUX.ORG.RU

Funtoo сообщила о зависимостях

 ,


0

1

не получается произвести выполнение команды запуска начала установки пакетов в Funtoo.

# emerge firefox chromium libreoffice gimp mupdf --autounmask-write
Calculating dependencies /

!!! Problem resolving dependencies for app-office/libreoffice
... done!

!!! The ebuild selected to satisfy "libreoffice" has unmet requirements.
- app-office/libreoffice-5.2.7.2::desktop-kit USE="branding cups dbus gltf java (-aqua) -bluetooth -coinmp -collada -debug -eds -firebird -gnome -googledrive -gstreamer -gtk -gtk3 -jemalloc -kde -libressl -mysql -odk -pdfimport -postgres -quickstarter (-telepathy) -test -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5" PYTHON_TARGETS="python2_7 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) bluetooth? ( dbus ) collada? ( gltf ) eds? ( gnome ) gnome? ( gtk ) telepathy? ( gtk ) libreoffice_extensions_nlpsolver? ( java ) libreoffice_extensions_scripting-beanshell? ( java ) libreoffice_extensions_scripting-javascript? ( java ) libreoffice_extensions_wiki-publisher? ( java )


# cat /etc/portage/make.conf

MAKEOPTS="-j3" 
LINGUS="ru_RU en_US"
CFLAGS="-march=btver2 -O2 -pipe"
CXXFLAGS="${CFALGS}"
VIDEO_CARDS="radeon"

USE="alsa automount branding core-kit cups dbus 
     flv introspection
     gltf
     gtk
     java jpeg jpg mp3 networkamanger nls
     png
     policykit
     python python2_7  
     udev 
     X
     xfce4-meta
     -gnome -gtk -kde -minimal
     -qt4
     -static-libs"

PYTHON_TARGETS="python2_7"

PYTHON_SINGLE_TARGET="python3_4"
★★

Ответ на: комментарий от anonymous

не понимаю сообщения о -python2_7 :

# cat /etc/portage/make.conf
MAKEOPTS="-j3" 
LINGUS="ru_RU en_US"
L10N="ru"
CFLAGS="-march=btver2 -O2 -pipe"
CXXFLAGS="${CFALGS}"
VIDEO_CARDS="radeon"

USE="alsa automount branding bzip2 core-kit cups dbus 
     flv introspection
     gltf
     gtk
     java 
     jpeg jpeg2k jpg mp3 networkamanger nls
     nsplugin
     pam pdf png
     policykit
     python python2_7 
     ssl tiff truetype  
     udev webp wmf
     X
     xfce4-meta xml
     -gnome -gtk -kde -minimal
     -qt4
     -static-libs"

PYTHON_TARGETS="-python2_7 python3_4"

PYTHON_SINGLE_TARGET="python3_4"


# emerge firefox chromium  gimp mupdf
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Calculating dependencies -Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
 /Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
 /Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'


!!! Problem resolving dependencies for media-gfx/gimp
... done!

!!! The ebuild selected to satisfy "gimp" has unmet requirements.
- media-gfx/gimp-2.9.4-r2::media-kit USE="alsa jpeg2k pdf python udev wmf -aalib (-altivec) (-aqua) -debug -doc -gnome -mng -openexr -postscript -smp -test -vector-icons -xpm" CPU_FLAGS_X86="mmx sse" LINGUAS="-am -ar -ast -az -be -bg -br -ca -ca@valencia -cs -csb -da -de -dz -el -en_CA -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -lt -lv -mk -ml -ms -my -nb -nds -ne -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -rw -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -tt -uk -vi -xh -yi -zh_CN -zh_HK -zh_TW" PYTHON_TARGETS="-python2_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( python_targets_python2_7 )

Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'

znavko ★★ ()
Ответ на: комментарий от Bruce_Lee

по идее разработчика генту - самая производительная система, так как оптиизирует софт под конктерную аппаратуру.

фанту - следующий этап разработки.

я не вижу разницы между генту и фанту.

ставить фанту сложнее, и она может зависать (что на данный момент у меня случается раз в день). но фанту придумана как что-то лучшее, чем генту.

разработчик экспериментирует с настройками, чтобы найти способ оптимизировать систему.

у меня получается настроить на ноутбуке, но каждый раз с подсказками, так как в документации не расписаны мои вопросы.

znavko ★★ ()
USE="python_targets_python2_7 python_single_target_python2_7" emerge libreoffice

Или то же самое, но с 3_4, не скопом, а только либру.

А чего у тебя в make.conf нет CPU_FLAGS_X86="" ?

Bruce_Lee ★★ ()

emerge firefox chromium libreoffice gimp mupdf

Судя по -j3, у тебя на это уйдет половина дня.

BceM_IIpuBeT ★★☆☆☆ ()
Ответ на: комментарий от BceM_IIpuBeT

это вот так?

PYTHON_SINGLE_TARGET="python3_4"
PYTHON_TARGETS="{$PYTHON_SINGLE_TARGET} python2_7"
znavko ★★ ()

Держи нас в курсе.

anonymous ()
Ответ на: комментарий от znavko

дАрагой, я тебе зачем разжевал про пистоно-таргеты?

Ты эту доку прочел?

Зачем после этого ты пишешь

у меня получается настроить на ноутбуке, но каждый раз с подсказками, так как в документации не расписаны мои вопросы.

и городишь в своем конфиге ерунду?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.