LINUX.ORG.RU

не загружается Debian после установки

 , ,


0

1

Устанавливаю дебиан через netinstall. Установка проходит успешно (ошибок не показывал), после окончания установки и перезагрузки не загружается в систему. EFI, только что стоял Mint 18.3 с ним EFI ок работало, даже пункт в меню от него остался, а от Debian нет пункта в меню. Ставил testing и sid (оба netinstall).

Возьми live-диск, поставь live-системе grub-efi, затем

grub-install /dev/sdX 
где X - буква диска. Или просто снова загрузи установочную флешку/диск, пройди до пункта работы с жёсткими дисками, нажми отменить (или похожее на это). Выбери пункт установки grub.

Ставил неделю назад debian netinstall на систему с uefi - всё работало.

стоял Mint 18.3 с ним EFI ок работало, даже пункт в меню от него остался

Если ты форматировал диск с Mint, и пункт в меню от него остался, значит, ты не ставил grub вообще.

Zomba444ok ()
Ответ на: комментарий от Zomba444ok

Заходил в rescue mode и реинсталлил оттуда grub. Не помогало. До grub дело не доходит. Обычно в биосе появлялся пункт с установленной ОС, сейчас там дебиана нет. Лазил на раздел EFI/debian, там один фаил grubx64.efi. Раза 3 переустанавливать пробывал, каждый раз не видит вообще в биосе дебиан.

bradolub ()

Ты ставил в Legacy-режиме? Если да, то ты сам виноват, если ставил в EFI-режиме, но оно не взлетело, то пиши багрепорты. Можешь вручную прописать свой дебиан в существующий ESP или создать новый. Подробнее в статье по ссылке у меня в профиле.

r3lgar ★★★★ ()
Ответ на: комментарий от Zomba444ok

Можетте дать линку на образ откуда ставили (надеюсь это testing хотя бы), может глюк образа или среза. Вообще я качал нетинсталл тестинга, была таже самая ошибка.

bradolub ()

В процессе установки появляется такой экран: https://itmages.ru/image/view/145825/9089ed41

Так вот, вариант ответа по умолчанию «Нет», но нужно отвечать как на картинке, «Да». Ты как ответил?

Vsevolod-linuxoid ★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от r3lgar

Да это баг какой-то. Сейчас установил Mint на этот же раздел, он увидел Debian, но естественно не загрузил. Сейчас установлю дебиан куда надо, затем минт на соседний раздел. И буду грузить Debian из под убунтовского граба. Я так понимаю именно проблема в Debian получается.

bradolub ()
Ответ на: комментарий от smilessss

Да нет в этом никаких проблем, пользователи сами себе наживают проблемы на ровном месте своим непониманием. Прежде чем что-то делать, нужно понять, как оно работает, а потом уже браться. Если тыкаться как слепой котёнок, можно не только ничего не добиться, но и огрести дополнительных проблем из ничего.

r3lgar ★★★★ ()