LINUX.ORG.RU

debian 8.3 install не дает создавать разделы ex4

 ,


0

1

Доброго времени суток LOR!

Ставлю debian jessie 8.3 c tftp, либо с образа mini.iso - когда компоненты самого инсталлера загружаются по сети.

При разбиении дисков не дает создавать раздел типа ext4. Его просто нет в предлагаемых вариантах. Есть только xfs.

Если сделать автоматическое разбиение, установщик предлагает сделать корень ext4, но при нажатии «применить» не может замонтировать корень. Выдает: the attempt to mount a filesystem with type ext4 in scsi1... Если попытаться изменить тип раздела, то, как и в первом случае, ext4 нет в предлагаемых вариантах.

Если ставить с образа debian-8.2.0-amd64-netinst.iso - то все ОК. Но тут компоненты инсталлера грузяться с CD, а не по сети и версия 8.2, а не 8.3.

Всегда так утсанавливал более ранние версии - все проходило без проблем. Не пойму, в чем сейчас дело...

ps: ставлю на виртуалку. Загружаюсь по сети. Диск не большой - окло 17Гб. Таблица разделов dos (не gpt).

Поиск в инете по запросу «the attempt to mount a filesystem with type ext4 in scsi1» ответа именно на мой вопрос не дает (или не так ищу).

Неужели в таком дистрибутиве установщик не рабочий? Может кто еще столкнулся с такой проблемой?

Заранее спасибо.

★★

1. Модули-то точно все подгрузил?

2. Обновить пустой 8.2 до 8.3 (если не ставить с диска вообще ничего, даже мелочи типа lspci и psmisc) по времени минут 5-10.

svr4 ()

Есть только xfs.

Это намек. Ставь xfs

anonymous ()

Только что скачал mini.iso (8.3) и проверил - все там прекрасно дает выбрать ext4 и т.д.

Belen ★★ ()
Ответ на: комментарий от Belen

Перезалил все заново - все работает. Не пойму, в чем была проблема...

samson ★★ ()
Ответ на: комментарий от svr4

Модули-то точно все подгрузил?

а разве там что то надо дополнительно подшружать для ext4?

2. Обновить пустой 8.2 до 8.3

это то понятно.

Не пойму, почему инсталлятор не предлагал ext4. Даже если я ссылки напутал или не с того mini.iso или образа для tftp загрузился...

samson ★★ ()
Ответ на: комментарий от samson

Потому что емнимс там есть expert install, и оно даёт галочками выбрать, чего грузить. И вангую что ext4 кое-кто просто забыл.

Как вариант, если у тебя миррор с пакетами локальный - файлы могли быть от 8.2 и 8.3 просто не понравилась версия.

svr4 ()
Последнее исправление: svr4 (всего исправлений: 1 )
Ответ на: комментарий от svr4

Ставлю обычно через expert mode. Но тут пробовал и без expert. Только разве там предлагается выбрать что-либо по поводу ext4? Как я понимаю, поддержка ext4 идет по умолчанию. Сейчас ставил - там все галки сняты. И никогда ни одной отмечал, если оно не требуется! Это в разделе выбора толи модулей толи доп по, еще до разбиения дисков.

mirror - http://ftp.ru.debian.org/

samson ★★ ()
Ответ на: комментарий от samson

По умолчанию, там можно хоть себе в ногу выстрелить. Оставив netinst без поддержки своей сетевой карты. Иксперт мод же.

http://geekologie.com/2012/02/03/expert-mode-toilet.jpg

И да, если её там не выбрать, то её и не будет. Корень можно держать хоть на zfs-пуле, правда дистрибутив придётся допиливать напильником. Штатно позволяет вроде jfs2, yaffs2, ext4, xfs и reiser.

svr4 ()
Последнее исправление: svr4 (всего исправлений: 2 )
Ответ на: комментарий от svr4

файлы могли быть от 8.2 и 8.3 просто не понравилась версия

Вот сижу и думаю, какая же все таки была у меня версия этого mini.iso до этого, тк уже грохнул все старые копии... Вроде как выгружал по ссылке: ftp://ftp.ru.debian.org/debian/dists/jessie/main/installer-amd64/current/imag...

я так понимаю, что в случае загрузки с mini.iso или по tftp прогружается только ядро и initrd с самым минимальным установщиком, дальше компоненты самого установщика грузятся по сети. Вот тут то что будет, если окажется более старая версия этого начально загрузчика?

в случае же загрузки netboot.iso компоненты самого загрузчика уже загружаются с CD а не по сети.

samson ★★ ()
Ответ на: комментарий от svr4

upd: Похоже что действительно версии не совпадали. Сейчас отрыл один из mini.iso, что остались, гружусь с него - нет ext4. Наверное более старой версии

samson ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.