LINUX.ORG.RU

Настройка сетевой карты

 


0

1

Помогите пожалуйста настроить сетевую карту RTL-8100/8101L/8139. Купил новую сетевую карту, вставляю сетевой кабель в разъём, но нет сети. На модеме есть DHCP, но карта почему-то не получает свой IP-адрес.

> ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:18:f3:80:d2:ad  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:e0:4c:4d:35:b2  
          inet6 addr: fe80::2e0:4cff:fe4d:35b2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:673 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:119432 (119.4 KB)

lo        Link encap:Локальная петля (Loopback)  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:756 errors:0 dropped:0 overruns:0 frame:0
          TX packets:756 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:51363 (51.3 KB)  TX bytes:51363 (51.3 KB)
> lspci | grep Ethernet
04:00.0 Ethernet controller: Qualcomm Atheros Attansic L1 Gigabit Ethernet (rev b0)
07:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)

Пробовал задавать статический IP-адрес - всё равно сети нет:

> cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

# Моя проводная сеть
iface eth1 inet static
address 192.168.1.110
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers modem 192.168.1.1
auto eth1

Ответ на: комментарий от mky
> lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.2 LTS
Release:	14.04
Codename:	trusty
> uname -a
Linux PC 3.13.0-61-generic #100-Ubuntu SMP Wed Jul 29 11:21:34 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
mrOrlando ()
Ответ на: комментарий от mrOrlando

Стандартно советуют выгрузить модули 8139cp и 8139too, а затем загрузить только 8139too (от root'а или через sudo):

# ip link set down dev eth1
# modprobe -r 8139cp 8139too
# modprobe 8139too
# ip link set up dev eth1
# ip addr add 192.168.1.110/24 dev eth1
# ping 192.168.1.1

Если не заработает, покажите вывод ″sudo ethtool eth1″.

Попробуйте переключить в 10 Мбит: ″ethtool -s eth9 speed 10 duplex half autoneg on″

mky ★★★★★ ()
Ответ на: комментарий от mky

Перезагрузил модуль, установил IP-адрес, но сеть не появилась:

# ethtool eth1

Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 32
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes

Потом переключил в 10 Мбит:

# ethtool -s eth1 speed 10 duplex half autoneg on

# ethtool eth1

Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Speed: 10Mb/s
	Duplex: Half
	Port: MII
	PHYAD: 32
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes

И через пару минут сеть заработала и DHCP раздал сетевой адрес!
PS хотя после перезагрузки приходится заново переключать в 10 Мбит.
Спасибо большое, помогло!

mrOrlando ()
Ответ на: комментарий от mrOrlando

Я бы проверил сетёвку под другой ОС, можно и под виндой. Возможно, что она с рождения глючная и на ней не работает 100 Мбит и тогда её можно поменять по гарантии.

Чтобы не переключать вручную, команда переключения прописывается в файле ″/etc/network/interfaces″ в параметре ″pre-up″.

mky ★★★★★ ()
Ответ на: комментарий от mky

Да, я об этом думал, но под рукой нету пк с виндой.

Спасибо, заработало при старте. Файл настройки сетевых интерфейсов выглядит так:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
pre-up ethtool -s eth1 speed 10 duplex half autoneg on

mrOrlando ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.