LINUX.ORG.RU

Расширения Gnome3

 , ,


0

1

На арч потавил gnome, захожу в файрфокс на страницу с расширениями кликаю на выключатель(в положение ON), спрашивает установить или отмена, нфжимаю установить - все он и не устанавливает и ошибку не дает. Что делать? Подскажите.

Проверь стоит ли unzip, у меня такое было. Ну и запусти в консоли: gnome-shell --replace и посмотри вывод

anonymous ()

вероятнее всего, расширение не совместимо с твоей версией GNOME Shell. решение проблемы зависит от того, действительно ли расширение несовместимо или автор просто не добавил твою версию в манифест расширения.
во втором случае достаточно загрузить архив с расширением (часто они имеют страницу на гитхабе, например), добавить в manifest.json свою версию GNOME Shell и установить. либо отключить проверку версий расширений, за это отвечает ключ disable-extension-version-validation в ветке org.gnome.shell в dconf:

$ gsettings set org.gnome.shell disable-extension-version-validation true

если расширение действительно несовместимо с твоим Shell, придется вносить изменения в его исходный код.

Lincor ()
Ответ на: комментарий от moddi3

погляди, в ~/.local/share/gnome-shell/extensions лежат те что якобы были установлены?

Classic ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.