LINUX.ORG.RU

Проблема с установкой dualboot(Arch/Win8) на ноутбук Sony

 , ,


1

1

Суть проблемы: не удается установить какой либо загрузчик на ноутбук sony vaio (svf153a1yv). Ноутбук шел с предустановленной win8 на uefi, отключив security boot Arch был успешно установлен, в раздел EFI установил grub, но при перезагрузке сразу же началась загрузка win8, требуется именно dualboot, т.к. не единственный пользователь девайса.
Пробовал различные варианты установки grub, но ничего не вышло. На одном англоязычном форуме вычитал, что это стандартная проблема vaio на uefi, он не позволяет вносить изменения в загрузчик и восстанавливает его до первоначального, связано с тивоизацией. Пришла идея занять один usb слот флешкой с установленным на неё grub и с него загружаться, но на данный момент единственным найденным способом для создания работающей загрузочной флешки является установка на неё образа при помощи LinuxLive USB Creator, но устанавливается только образ системы, а нужен grub или другой загрузчик, создание загрузочной флешки под linux успехом не увенчался ни один найденный вариант, под win указанный, на данный момент, является единственным рабочим. Мучаюсь уже больше месяца, но пока безрезультатно.
Хотелось бы узнать, может быть есть не опробованные варианты или кто-либо сталкивался с подобной проблемой.
Так же устроит вариант, хотелось бы конечно dualboot, создания загрузчика только Arch на флеш, система должна быть на харде, виртуалка тоже не устроит.

Это читал? Тут пишут, что UEFI при загрузке принудительно выставляет загрузчик Sony Original первым в списке загрузки, а груб задвигает в конец.

Чтобы это обойти, нужно взять загрузчик груба типа /boot/efi/EFI/debian/grubx64.efi и перезаписать им микрософтовский /boot/efi/EFI/Boot/bootx64.efi на нужном разделе. Инструкция для vaio pro, но возможно подойдет и для твоего ноута, если поизучать выхлоп efibootmgr и поковыряться в содержимом EFI разделов.

archie ()
Ответ на: комментарий от archie

спасибо, на эту ссылку не натыкался, но там так же нет решения, Sony Original после перезагрузки меняет порядок загрузки и всё повторяется(

lowerki ()
Ответ на: комментарий от lowerki

Там есть решение, прямо в начале поста:

Preliminaries

As mentioned here, one has to copy the file /boot/efi/EFI/debian/grubx64.efi to /boot/efi/EFI/Boot/bootx64.efi. Failure to do this will result in Windows remaining stubbornly the OS to be booted.

Дальше аффтар рассуждает, для чего это нужно и как бы это копирование автоматизировать после каждого обновления груба. Вот для автоматизации копирования решения не найдено, а с ручным копированием все судя по всему работает.

Тебе соответственно нужно загрузиться с флешки в UEFI режиме, примонтировать все EFI разделы, посмотреть где какие файлы лежат, свериться с efibootmgr и перезаписать виндовый загрузчик грубом. Разумеется с бекапом, на случай если что-то пойдет не так.

archie ()

Сони, как всегда, в своём репертуаре - анальное огораживание по максимуму. Что Xperia самый огороженный из андроидов, ещё и с зондами, что ваш случай. Также все прекрасно помнят Sony Memory Stick, SACD-диски и «защищённые» CD Audio, устанавливающие шпиона в ваши винды. Одни из самых шизанутых копирастов, гореть им в аду. Крайне неудачные у них ноуты для линукса, будете мучиться.

anonymous ()

Ubuntu грузится в режиме Secure Boot. Что ты делаешь не так?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.