LINUX.ORG.RU

при запуске свежеустановленного debian v7.5.0 amd64 пустой экран «и тишина»(с)


0

2

установил дуалбутом Debian v7.5.0 amd64 на ноутбуке Lenovo G700 и при первой же загрузке столкнулся со стабильно повторяющейся проблемой - появляется груб, позволяет выбрать любой из трёх пунктов (debian, debian-режимвосстановления, оффтоп), при выборе оффтопа всё работает и позволяет постить на лорчик «из горящего танка», а при выборе первых двух пунктов проскакивают несколько (совсем мало в случае выбора первого пункта и несколько экранов случае выбора второго пункта) строк текста, после чего экран гаснет полностью, такое ощущение, что у него даже подсветка отключается, и компьютер никуда далее не движется. Через некоторое время начинают «пищать» клавиши, даже кнопка питания :)

Устанавливал два раза, в beginners-mode, один раз при установке в моменте «Software Selection» указал установку Debian desktop environment, SSH server, Laptop и Standard system utilites, второй раз указал только Standard system utilites, оба раза одна беда.

Вопрос - можно ли каким-либо образом просмотреть пошагово процедуру загрузки, что-бы попробовать хотя-бы определить момент впадания в «чёрноэкранное» состояние? Подвопрос - что можно ещё такого сделать, чтоб вернуться от ситуации «тут линукс, а тут оффтоп» к старому доброму дуалбуту?

★★

указал установку Debian desktop environment, SSH server, Laptop и Standard system utilites, второй раз указал только Standard system utilites

...а если не указывать ничего (потом установишь) и при установке выбрать дрова необходимые только для данной системы?

Trauka ()

при выборе оффтопа

...а что за «оффтопа», у меня не дуалбут, может это только на дуалбут такое появляется. ...з.ы. ...я так для себя спросить

Trauka ()
Ответ на: комментарий от Trauka

ничего не указывать - т.е. даже «Стандартные системыне утилиты»? Проверить то можно, максимум 10 минут займёт переустановка. Вот только не волчанка ли у меня?

spunky ★★ ()
Ответ на: комментарий от Trauka

у меня на этой же SSD-шке стоит win7, при загрузке GRUB-а эта ОС отображается как строка «Windows 7 (loader) (on /dev/sda1)». Теперь, когда тайна раскрыта, пользоваться словом «оффтоп» больше не буду.

spunky ★★ ()

Если в параметры загрузки nomodeset добавить, пробовали? Переустанавливать не вижу смысла, для начала Standard system utilites достаточно, остальное можно потом поставить.

anonymous ()
Ответ на: комментарий от spunky

ничего не указывать

...вобще ничего, я, правда не знаю как ты там диски разбиваешь, (надеюсь правильно), груб, конечно в виндовый раздел, тот, который загрузочный. вобще установщик сам грамотно предложит куда что ставить. ты ток да отвечай.

Trauka ()
Ответ на: комментарий от anonymous

для начала Standard system utilites достаточно

...да? ...а для чего это иксовое барахло, которое потом хрен удалишь? ...голая система запустится в консоль и ставь все что надо, [d]надо!!!!

Trauka ()
Ответ на: комментарий от Trauka

ТС пишет:

при выборе первых двух пунктов проскакивают несколько (совсем мало в случае выбора первого пункта и несколько экранов случае выбора второго пункта) строк текста, после чего экран гаснет

Значит загрузчик работает корректно, т.к. загружает ядро и передаёт ему управление. Тем более из этого же загрузчика ТС вызывает загрузчик Windows и запускает её. Значит вывод один: загрузчик работает корректно.

kostik87 ★★★★★ ()

Какая видео карта в ноутбуке? Intel есть или только Nvidia? Если карты две, то случаем не включена по умолчанию Nvidia, если это возможно, конечно?

Определена gfxpayload в конфиге загрузчика? Попробуй указать там некоторый видео режим вместо «auto».

kostik87 ★★★★★ ()
Ответ на: комментарий от Trauka

ну, 10 минут прошли, даже больше, переустановил ещё раз :) Поставилось не 126 пакетов, как в случае с установкой Standard system utilites, а 18, и на этом, к сожалению, различия закончились. Дальше те же яйца - чернющий экран при загрузке.

spunky ★★ ()
Ответ на: комментарий от kostik87

...ну, и пусть работает. ...а что ставит установщик при выборе пунктов в установке программ- неизвестно, там тянет кучу зависимостей для кучи видюх, процессоров и т.д. надо поставить голую систему. если зайдет в консоль- то была проблема в выборе софта. ...а тем более Standard system utilites не ставить.

Trauka ()
Ответ на: комментарий от Trauka

а что ставит установщик при выборе пунктов в установке программ- неизвестно, там тянет кучу зависимостей для кучи видюх, процессоров и т.д. надо поставить голую систему.

С чего ты решил, что так надо ТС. Поддержка всего оборудования идёт лишь сугубо с ядром, не считая проприетарных драйверов, например Nvidia или AMD (ATI), ну и если говорить о специфике Debian, то это ещё прошивик, которые нужно ставить отдельно, что бы заработало оборудование, которое маломальски требует закрытые прошивки. В итоге, что имеем: поддержка всего оборудования в ядре и модулях, прочий установленный софт не оказывает влияния, проблема либо в ядре, либо в конфиге загрузчика, даже несмотря на то, что он «дефолтный».

kostik87 ★★★★★ ()
Ответ на: комментарий от Trauka

Естесственно, тогда установщик не нужен, как и дебиан, а нужен LFS.

anonymous ()
Ответ на: комментарий от Trauka

, т.е. то что нужно, а не то что предлагает и тянет установщик

Что бы ставить лишь то, что надо тебе надо использовать Source-based дистрибутив. А то установщик исходя из бинарных пакетов и зависимостей уже предварительно собранных программ притянет ещё кучу пакетов с программами, которые тебе и не нужны, но ты от них не можешь отказаться, потому что их требуют уже собранные за тебя программы.

kostik87 ★★★★★ ()
Ответ на: комментарий от anonymous

Если в параметры загрузки nomodeset добавить, пробовали?

Ууууу! Однако! Загрузился до консоли :) Успех, правда теперь ещё проверять с графической оболочкой, она долго ставится - там пакетов что-то около 13 сотен.

подправил строку
linux /boot/vmlinuz-3.2.0-4-amd64 root=UUID=bla-bla-bla ro quiet nomodeset

spunky ★★ ()
Ответ на: комментарий от RisuX3

попробуй запустить ядро с параметрами apic=off noapic

это два разных параметра или один? Или один в двух вариантах написания?

spunky ★★ ()
Ответ на: комментарий от kostik87

...я пологаю, что используется netinstal. там ничего не тянет. там тянет, то что бы просто загрузится.

Trauka ()
Ответ на: комментарий от RisuX3

попробовал. Добавлял в строку загрузки ядра linux /boot/vmlinuz-... apic=off noapic в разных комбинациях и по отдельности, не помогло.

spunky ★★ ()
Ответ на: комментарий от RisuX3

эх, тяжела судьба криворукого дуалбутчика. Пока туда-сюда сбегаешь - окажется зря бегал :) Планшет чтоль достать?

spunky ★★ ()
Ответ на: комментарий от spunky

Просто у меня примерно такая же проблема. В 80% всё заканчивается чёрным экраном. Без APIC иксы не стартуют, а модуля APIC для моего ноутбука вроде как нет. Приходится терпеть :)

RisuX3 ()
Ответ на: комментарий от spunky

ну, в графическом режиме тоже запустилось с параметром nomodeset. Вот без него я только попробовать подзабыл, а то окажется ещё, что дело вовсе не в бобине.

spunky ★★ ()

Подвопрос - что можно ещё такого сделать, чтоб вернуться от ситуации «тут линукс, а тут оффтоп» к старому доброму дуалбуту?

Что-что?

zorg ★★ ()
Ответ на: комментарий от spunky

UUID=bla-bla-bla ro quiet nomodeset77

quiet-то тоже убери, больше информации будет выдавать

xorik ★★★★★ ()
Ответ на: комментарий от zorg

Сейчас у меня на рабочем стационарном компьютере личный centos, а на личном ноутбуке рабочий win7, а я хочу на личный бук и рабочий win7, и личный debian. А рабочую машину вообще в серверную поставить, пусть смотрит, как работают её собратья-служители.

spunky ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.