LINUX.ORG.RU

Проблема со сборкой seahorse в Debian

 


0

1

Был у меня один PGP-ключ с паролем. И захотел я этот пароль убрать (установить пустой). Ну, захожу, ввожу старый пароль, ввобжу новый пароль, подтверждаю, что я уверен что это нормально, что пароль слабый, подтверждаю, что это нормально без пароля. И вроде бы всё, но в этот момент seahorse предлагает ввести пароль еще раз и не принимает пустой пароль (и старый тоже). В итоге пароль остаётся не сброшенным. Вот если на любой другой пароль поменять - проблем нет. А на пустой - не получается.

Ну я думаю - сейчас возьму и соберу из исходников. Однако не получается. Там требования в зависимостях libsecret-1-dev (>= 0.16), а у меня apt-cache policy libsecret-1-dev показывает только наличие 0.15 и не могу найти подходящего репозитория, где есть пакет 0.16...

Как после этого люди могут серьезно утверждать, что debian лучше, чем ubuntu?

Ну я думаю - сейчас возьму и соберу из исходников.

Глупый, конечно, вопрос: а man читал?

Как после этого люди могут серьезно утверждать, что debian лучше, чем ubuntu?

Этот факт не зависит от нас и наших знаний о нём.

ziemin ★★ ()
Ответ на: комментарий от ziemin

Глупый, конечно, вопрос: а man читал?

глупый ответ - весь текст man на все пакеты конечно не читал.

я взял исходники с git
git clone git://git.gnome.org/seahorse
прочитал README и попробовал выполнить ./configure

он выдал мне ошибку:
configure: error: libsecret library or headers not found.

я посмотрел зависимости, дальше написано в исходном посте

terradot ()
Ответ на: комментарий от terradot

глупый ответ - весь текст man на все пакеты конечно не читал.

Дык там может ключик есть?

По теме. Какой релиз и подключал ли sid?

ziemin ★★ ()

А почему вы обвиняете Дебиан, если сами стянули исходники не из репозитория Дебиана, а с gnome.org?

скачайте из deb-src вашего, и будет вам счастье.

Adonai ★★★ ()
Ответ на: комментарий от Adonai

сами стянули исходники не из репозитория Дебиана, а с gnome.org?

там свежее.

почему вы обвиняете Дебиан

потому что в gentoo есть пакеты -9999 и там это не проблема,
потому что в ubuntu есть launchpad.net и интеграция с git и там это не проблема
и только в debian это кромешный ужас

terradot ()
Ответ на: комментарий от terradot

Ты как хочешь? По хорошему (скомпилять нужный пакет и его зависимости) или по-плохому (обмануть configure и попробовать запуститьь на старой версии). Я к тому, что версия минорная.

ziemin ★★ ()

Стянул с гита левый сыр и требуешь что бы всё с ним стыковалось? Молодец чё. Да ещё и обвиняешь целый дистрибутив. Раз уж Тянешь с гита то тяни и зависимости libsecret-1-dev тоже собери. А лучше ещё напиши багрепорт, не факт что гитовая версия исправна в этом плане.

Dron ★★★★★ ()
Ответ на: комментарий от ziemin

если честно, я подумываю над тем чтобы поставить убунтовые пакеты, и скомпилять с их использованием (то есть очень по-плохому). Собственно, я это уже почти проделал, только у меня теперь другие ошибки в ./configure, с которыми я разбираюсь.

А топик мне, чтобы выразить негодование debian-ом.

terradot ()
Ответ на: комментарий от terradot

поставить убунтовые пакеты, и скомпилять с их использованием (то есть очень по-плохому).

Сделай просто по-плохому.

А топик мне, чтобы выразить негодование debian-ом.

Если бы дистры были людьми, то дебиан бы тут же сделал вдоль.

ziemin ★★ ()
Ответ на: комментарий от terradot

Да, там свежее.

Но ведь Дебиан строится не как bleeding edge. Тут, скорее, несовпадение философии Дебиана с вашими целями и ожиданиями от него.

Может, имеет смысл перейти обратно на Gentoo/Ubuntu?

Adonai ★★★ ()
Ответ на: комментарий от Adonai

Дебиан строится не как bleeding edge

ну и что? Вот у убунты тоже есть релизы. Что никак ей не мешает.

несовпадение философии Дебиана

недостаток фич у Дебиана. Инфраструктуры для сборки конкретно. И нечего тут оправдываться.

terradot ()
Ответ на: комментарий от terradot

недостаток фич у Дебиана. Инфраструктуры для сборки конкретно. И нечего тут оправдываться.

Ты дурак? Хотя нет это не вопрос. Ты дурак.

Dron ★★★★★ ()
Ответ на: комментарий от Dron

отсутсвие такой инфраструктуры приводит к тому, что люди менее активно работают над recipies чем в Ubuntu, именно поэтому убунта круче дебиана для разработчиков.

А Вы и дальше сидите на своём дистрибутиве с устаревшими пакетами.

terradot ()
Ответ на: комментарий от terradot

Проблема в том, что у Ubuntu != Debian. Так что тут не стоит попусту негодовать по этому. Пакеты другие, зависимости другие, фактически среда другая.

kachsheev ★★★ ()
Ответ на: комментарий от Adonai

скачайте из deb-src вашего, и будет вам счастье.

не будет:
sudo apt-get source seahorse
sudo apt-get -b source seahorse

seahorse-gkr-actions.c:245:39: error: too few arguments to function 'secret_service_prompt_at_dbus_path'

terradot ()
Ответ на: комментарий от terradot

недостаток фич у Дебиана. Инфраструктуры для сборки конкретно.

про cdbs ты конечно не слышал.

bass ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.