LINUX.ORG.RU

Что оно хочет? (ошибка зависимостей)


0

1

System hostname Debian-60-squeeze-64-LAMP
Operating system Debian Linux 6.0
Webmin version 1.660
Kernel and CPU Linux 2.6.32-5-amd64 on x86_64

Уже 40+ пакетов хотят обновиться.
Жму обновление. Все выдает одинаковые ошибки:

Создание полного списка обновлений ..

Сейчас обновляется apt-show-versions ..

Установка пакетов с помощью команды apt-get -y install apt-show-versions ..

    dpkg: dependency problems prevent configuration of mysql-server-5.1:
     mysql-server-5.1 depends on mysql-server-core-5.1 (= 5.1.63-0+squeeze1); however:
      Version of mysql-server-core-5.1 on system is 5.1.66-0+squeeze1.
    dpkg: error processing mysql-server-5.1 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     mysql-server-5.1
    Reading package lists...
    Building dependency tree...
    Reading state information...
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     mysql-server-5.1 : Depends: mysql-server-core-5.1 (= 5.1.63-0+squeeze1) but 5.1.66-0+squeeze1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
.. ошибка при установке!
И так везде. Везде матерится на мускуль.

Сделал apt-get -f install. Потом часть (большая) пакетов обновилась.

Часть пакетов не обновляется, сыпет:

The following packages were automatically installed and are no longer required:
  libhtml-template-perl mysql-server-5.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

вопрос:

apt-get autoremove libhtml-template-perl mysql-server-5.1

Мне все не похерит?)


Зачем сносить собрался?
Сделай инсталл mysql-server-core-5.1, не совсем очевидное решение, но часть пакетов так чинятся. Пока не нашел причины, почему зависимости не ставятся сами, хотя в вываливаемых ошибках вполне конкретно описано чего не хватает

anonymous ()

dpkg --force
next -> next -> ok

anonymous ()

Проще через aptitude обновить.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Из сугубо моего личного опыта, не всегда помогает

anonymous ()
Ответ на: комментарий от anonymous

Я имел в виду интерактивный режим. Там можно побродить по звисимостям, посмотреть, что с чем конфликтует. Связка aptitude safe-upgrade + ручное разруливание оставшихся зависимостей мне всегда помогала.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Лучше оставлю как есть. Безопасность не под угрозой, вроде бы. А поломать жалко очень.

dk- ()
Ответ на: комментарий от i-rinat

Натыкался, что в списке поломанных пакетов и зависимостей aptitude радовало меня пустотой. потому и написал, да возможно не осилил, но возится было лень. поставил зависимости по выхлопу apt, пациент ожил.

anonymous ()

если я не глючу оно пишет что системный новее того что в репах.

Slackware_user ★★★★★ ()

aptitude update

aptitude full-upgrade

зы. как ты докатился до линукса то?

subwoofer ★★★★★ ()
Ответ на: комментарий от Slackware_user

точно, значит надо смотреть список репозиториев

subwoofer ★★★★★ ()
Ответ на: комментарий от subwoofer

Ну дык эта. На впс венду что ли держать?

Я же не фанатик, а инструмент под задачу.

dk- ()
Ответ на: комментарий от dk-

ну в анстейбле (хотя с 6.0 песочек сыпется вроде) и не такое может быть, покажи список репозиториев

subwoofer ★★★★★ ()
Последнее исправление: subwoofer (всего исправлений: 1)
Ответ на: комментарий от subwoofer

Сходу не нашел как посмотреть.

Ну вебмин. Впс от хетцнера. Репозиторий по дефолту.

dk- ()
Ответ на: комментарий от dk-

cat /etc/apt/sources.list

а вообще снеси этот мускуль и поставь заново, если ничего не отвалися

subwoofer ★★★★★ ()
Ответ на: комментарий от subwoofer

а вообще снеси этот мускуль и поставь заново, если ничего не отвалися

Если потом вебмин не заведется?)))

#######################################################################################
# Hetzner APT-Mirror

deb http://mirror.hetzner.de/debian/packages squeeze main contrib non-free
deb http://mirror.hetzner.de/debian/security squeeze/updates main contrib non-free



#######################################################################################
# Backupmirror
#

deb http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze main non-free contrib
deb-src http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze main non-free contrib

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

## backports
deb http://backports.debian.org/debian-backports squeeze-backports main

dk- ()
Ответ на: комментарий от dk-

Если потом вебмин не заведется?)))

и настигнет тебя жопа с текстовым интерфейсом: ssh называется

subwoofer ★★★★★ ()
Ответ на: комментарий от subwoofer

Нафиг нафиг такое счастье!)

Я лучше абгрейд через «новый впс» устрою.
Один фиг пора с 60гб до 80гб расширяться

dk- ()
Ответ на: комментарий от dk-

левые репы с криворукими мейнтейнерами.

возможны другие варианты

Slackware_user ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.