LINUX.ORG.RU

Powercomm BNT-1000AP, nut, Debian 6 (2.6.32-5) нет USB-порта

 , , , ,


0

1

Доброго времени суток

Подключил UPS, системой он увиделся:

[    3.873603] usbcore: registered new interface driver hiddev
[    4.290054] generic-usb 0003:0D9F:0004.0001: hiddev0,hidraw0: USB HID v1.00 Device [POWERCOM Co.,LTD HID UPS Battery] on usb-0000:00:10.0-1/input0
[    4.290101] usbcore: registered new interface driver usbhid
[    4.290393] usbhid: v2.6:USB HID core driver

Выполнил modprobe usbserial, в /etc/nut/ups.conf прописал:

[servups]
    driver = powercom
    port = /dev/ttyUSB0

usbdrvctl start говорит, что нет /dev/ttyUSB0. И его действительно нет. Вообще, нет никаких портов, которые бы относились к USB UPSa

mknod /dev/ttyUSB0 c 188 0 создает файл-устройство, но толку от этого мало, с UPS-ом это не позволяет общаться.

Прописал вместо /dev/ttyUSB0 в конфиге /dev/hidraw0 и в ответ:

Network UPS Tools - UPS driver controller 2.4.3
Network UPS Tools - PowerCom protocol UPS driver 0.12 (2.4.3)
tcgetattr(/dev/hidraw0): Invalid argument
Driver failed to start (exit status=1)

Куда смотреть, что б появился USB-порт UPSa?


а зачем тебе /dev/ttyUSB0. попробуй port = auto

punya ★★ ()

Да, спешка хороша только при ловле блох...

Похоже в версии nut-2.4.3, что установлена, просто еще нет поддержки моего UPSa. Обновлюсь до свежей, посмотрим... Спасибо за ответы.

D_Ima ()

Мой конфиг с дебиана, все работает

[powercom]
driver = usbhid-ups
port = auto
desc = «Powercom BNT-600AP»
pollonly
# shutdown at 45% charge
override.battery.charge.warning = 60
override.battery.charge.low = 45
# ignore UPS info, use variables above
ignorelb
# delay 60 seconds for corrent PC shutdown
override.ups.delay.shutdown = 60

nu11 ★★★★★ ()
Последнее исправление: nu11 (всего исправлений: 1)
Ответ на: комментарий от D_Ima

Похоже в версии nut-2.4.3, что установлена, просто еще нет поддержки моего UPSa

из репозитория? Быть не может, я поверкомом той же серии уже года 4 пользуюсь на дебиане, все поддерживается давно

nu11 ★★★★★ ()
Ответ на: комментарий от nu11

Не знаю, что и как, но обновился дебами до последней stable-версии - 2.6.4 и все заработало.

Спасибо большое за конфиг, бум изучать :)

D_Ima ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.