LINUX.ORG.RU

amd e350 (radeon hd 6310) и звк через hdmi


0

1

сабж, на системе с указанной конфигурацией нет звука

видеодрайвер radeon

под win звук есть, через аналоговый выходи звук есть, установка пульсы (до этого ее не было) не помогла

в alsamixer все включено (mute отключен)

раньше звук был, но было проведено обновление на 3.2.0-4 с 3.2.0-3 и заменен fglrx на radeon


# запуск mplayer
mplayer -ao alsa:device=hw=0.3 /home/r/test.mp3

#нормально играет музыку но без звука
# в логах ничего подозрительного
# 

r@r-htpc ~ % uname -a                           
Linux r-htpc 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
r@r-htpc ~ % aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

r@r-htpc ~ % aplay -L                                                             
default
    Playback/recording through the PulseAudio sound server
hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
sysdefault:CARD=SB
    HDA ATI SB, ALC892 Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    Front speakers
....

r@r-htpc ~ % lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]


r@r-htpc ~ % lsmod |grep snd 
snd_hda_codec_realtek   188858  1 
snd_hda_codec_hdmi     30824  1 
snd_hda_intel          26345  5 
snd_hda_codec          78031  3 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek
snd_hwdep              13186  1 snd_hda_codec
snd_pcm                68083  3 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi
snd_page_alloc         13003  2 snd_pcm,snd_hda_intel
snd_seq                45126  0 
snd_seq_device         13176  1 snd_seq
snd_timer              22917  2 snd_seq,snd_pcm
snd                    52889  19 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek
soundcore              13065  1 snd

Deleted

оффтопом: каково сидеть на е350 и линуксе? Задумываюсь поменять атом330 на такое.

Deleted ()
Ответ на: комментарий от Deleted

ну как каково? сабж первая проблема с таким железом (я проверял на htpc и на ноуте 1215b, сам ноут - уг), причем ноут отлично цепляет монитор через hdmi через графику все конфигурится и тутже работает, и fullhd можно смотреть (что я и делал както), но вот звук что-то через hdmi не идет.

вафля и енергосбережение завелось автоматом вроде (когда покупал ноут пришлось ядро из анстейбла тянуть ибо железо тогда новое было, а щас все из тестинга), что там еще?

Deleted ()
Ответ на: комментарий от Kompilainenn

похоже что нужен, но этож не opengl какойто, да у того драйвера на телевизоре получается черная рамка по краям

Deleted ()

Блин:

https://wiki.archlinux.org/index.php/ATI_%28Русский%29#HDMI_.D1.81.D0.BE_.D0....

В ядрах >= 3.0 модуль звука выключен по умолчанию. Добавьте radeon.audio=1 в конец строки «kernel» в файле /boot/grub/menu.lst для включения этого модуля. Подробности можно узнать в этом треде. Видеокарты линейки Evergreen получат поддержку начиная с ядра >= 3.3

надо попробовать

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.