LINUX.ORG.RU

Debian squeeze - не определяется звуковая карта

 , , ,


0

1

Установил на новую машину Debian squeeze c дефолтным ядром и как и следовало ожидать - все завелось, кроме звуковой карты.

root@valet-comp:/home/valet# uname -a
Linux valet-comp 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64 GNU/Linux

root@valet-comp:/home/valet# lspci
00:00.0 Host bridge: Intel Corporation Device 0150 (rev 09)
00:01.0 PCI bridge: Intel Corporation Device 0151 (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0152 (rev 09)
00:14.0 USB Controller: Intel Corporation Device 1e31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 1e3a (rev 04)
00:1a.0 USB Controller: Intel Corporation Device 1e2d (rev 04)
00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 1e10 (rev c4)
00:1c.5 PCI bridge: Intel Corporation Device 1e1a (rev c4)
00:1c.6 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c4)
00:1d.0 USB Controller: Intel Corporation Device 1e26 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Device 1e44 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 1e02 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 1e22 (rev 04)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 09)
04:00.0 PCI bridge: Device 1b21:1080 (rev 03)

root@valet-comp:/home/valet# alsactl init
alsactl: init:1743: No soundcards found...

Как я понял, нет драйверов к моей звуковой карте Audio device: Intel Corporation Device 1e20 (rev 04).

Сразу хочу уточнить, что помогает смена ядра, пробовал ставить ядро 3.2 из бекпортов - там звук работает из коробки, но там другие проблемы - например gvfsd-metadata сжирает целое ядро процессора да еще и как я понял постоянно что-то пишет на диск, что особо для меня критично так как у меня SSD и как понял нет четкого решения побороть это. Да и вообще не хотелось бы сидеть на таких сырых ядрах - мало ли что там еще может быть...

В идеале хотелось бы побороть проблему какими-то штатными средствами, например установкой каких-то deb-пакетов, но если это невозможно, то конечно поставлю все что нужно - ведь что-что, а звук то нужен


почитай вот тут
у меня была похожая проблема, правда debian wheezy+HDA ATI SB, решилась просто добавлением в /etc/modprobe.d/alsa-base.conf строки:
options snd-hda-intel model=auto

shrm ()
Ответ на: комментарий от i_gnatenko_brain

1. а что я разве не так что-то оформил. LORCODE читал, что я могу сделать, если тут кривой (как мне кажется) спойлер. 2. Ок, какое ядро для Debian'а попробовать так чтобы не собирать, а поставить готовое из бекпортов.

valet ()
Ответ на: комментарий от valet

Добиавл, перезагрузился, не помогло, звука нет.

что добавил? options snd-hda-intel model=auto - это для моей звуковухи, по ссылке ходил/читал? там про твою проблему как раз

shrm ()
Ответ на: комментарий от shrm

Добавил snd-hda-intel model=auto - никакого эффекта. А по ссылке там вопрос решается тем, что ставится ядро 3.2 из бекпортов, у меня тоже на ядре 3.2 есть звук, но зато и другие проблемы, которые я указал в первом посте.

valet ()
Ответ на: комментарий от i_gnatenko_brain

И что это даст? Я там использовал [ cut ] и [ quote ] - не вижу особых проблем с этим, что это меняет, тем более код не имеет там 100500 строк.

valet ()
Ответ на: комментарий от valet

По теме сабжа, сообщу, что проблему решил установкой ядра linux-image-3.2.0-0.bpo.4-amd64

valet ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.