LINUX.ORG.RU

Помогите, пожалуйста, заставить работать Epson Stylus CX7300 под ArchLinux.

 , ,


0

1

Всем ку! Все делал по Арчвики- поставил капс, запустил его демона, выгрузил usblp, в dmesg подключение принтера отразилось:

[ 1624.463192] usb 2-1: new high-speed USB device number 6 using ehci_hcd
[ 1624.599728] scsi11 : usb-storage 2-1:1.2
[ 1624.873497] Did not find alt setting 1 for intf 0, config 1
[ 1625.602752] scsi 11:0:0:0: Direct-Access     EPSON    Stylus Storage   1.00 PQ: 0 ANSI: 2
[ 1625.610863] sd 11:0:0:0: [sdc] Attached SCSI removable disk
перешел на 127.0.0.1:631, администрирование, root/пароль, Добавить принтер. В списке локальных- Последовательный порт #1. В качестве драйвера к нему указываю CX74000(в Бубунте и Сузе работал с таким драйвером), добавляю. Пытаюсь на него печатать- ничего. на 127.0.0.1:631 говорится, что печать идет. Что делать?


У самого такой принтер. Может, случилась аппаратная проблема? У принтеров этой серии частенько что-то шалит.

PrikPavel ()
Ответ на: комментарий от Vekt

Попробуйте всё же разблокировать usblp, убедиться, что появился интерфейс принтера, и сказать CUPS'у, что принтер расположен по адресу parallel:/dev/путь/к/этому/файлу. Решение неправильное, т.к. от usblp CUPS отказывается в пользу libusb, но принтер должен заработать.

В Gentoo для этого также собирают CUPS с USE=-usb, а в Debian - накладывают патч (debian/patches/usb-backend-both-usblp-and-libusb.dpatch: Make the USB backend supporting both printer access via libusb and via the usblp kernel module. Make it also printing via libusb if the URI for the queue was generated via usblp and vice versa. This should solve most USB printing problems which occured on the transition to CUPS 1.4.x; http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546558)

AITap ★★★★★ ()
Ответ на: комментарий от AITap

В том то и проблема- Сначала я вообще только капс поставил, без всякого выключения модулей. Принтер отображался так же и не печатал. После этого я по советам на арчфоруме заменил cups на cups-usblp и выгрузил модуль, и опять ничто не изменилось...Хотя, что то мне сейчас подсказывает, что cups-usblp надо использовать не выгружая модуль... попробую.

Vekt ()
Ответ на: комментарий от Vekt

Да! Решение такое- вместо cups поставить cups-usblp и врубить модуль usblp. Принтер определился не как Последовательный порт #1, а целиком- Epson Stylus CX7300. Взлетело.

Vekt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.