LINUX.ORG.RU

MF626 + Debian


0

1

Добрый день. Есть модем ZTE MF626 и установленный дистрибутив debian-live-6.0.2-i386-standard.iso, стоит на нэттопе ASUS B202. Голая консоль, без иксов, из пакетов стоит несколько небольших. Модем разлочил и снял флаг - теперь при загрузке с помощью скрипта подается команда «modprobe usbserial vendor=0x19d2 product=0x0031» вроде все ок - появляется 3 устройства ttyUSB0-2. Скачан и настроен wvdial на ttyUSB2. После первого запуска wvdial модем может дозвониться, инэт появляется (а может и не дозвонится). После второго вероятность соединения значительно ниже и т.д. с каждым разом. Причем бывает, что модем существенно затормаживает систему (мне кажется именно работу с usb, т.к. команда lsusb выполняется с задержкой примерно в минуту и модема уже не видно). Вторая ситуация - когда модем виден, но соединения нет. wvdial выдает «Cannot get information for serial port» и «Modem not responding» хотя ни конфиг ни модем я не трогаю. Подскажите пожалуйста в какую сторону рыть и может быть есть более лучший «дозвонщик». Заранее спасибо.

Как разлочил то? Я в своё время намаялся с билайновским, пока не перешил в zte.

kraftello ★★★★★ ()

Да и даже на родной прошивке может терять нет, помогает только извлечение из юсб порта. Фейковый сидиром отключён.

kraftello ★★★★★ ()
Ответ на: комментарий от AITap

Хм, сейчас как раз такой момент, что подтормаживает работа с юсб. dmesg: [ 99.548026] usb 3-2: device descriptor read/64, error -110 [ 114.764025] usb 3-2: device descriptor read/64, error -110 [ 114.980022] usb 3-2: new full speed USB device using uhci_hcd and address 3 [ 130.092025] usb 3-2: device descriptor read/64, error -110 [ 145.308023] usb 3-2: device descriptor read/64, error -110 [ 145.524021] usb 3-2: new full speed USB device using uhci_hcd and address 4 [ 155.932021] usb 3-2: device not accepting address 4, error -110 [ 156.044026] usb 3-2: new full speed USB device using uhci_hcd and address 5 [ 166.452023] usb 3-2: device not accepting address 5, error -110 [ 166.452127] hub 3-0:1.0: unable to enumerate USB device on port 2 машина вместо положенных 17 секунд загружается за 166. Разлочил перепрошивкой, долго искал нужную - там танцев тоже хватает. Если надо, могу поискать какой именно. Да кстати - при этой ошибке (лог выше) помогает только физическое извлечение из порта, ребуты не помогают.

Slayer ()
Ответ на: комментарий от AITap

Порты исправны, перегрева нет - градусника нет, но нэттоп стоит на столе, на ощупь перегрева нет, СО работает, воздух чуть теплый. Модем рабочий - проверял на винде, все работает. п.с. Не могу разобраться с лоркод, не работает (мож чего делаю не так) - [code] так и выводится.

Slayer ()
Ответ на: комментарий от Slayer

[code] так и выводится.

Под полем для ввода сообщения нужно выбрать «LORCODE».

AITap ★★★★★ ()
Ответ на: комментарий от anonymous

То есть дело не в руках, а в модеме и его совместимостью с линухом? Может другой звонилкой попробовать, может кто что подсказать?

Slayer ()
Ответ на: комментарий от Slayer

пфф, так у тебя модем заглюкивает через время. и его драйвер срёт в dmesg ошибками. а «звонилка» это уже клиент драйвера, это ж очевидно

ну можешь попробовать напрямую ч-з pppd, без всяких звонилок (конфигов в поиске куча). но это как мёртвому припарки.

anonymous ()
Ответ на: комментарий от anonymous

Пардон, просто я ещё только начинающий пользователь. Заглюкивает он именно после использования wvdial. Т.е. если включить комп, и не пользоваться wvdial-ом все будет ок, почему я на него и подумал. Тогда встает вопрос - какой USB модем «дружнее остальных» с линуксом?

Slayer ()
Ответ на: комментарий от Slayer

просто поставь новое ядро. этот модем работает с линупсом сто лет

просто в дебиан стейбл неадекватная политика заморозки версии ядра

правда, иногда (очень-очень редко) его всё равно придётся передёрнуть, даже под вендой

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.