LINUX.ORG.RU

[wifi] [asus eeepc 1015px] [gentoo]


0

1

вопрос в следующем. собрал ядро 2.6.39-gentoo-r3.
подключил поддержку своей видеокарты Broadcom Corporation Device 4727 (rev 01).
но в результате не работает :(
вот кусок lspci -nnk

02:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4727] (rev 01)
Subsystem: Device [1a3b:2047]
Kernel modules: brcmsmac
как заставить этот модуль (brcmsmac) работать???
p.s.в других устройствах есть пункт Kernel driver in use:

Свой WiFi-адаптер с тем же ID мне на brcmsmac работать заставить пока не удалось. Туда по идее должна подгрузаться бинарная закрытая прошивка.

Пока использую не этот ядерный модуль, а wl из пакета net-wireless/broadcom-sta (проприетарный драйвер для сего девайса).

WiseLord ()

>видеокарты

Network controller

Внезапно, это не видеокарта.

gentoo_root ★★★★★ ()
Ответ на: комментарий от sanychlxg

Искать не нужно - по идее, вот она: net-wireless/b43-firmware Но у меня что-то оно не заработало (вполне может быть, что даже именно из-за этого бага), поэтому я просто поставил проприетарный драйвер net-wireless/broadcom-sta. Хотя, может быть, для вашего ноутбука и ядерный модуль + firmware заработает.

WiseLord ()
Ответ на: комментарий от sanychlxg

у меня не EEE, у меня HP Probook 4720, сию штуку не запускал.

В общем, удалось запустить brcmsmac модуль - достаточным оказалось лишь установить sys-kernel/linux-firmware - необходимая прошивка находится, как оказалось, в этом пакете. Всё само подхватилось и wifi заработал и на этом модуле. Сейчас пытаюсь добиться ещё и правильного загорания светодиода wi-fi. При отключенном wifi он должен гореть жёлтым, при включённом - синим. На broadcom-sta так и было, на brcmsmac пока горит только жёлтым, хотя сам wifi вполне работает.

WiseLord ()
Ответ на: комментарий от WiseLord

Судя по информации на оф. сайте разработчиков brcmsmac, поддержка светодиодов не реализована, соответствующая строчка висит пока в TODO.

WiseLord ()
Ответ на: комментарий от WiseLord

я тут все ни как понять не могу, почему сети видит, а подключиться не может. помогло пару раз лишь установка wicd (изначально было только networkmanager+applet) и после мучений както получалось, а если пользоваться чем-то одним, то работать не будет (сети видит, но не подключается). как победить?

sanychlxg ()
Ответ на: комментарий от sanychlxg

Ура красавчики!

Помогите и мне настроить пожалуйста. То же пока юзаю через wl. Если не трудно опишите подробней что нужно делать в Ubuntu 10.04.3 LST чтоб заработало.

ArtemDMX ()
Ответ на: Ура красавчики! от ArtemDMX

На ubuntuforums рекомендуют wl.

а вообще установи пакеты linux-firmware и linux-firmware-nonfree, отключи аппаратно wi-fi, выгрузи модуль

sudo modprobe -r wl
и загрузи
sudo modprobe brcmsmac
если нормально работает добавь wl в блеклист, незнаю как у вас делается в убунтах, но точно делается

bhfq ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.